You are not logged in.

#1 2020-12-03 21:15:48

Annoyingduck
Member
Registered: 2016-08-02
Posts: 178

Lost the ability to automount NTFS drive using LABEL

After the recent updates, I cannot automount my NTFS drive which I have set to mount by Label. If I change it to the standard sdb method it works fine, however all of my syncing and everything I have setup on the label mount point fails to work...so this is not ideal. This is the case on 2 computers I've updated.

Here's my original fstab entry which has worked fine for the past 4 years and now no longer works:

LABEL=1TB\040Storage /mnt/1TB\040Storage auto nosuid,nodev,nofail,x-gvfs-show 0 0

However after the update, if I change it to something like this it automounts just fine at boot, but this is not what is ideal for me:

/dev/sdb1 /mnt/sdb1 auto nosuid,nodev,nofail,x-gvfs-show 0 0

I'd really like to find out what has changed and if I can get the automount to work using LABEL again, as I sync many folders to 5 other devices using Syncthing, and if I change the mount point, I'll have to redo every single sync folder.

Offline

#2 2020-12-03 21:29:57

loqs
Member
Registered: 2014-03-06
Posts: 13,005

Re: Lost the ability to automount NTFS drive using LABEL

Offline

#3 2020-12-03 21:38:57

Annoyingduck
Member
Registered: 2016-08-02
Posts: 178

Re: Lost the ability to automount NTFS drive using LABEL

Ahh, thanks. Good find. I'll leave this unsolved for a bit and see what happens down the road with this.

Offline

#4 2020-12-04 02:00:03

Annoyingduck
Member
Registered: 2016-08-02
Posts: 178

Re: Lost the ability to automount NTFS drive using LABEL

A little update, downgrading systemd from 247.1 to 246.6 fixes the issue for now until it's fixed upstream

Offline

#5 2020-12-05 10:32:28

xerxes_
Member
Registered: 2018-04-29
Posts: 343

Re: Lost the ability to automount NTFS drive using LABEL

Is this something related with this: https://github.com/systemd/systemd/blob/master/NEWS : CHANGES WITH 247: KERNEL API INCOMPATIBILITY: (...) ?

Offline

#6 2020-12-05 12:06:41

loqs
Member
Registered: 2014-03-06
Posts: 13,005

Re: Lost the ability to automount NTFS drive using LABEL

xerxes_ wrote:

Is this something related with this: https://github.com/systemd/systemd/blob/master/NEWS : CHANGES WITH 247: KERNEL API INCOMPATIBILITY: (...) ?

No.

Offline

Board footer

Powered by FluxBB