You are not logged in.

#1 2020-12-11 11:33:22

Registered: 2020-12-05
Posts: 25

[SOLVED] Internal microphone not working (MSI Prestige 14 Evo Tiger

I tried to get my internal mircophone working, but no luck so far. External microphone over 3.5 jack is working.

Sound is working after installing `sof-firmware`  and setting etc/modprobe.d/... conf file with `options snd-intel-dspcfg dsp_driver=1` and separatly (two different files) `blacklist snd_sof_pci`.

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC298 Analog [ALC298 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

After, I modified files according to

In hw:CARD,DEVICE notation, you would specify the above device as hw:0,0.

Then, edit /etc/pulse/ and insert a load-module line specifying your device as follows:

  load-module module-alsa-source device=hw:0,0
  # the line above should be somewhere before the line below

Finally, restart pulseaudio to apply the new settings:

  $ pulseaudio -k ; pulseaudio -D

( … Microphone)

Resulting in Error:

E: [pulseaudio] main.c: Daemon startup failed.

Then got in journalctl

pulseaudio[822]: Failed to load module "module-alsa-source" (argument: "device=hw:0,0"): initialization failed.
pulseaudio[4181]: Daemon already running.
pulseaudio[4181]: pa_pid_file_create() fehlgeschlagen.
pulseaudio[4236]: bind(): Address already in use
pulseaudio[4236]: Failed to load module "module-native-protocol->
pulseaudio[4237]: Daemon already running.
pulseaudio[4237]: pa_pid_file_create() fehlgeschlagen.
systemd[812]: Failed to start Sound Service.

So I guess I am on the wrong track.
I am loosing overview and would be very thankful for any hints how to proceed.

Last edited by bd (2020-12-11 14:21:25)


#2 2020-12-11 14:17:31

Registered: 2020-12-05
Posts: 25

Re: [SOLVED] Internal microphone not working (MSI Prestige 14 Evo Tiger

Okay, solved this finally.

I had to check my files in /etc/modprobe.d/ again.

Finally, with working setup it remains only one conf-file, with

blacklist snd_hda_intel


#3 2020-12-20 15:00:09

Registered: 2013-12-19
Posts: 9

Re: [SOLVED] Internal microphone not working (MSI Prestige 14 Evo Tiger

You fix it by updating the linux kernel to 5.10.1


Board footer

Powered by FluxBB