You are not logged in.

#1 2020-12-20 00:51:28

TheFurryWeeb
Member
Registered: 2020-08-06
Posts: 57

[ERROR] [SOLVED] I cannot install the latest Linux kernel from source

Basically, I wanted to practice how to compile the latest Linux kernel because Linux 5.11 is going to come with Syscall User Dispatch. (This function can make the Linux kernel capable of telling the difference between a Windows game written with DirectX APIs in mind and a Windows game that is using OpenGL or Vulkan. If the game runs on OpenGL or Vulkan, the kernel is going to treat those games as native Linux programs because they're requesting POSIX syscalls, unlike DirectX games, which they are requesting Windows NT syscalls. But with the DX games, this function is also going to optimise Wine for them, which is also very good. This is why I decided that I would like to learn how to compile the Linux kernel by myself; to get this new function as early as when Linus Torvalds blesses us with this new creation of his and Valve's.)

The warm-up with my Linux Mint VM was pretty good. I just downloaded the kernel sources into a specific compilation directory, installed the necessary dependencies, made a 100% optimised config file and ran this chain of commands:

make -j4 && sudo make modules_install -j4 && sudo make headers_install -j4 && sudo make install -j4

Then I regenerated the initramfs and the GRUB config file, rebooted the VM and it worked like a charm.



I cannot say the same thing with my daily driver machine running Arch Linux.

I copied the tar file over and edited the config file to make it fit for the needs of my bare metal, extracted it, followed the Arch Wiki for Arch-specific commands and ran the same make commands, but the compliler has just stopped at a random point, and for the second instance of running the make command chain, it has now spit out an error message saying this:

  ...
  CC      fs/direct-io.o
  CC      fs/mpage.o
  CC      fs/proc_namespace.o
  CC [M]  fs/f2fs/debug.o
  CC [M]  fs/f2fs/xattr.o
  CC      fs/eventpoll.o
  CC      fs/anon_inodes.o
  CC      fs/signalfd.o
  CC [M]  fs/f2fs/acl.o
  CC [M]  fs/f2fs/verity.o
  CC      fs/timerfd.o
  CC      fs/eventfd.o
  CC      fs/userfaultfd.o
  LD [M]  fs/f2fs/f2fs.o
  CC      fs/aio.o
  CC      fs/io_uring.o
  CC      fs/io-wq.o
  CC      fs/dax.o
  CC      fs/locks.o
  CC      fs/binfmt_script.o
  CC      fs/binfmt_elf.o
  CC      fs/compat_binfmt_elf.o
  CC      fs/mbcache.o
  CC      fs/posix_acl.o
  CC      fs/coredump.o
  CC      fs/drop_caches.o
  CC      fs/fhandle.o
  CC      fs/dcookies.o
  CC [M]  fs/binfmt_misc.o
  AR      fs/built-in.a
[ironicfur@IronicFur-PC linux-5.10.1]$ make -j4 && sudo make modules_install -j4 && sudo make headers_install -j4 && sudo make install -j4
  DESCEND  objtool
  CALL    scripts/atomic/check-atomics.sh
  CALL    scripts/checksyscalls.sh
  CHK     include/generated/compile.h
  CHK     kernel/kheaders_data.tar.xz
  GEN     kernel/kheaders_data.tar.xz
make[1]: *** [kernel/Makefile:146: kernel/kheaders_data.tar.xz] Error 127
make: *** [Makefile:1805: kernel] Error 2
make: *** Waiting for unfinished jobs....

It clearly says something about some kheaders file, but I don't know what Error 127 means. I tried to redo it with a clean build directory, without using the

make install -j4

command, but it still shows this error message.

What can I do with this (seemingly Arch-specific) issue?

Last edited by TheFurryWeeb (2020-12-20 12:11:27)


A computer and Linux nerd, an avid 2D platformer and RPG gamer and a furry combined into one person.

I hope I can help you out with your Arch issues and get myself helped out, as well.

Offline

#2 2020-12-20 00:53:02

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,414

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source

Just use the linux-mainline PKGBUILD in the AUR.

Offline

#3 2020-12-20 00:55:54

TheFurryWeeb
Member
Registered: 2020-08-06
Posts: 57

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source

Scimmia wrote:

Just use the linux-mainline PKGBUILD in the AUR.

Does it have a delay compared to when Linus releases a new version of the source code on kernel.org and on GitHub?


A computer and Linux nerd, an avid 2D platformer and RPG gamer and a furry combined into one person.

I hope I can help you out with your Arch issues and get myself helped out, as well.

Offline

#4 2020-12-20 01:05:53

loqs
Member
Registered: 2014-03-06
Posts: 13,173

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source

linux-mainline tracks the latest tag from of Linus's tree aka mainline.
What is the output on the Arch box of:

type -a cpio

Edit:
Also from the linux tree the output of:

stat kernel/gen_kheaders.sh

Last edited by loqs (2020-12-20 01:07:33)

Offline

#5 2020-12-20 01:09:04

TheFurryWeeb
Member
Registered: 2020-08-06
Posts: 57

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source

loqs wrote:

linux-mainline tracks the latest tag from of Linus's tree aka mainline.
What is the output on the Arch box of:

type -a cpio

Edit:
Also from the linux tree the output of:

stat kernel/gen_kheaders.sh
bash: type: cpio: Command not found

So I just installed the cpio package and I hope for the best.

Edit of the edit: This is the output of the

stat kernel/gen_kheaders.sh

command:

File: kernel/gen_kheaders.sh
    Size: 3239      	blocks: 8          IO-block: 4096   regular file
   Device: 803h/2051d	I-node: 405189      links: 1
Permissions: (0775/-rwxrwxr-x)  Uid: ( 1000/ironicfur)   Gid: ( 1000/ironicfur)
   Access: 2020-12-20 01:14:53.683972078 +0100
Modified: 2020-12-14 19:33:01.000000000 +0100
Changed: 2020-12-20 01:03:55.833002905 +0100
 Made: 2020-12-20 01:03:55.833002905 +0100

Last edited by TheFurryWeeb (2020-12-20 01:28:40)


A computer and Linux nerd, an avid 2D platformer and RPG gamer and a furry combined into one person.

I hope I can help you out with your Arch issues and get myself helped out, as well.

Offline

#6 2020-12-20 01:18:38

loqs
Member
Registered: 2014-03-06
Posts: 13,173

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source

Offline

#7 2020-12-20 01:29:18

TheFurryWeeb
Member
Registered: 2020-08-06
Posts: 57

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source

loqs wrote:

I corrected the issue in the previous post. Now it shows a proper log.


A computer and Linux nerd, an avid 2D platformer and RPG gamer and a furry combined into one person.

I hope I can help you out with your Arch issues and get myself helped out, as well.

Offline

#8 2020-12-20 02:12:05

TheFurryWeeb
Member
Registered: 2020-08-06
Posts: 57

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source

Ok, seems that only installing the cpio package was enough to solve this. Now this thread should be closed.


A computer and Linux nerd, an avid 2D platformer and RPG gamer and a furry combined into one person.

I hope I can help you out with your Arch issues and get myself helped out, as well.

Offline

#9 2020-12-20 11:31:03

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,239
Website

Re: [ERROR] [SOLVED] I cannot install the latest Linux kernel from source


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB