You are not logged in.

#1 2020-12-25 00:34:55

BrooklynOC
Member
Registered: 2020-10-14
Posts: 6

Problem with setting iommu groups AMD-Vi: Unable to read/write to IOMM

im trying to isolate my rx 5600xt for virtualization and when I ran dmesg | grep -i -e DMAR -e IOMMU this problem came up saying :
[    0.558489] pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
I have went into /etc/defualt/grub and changed GRUB_CMDLINE_LINUX_DEFAULT and typed in iommu=pt and the error still came up with the error then I typed it into the GRUB_CMDLINE line and it still didn't worked then I deleted iommu=pt in the GRUB_CMDLINE_LINUX_DEFAULT and the same error came up i changed the pt in iommu=pt to iommu=soft and it disabled it.
My specs are:
amd ryzen 5 3400g
amd rx 5600xt
asrock b450 pro4
klevv cras c710
klevv bolt x 8gb 3200MHz ram

Offline

#2 2020-12-28 13:46:57

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,786

Re: Problem with setting iommu groups AMD-Vi: Unable to read/write to IOMM

That motherboard has many released firmware versions[1] , which one are you using ?

remove the iommu parameters from command line and post full dmesg and/or journalctl -b output (run both as root).
Also lspci -knn .
Those logs are likely large, consider using a pastebin client[2] .

[1] https://www.asrock.com/MB/AMD/B450%20Pr … x.asp#BIOS
[2] https://wiki.archlinux.org/index.php/Li … in_clients


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) DOES NOT EQUAL  (A works at time C)

Offline

#3 2021-01-11 11:18:08

BrooklynOC
Member
Registered: 2020-10-14
Posts: 6

Re: Problem with setting iommu groups AMD-Vi: Unable to read/write to IOMM

im currently running BIOS version P4.20 and when i booted into arch linux on a usb to install it again after moving back to windows the error is still there

Offline

Board footer

Powered by FluxBB