You are not logged in.

#1 2020-12-27 16:47:08

kullfar
Member
Registered: 2013-04-22
Posts: 10

xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

Downgrading xfce4-panel (4.16.0-1 -> 4.14.4-1) is fixing the issue.

I have reported this to the qastools https://gitlab.com/sebholt/qastools/-/issues/2

But, maybe qastools is not the only one affected application.

Should we report to xfce4-panel or someone know the solution?

Last edited by kullfar (2020-12-27 17:25:08)

Offline

#2 2020-12-27 21:29:08

toz
Member
Registered: 2011-10-28
Posts: 442

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

Do you have the new Status Tray plugin added to the panel? It will display the qasmixer tray icon.

Online

#3 2020-12-28 00:45:35

WFV
Member
From: ☭USSA⛧⭒⭒⭒⭒
Registered: 2013-04-23
Posts: 275

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

@kullfar
Status Tray plugin core-dumps here (so TeamViewer no longer goes to tray) simply adding to panel, maybe config file needs corrected but haven't found one yet. Does it solve qastools for you?


"Wisdom is knowing I am Nothing." "Love is Knowing I am Everything." and in between the two, life moves.

Offline

#4 2020-12-28 01:24:08

toz
Member
Registered: 2011-10-28
Posts: 442

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

WFV wrote:

@kullfar
Does it solve qastools for you?

Yes. Installing qastools and running qasmixer makes it show up in my status tray plugin.

Online

#5 2020-12-28 07:19:04

kullfar
Member
Registered: 2013-04-22
Posts: 10

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

toz wrote:

Do you have the new Status Tray plugin added to the panel? It will display the qasmixer tray icon.

Sure, Status Tray plugin is automatically here. And the tray icon for qasmixer is on the place, but no notification balloon are shown. If I change the volume by the media-key on the keyboard, qasmixer is showing notification balloon (it looks like

notify-send --expire-time=4000 'Volume 35%'

does). But no such pop-up is shown now with the new xfce4-panel.

Offline

#6 2020-12-28 11:54:49

robson75
Member
From: Poland
Registered: 2020-06-28
Posts: 14

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

From what I noticed, the new Xfce4 panel does not display hints for applications based on gtk2, while those based on gtk3 work properly.


Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline

#7 2020-12-28 15:50:29

kullfar
Member
Registered: 2013-04-22
Posts: 10

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

robson75 wrote:

From what I noticed, the new Xfce4 panel does not display hints for applications based on gtk2, while those based on gtk3 work properly.

And qastools is based on qt5. Maybe that is the reason.

Offline

#8 2020-12-28 18:32:57

kullfar
Member
Registered: 2013-04-22
Posts: 10

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

FYI, I have reported to the xfce4-panel
https://gitlab.xfce.org/xfce/xfce4-panel/-/issues/381

Offline

#9 2021-01-09 09:54:39

kullfar
Member
Registered: 2013-04-22
Posts: 10

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

I did some investigations.
To make notification bubbles work you need either slow PC (such slow so xfce4-panel starts after qasmixer), either stop qasmixer and xfce4-panel, then start qasmixer and only then start xfce4-panel.

Steps to reproduce successfull scenario:
1. close qasmixer if open
2. execute "xfce4-panel -q" - this will close panel
3. execute "qasmixer -t" (actualy, "-t" option does not work as expected "start minimized in tray.")
4. execute "xfce4-panel"

5. Notifications do work. Bubbles are here.


Steps to reproduce error scenario:
1e. close qasmixer if open
2e. execute "xfce4-panel -q" - this will close panel
3e. execute "xfce4-panel" (that's it, before qasmixer)
4e. execute "qasmixer -t" ("-t" option do work as expected "start minimized in tray.")

5.Notifications does not work. Bubbles are NOT here. And in console, where we executed "xfce4-panel" we can see such error messages after executing "qasmixer -t" from the step 4e:

(wrapper-2.0:1345): Gtk-CRITICAL **: 12:34:37.138: gtk_widget_set_accel_path: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

(wrapper-2.0:1345): Gtk-CRITICAL **: 12:34:37.138: gtk_widget_add_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

(wrapper-2.0:1345): Gtk-CRITICAL **: 12:34:37.139: gtk_widget_set_accel_path: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

(wrapper-2.0:1345): Gtk-CRITICAL **: 12:34:37.139: gtk_widget_add_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed

There were no such error messages in successfull scenario.

All this make me think, that the problem is in the new xfce4-panel.

p.s. I'm thinking about some sort of workaround - start qasmixer not from XFCE Autostart list with trigger: "on login", but a bit earlier.

Offline

#10 2021-01-11 08:57:24

kullfar
Member
Registered: 2013-04-22
Posts: 10

Re: xfce4-panel (4.16.0-1) doesn't show qastools (0.23.0-1) notifications

UGLY WORKAROUND for the moment:
0. remove QasMixer from XFCE Autostart
1. add

/usr/bin/qasmixer -t &

to the ~/.xprofile
2. Since QasMixer will not start minimised to systray (no systray launched yet) we need to close opened QasMixer window.
We will use wmctrl to close the window, but we need WindowManager initialised, so we will sleep 1 sec before closing.
Add

sh -c "sleep 1; wmctrl -c QasMixer"

to XFCE autostart application list.

Offline

Board footer

Powered by FluxBB