You are not logged in.

#1 2020-12-27 16:55:23

LuizF
Member
Registered: 2020-12-27
Posts: 4

[SOLVED] Problem installing LTSpice with yay

HI, i'm trying to install LTSpice using yay, but it doesn't install. (https://aur.archlinux.org/packages/ltspice/)
The konsole outputs the following installation requests:
1)wine
2)lib32-sdl2
3)lib32-fon- tconfig
4)lib32-freetype2
5)lib32-openal
6)lib32-libgl
7)lib32-vkd3d
8)lib32-libpulse
9)lib32-mesa
10)lib32-krb5
11)mesa-git
12)lib32-harfbuzz
13)lib32-libglvnd
14)lib32-libx11
15)linux<5.2
16)lib32-llvm
17)lib32-curl
18)lib32-llvm-libs
19)lib32-gtk2

It gives me some repository options, i just use the default. It takes a long time to process between each request and than it returns a lot of errors.
Basically saying it couldn't find all the necessary packages.
What do i do? Do i have  to install something before it?
Thanks

Last edited by LuizF (2020-12-28 18:28:19)

Offline

#2 2020-12-27 17:03:01

loqs
Member
Registered: 2014-03-06
Posts: 12,556

Re: [SOLVED] Problem installing LTSpice with yay

Official_repositories#multilib.  Please post commands and their complete outputs in code tags.
As you are new to using AUR I suggect you stop using an AUR helper.  Please also avoid using a helper when posting to the forums as they are unsupported.

Offline

#3 2020-12-27 17:52:00

LuizF
Member
Registered: 2020-12-27
Posts: 4

Re: [SOLVED] Problem installing LTSpice with yay

loqs wrote:

Official_repositories#multilib.  Please post commands and their complete outputs in code tags.
As you are new to using AUR I suggect you stop using an AUR helper.  Please also avoid using a helper when posting to the forums as they are unsupported.

Will do, thanks.
Well, i've uncommented and updated the multilib, as it says, and now it gives me other error:

luizf@arch ltspice]$ ls
PKGBUILD  ltspice-help.sh  ltspice.sh
[luizf@arch ltspice]$ makepkg -si
==> Making package: ltspice 17.20201213.13-1 (Sun Dec 27 14:47:15 2020)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
warning: cannot resolve "libcap=2.46", a dependency of "lib32-libcap"
warning: cannot resolve "lib32-libcap", a dependency of "lib32-systemd"
warning: cannot resolve "lib32-systemd", a dependency of "lib32-dbus"
warning: cannot resolve "libdbus-1.so=3-32", a dependency of "lib32-libpcap"
warning: cannot resolve "lib32-libpcap", a dependency of "wine"
warning: cannot resolve "libcap=2.46", a dependency of "lib32-libcap"
warning: cannot resolve "lib32-libcap", a dependency of "lib32-systemd"
warning: cannot resolve "lib32-systemd", a dependency of "lib32-dbus"
warning: cannot resolve "lib32-dbus", a dependency of "lib32-faudio"
warning: cannot resolve "lib32-faudio", a dependency of "wine"
:: The following package cannot be upgraded due to unresolvable dependencies:
      wine

:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
 there is nothing to do
==> Missing dependencies:
  -> wine
==> Checking buildtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...

Packages (20) perl-clone-0.45-2  perl-encode-locale-1.05-7
              perl-file-listing-6.11-1  perl-html-parser-3.75-1
              perl-html-tagset-3.20-10  perl-http-cookies-6.09-1
              perl-http-daemon-6.06-2  perl-http-date-6.05-3
              perl-http-message-6.26-1  perl-http-negotiate-6.01-8
              perl-io-html-1.004-1  perl-libwww-6.50-1
              perl-lwp-mediatypes-6.02-8  perl-net-http-6.19-4
              perl-try-tiny-0.30-5  perl-uri-5.05-1
              perl-www-robotrules-6.02-8  cksfv-1.3.14-5  gendesk-1.0.6-1
              icoutils-0.32.3-3

Total Download Size:   3.25 MiB
Total Installed Size:  9.97 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 perl-encode-loca...    11.0 KiB  0.00   B/s 00:00 [################] 100%
 perl-http-date-6...     9.7 KiB  0.00   B/s 00:00 [################] 100%
 perl-file-listin...     9.5 KiB  1351 KiB/s 00:00 [################] 100%
 perl-html-tagset...    11.3 KiB  1134 KiB/s 00:00 [################] 100%
 perl-clone-0.45-...    10.4 KiB  2.55 MiB/s 00:00 [################] 100%
 perl-io-html-1.0...    14.8 KiB  0.00   B/s 00:00 [################] 100%
 perl-lwp-mediaty...    19.6 KiB  0.00   B/s 00:00 [################] 100%
 perl-uri-5.05-1-any    78.7 KiB  7.69 MiB/s 00:00 [################] 100%
 perl-http-messag...    75.8 KiB   261 KiB/s 00:00 [################] 100%
 perl-html-parser...    81.3 KiB  11.3 MiB/s 00:00 [################] 100%
 perl-http-cookie...    22.3 KiB  0.00   B/s 00:00 [################] 100%
 perl-http-daemon...    18.6 KiB  0.00   B/s 00:00 [################] 100%
 perl-http-negoti...    12.6 KiB  0.00   B/s 00:00 [################] 100%
 perl-net-http-6....    23.5 KiB  0.00   B/s 00:00 [################] 100%
 perl-try-tiny-0....    19.0 KiB  0.00   B/s 00:00 [################] 100%
 perl-www-robotru...    12.7 KiB  0.00   B/s 00:00 [################] 100%
 perl-libwww-6.50...   138.5 KiB  10.4 MiB/s 00:00 [################] 100%
 cksfv-1.3.14-5-x...    11.9 KiB  0.00   B/s 00:00 [################] 100%
 icoutils-0.32.3-...    53.6 KiB  13.1 MiB/s 00:00 [################] 100%
 gendesk-1.0.6-1-...     2.6 MiB  4.69 MiB/s 00:01 [################] 100%
(20/20) checking keys in keyring                   [################] 100%
(20/20) checking package integrity                 [################] 100%
(20/20) loading package files                      [################] 100%
(20/20) checking for file conflicts                [################] 100%
(20/20) checking available disk space              [################] 100%
:: Processing package changes...
( 1/20) installing cksfv                           [################] 100%
( 2/20) installing perl-encode-locale              [################] 100%
( 3/20) installing perl-http-date                  [################] 100%
( 4/20) installing perl-file-listing               [################] 100%
( 5/20) installing perl-html-tagset                [################] 100%
( 6/20) installing perl-clone                      [################] 100%
( 7/20) installing perl-io-html                    [################] 100%
( 8/20) installing perl-lwp-mediatypes             [################] 100%
( 9/20) installing perl-uri                        [################] 100%
(10/20) installing perl-http-message               [################] 100%
(11/20) installing perl-html-parser                [################] 100%
(12/20) installing perl-http-cookies               [################] 100%
(13/20) installing perl-http-daemon                [################] 100%
(14/20) installing perl-http-negotiate             [################] 100%
(15/20) installing perl-net-http                   [################] 100%
(16/20) installing perl-try-tiny                   [################] 100%
(17/20) installing perl-www-robotrules             [################] 100%
(18/20) installing perl-libwww                     [################] 100%
Optional dependencies for perl-libwww
    perl-lwp-protocol-https: for https:// url schemes
(19/20) installing icoutils                        [################] 100%
(20/20) installing gendesk                         [################] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Warn about old perl modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB:pt_BR",
        LC_ALL = (unset),
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
==> ERROR: Could not resolve all dependencies.

What do i do now?

Last edited by LuizF (2020-12-27 17:53:06)

Offline

#4 2020-12-27 17:56:13

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,068

Re: [SOLVED] Problem installing LTSpice with yay

LuizF wrote:

Well, i've uncommented and updated the multilib, as it says

I don't believe that you have. Please post the contents of your pacman.conf.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#5 2020-12-27 18:06:32

loqs
Member
Registered: 2014-03-06
Posts: 12,556

Re: [SOLVED] Problem installing LTSpice with yay

warning: cannot resolve "libcap=2.46", a dependency of "lib32-libcap"

You enabled multilib-testing along with multilib but not testing?
Edit:
I suggest you comment multilib-testing out again.

Last edited by loqs (2020-12-27 18:07:14)

Offline

#6 2020-12-27 20:49:57

LuizF
Member
Registered: 2020-12-27
Posts: 4

Re: [SOLVED] Problem installing LTSpice with yay

loqs wrote:
warning: cannot resolve "libcap=2.46", a dependency of "lib32-libcap"

You enabled multilib-testing along with multilib but not testing?
Edit:
I suggest you comment multilib-testing out again.

Yes, i uncommented multilib-testing, did it wrong, thank you!

Now it downloaded perfectly.

I'm sorry, just another question: i'm new to arch linux,

Why have i had to uncomment those libs? I've downloaded everything i needed already, but only this program required this.

Besides, everything i've downloaded got the packages required automatic. why did i have to get those packages?

Besides, why shouldn't i use aur helpers?

Thanks

Last edited by LuizF (2020-12-27 20:51:40)

Offline

#7 2020-12-27 21:02:35

loqs
Member
Registered: 2014-03-06
Posts: 12,556

Re: [SOLVED] Problem installing LTSpice with yay

Packages in the default set of enabled repositories (core,  extra and community) only have dependencies in those repositories.  AUR PKGBUILDs can depend on anything from any repository and packages that exist in no repository.
AUR helpers automation can confuse users about if a package is from a repository or built from AUR,  they do not teach users how to spot issues in a PKGBUILD and resolve them.  They also frequently introduce issues.

Offline

#8 2020-12-27 21:07:42

LuizF
Member
Registered: 2020-12-27
Posts: 4

Re: [SOLVED] Problem installing LTSpice with yay

loqs wrote:

Packages in the default set of enabled repositories (core,  extra and community) only have dependencies in those repositories.  AUR PKGBUILDs can depend on anything from any repository and packages that exist in no repository.
AUR helpers automation can confuse users about if a package is from a repository or built from AUR,  they do not teach users how to spot issues in a PKGBUILD and resolve them.  They also frequently introduce issues.

Ok, got it.

Thank you very much

Offline

#9 2020-12-27 23:16:08

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,501

Re: [SOLVED] Problem installing LTSpice with yay

Please remember to mark your thread [SOLVED] (edit the title of your first post).


"The prettier the user interface, and the fewer odd replies the system allows you to make, the dumber you once appeared in the mind of the designer." -- Ellen Ullman
-----
How to post

Offline

Board footer

Powered by FluxBB