You are not logged in.

#1 2020-12-28 13:42:18

MachineLearninja
Member
Registered: 2020-12-28
Posts: 3

Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2)

Hello guys, i am relatively new to Arch and after an Update some programms(VLC and Anki) are not running anymore. In both i get the error "Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2)". Is there a way to solve this problem without downgrading qt, since i don't know if other programs depend on the newer version.

Offline

#2 2020-12-28 13:48:13

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,197

Re: Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2)

Check any unofficial (AUR or other) packages you have installed, they may need rebuilt. Especially themes.

Offline

#3 2020-12-28 13:55:29

MachineLearninja
Member
Registered: 2020-12-28
Posts: 3

Re: Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2)

As far as i know the only aur packages i've installed are android studio and ungoogled-chromium. I've rebuilt ungoogled-chromium already a few days ago and updated android studio. But it's not working. VLC and Anki are from the official repo since i've installed them with pacman.

Edit: with pacman -Qm i've found out that i've installed qt5-styleplugins from AUR. i rebuilt it and now everything is working fine.

Last edited by MachineLearninja (2020-12-28 13:59:09)

Offline

#4 2020-12-28 13:57:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,800

Re: Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2)

Are you sure?

pacman -Qm

what's particularly often of interest here is qt5-styleplugins or so, which QT5 theme are you using.

Offline

#5 2020-12-28 14:00:56

MachineLearninja
Member
Registered: 2020-12-28
Posts: 3

Re: Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2)

V1del wrote:

Are you sure?

pacman -Qm

what's particularly often of interest here is qt5-styleplugins or so, which QT5 theme are you using.

Yeah i did it 5 minutes ago, and it was qt5-styleplugins. I really don't know when i installed it, but after rebuilding it everything works fine know!

Offline

#6 2020-12-28 14:19:51

progandy
Member
Registered: 2012-05-17
Posts: 4,020

Re: Cannot mix incompatible Qt library (5.15.0) with this library (5.15.2)

qt5-styleplugins was a community package until it was dropped in may:
https://lists.archlinux.org/pipermail/a … 29986.html

Last edited by progandy (2020-12-28 14:20:59)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

Board footer

Powered by FluxBB