You are not logged in.

#1 2021-01-01 16:51:32

salonkommunist
Member
From: Germany
Registered: 2020-02-18
Posts: 29

[SOLVED] Humming sound since latest kernel update

Since the latest kernel update to 5.10.3-arch1-1, there is a humming sound (much like a ground loop) coming from my speakers when there is no playback. I am not sure whether the kernel update is related, but I have made no other changes since the issue started.

If any sound is played, the hum will cease immediately, but will continue a few seconds after playback has stopped.

How do I revert to the previous behaviour, i.e. prevent the hum?

Last edited by salonkommunist (2021-01-02 00:46:51)

Offline

#2 2021-01-01 17:12:14

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,648

Re: [SOLVED] Humming sound since latest kernel update

Is there an open microphone?  Try muting all input devices.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2021-01-01 17:23:01

salonkommunist
Member
From: Germany
Registered: 2020-02-18
Posts: 29

Re: [SOLVED] Humming sound since latest kernel update

Done, but to no effect.

Might this be related to some power saving mode as described here? https://www.kernel.org/doc/html/latest/ … rsave.html

There are, however a lot of items named /sys/modules/snd_* ; which do I edit?

Offline

#4 2021-01-02 00:46:28

salonkommunist
Member
From: Germany
Registered: 2020-02-18
Posts: 29

Re: [SOLVED] Humming sound since latest kernel update

Fixed by changing the value inside /sys/module/snd_hda_intel/parameters/power_save to 0.

Offline

#5 2021-01-03 19:20:25

Jackseller
Member
Registered: 2020-08-03
Posts: 1

Re: [SOLVED] Humming sound since latest kernel update

I have the same kind of problem since kernel 5.10.
It's like a "fade in sound" for two seconds.

salonkommunist wrote:

Fixed by changing the value inside /sys/module/snd_hda_intel/parameters/power_save to 0.

This solution only works until you reboot your system.

For a permanent fix, create a new .conf file :

/etc/modprobe.d/audio_disable_powersave.conf

Add the following settings in the file :

options snd_hda_intel power_save=0

Then reboot your system.

Offline

Board footer

Powered by FluxBB