You are not logged in.

#1 2021-01-04 18:07:22

lazaro92
Member
Registered: 2021-01-04
Posts: 6

First attempt to install Arch Linux Failed

Hi, I'm stuck with the Arch Linux installation in a VM in VirtualBox. The command "arch-chroot /mnt" fails with the message "chroot: failed to run command /bin/bash/: No such file or directory".

PC ASPECTS:
- It uses BIOS, not UEFI.
- 8GB of RAM (4 for the Virtual machine).
- 10GB for the virtual disk (the disk is HDD not SDD).

STEPS (the same as the Installation guide in the Wiki):

1. Keyboard layout: I put it as Spanish  (I use Spanish keyboard).
2. Verify the boot mode: it does not found anything, so it's BIOS (also I know it is BIOS).
3. Verify internet connection: yes, I can ping google.com or archlinux.org.
4. Update system-clock: Ok, I see that it also updates the Pacman mirror list.
5. Partition disk (I use cfdisk):
   5.1. I format the disk as "dos" (It is an HDD of 1TB, in the VM I only assigned 10GB).
   5.2. I create a partition of 8GB | primary | bootable | type: Linux -> /dev/sda1.
   5.3. I create a SWAP partition of 2GB | primary | type: Linux Swap / Solaris -> /dev/sda2.
6. Format the partitions:
   6.1. mkfs.ext4 /dev/sda1
   6.2. mkswap   /dev/sda2
7. Mount the filesystem:
   7.1 mount /dev/sda1 /mnt
   7.2 swapon /dev/sda2
8. Installation:
   8.1. Select mirrors: for the moment I am skipping this step - Is it necessary if it is updated in step 4?.
   8.2. Install essential packages: I run "pacstrap /mnt base linux linux-firmware".
   8.3. Generate fstab file: I run "genfstab -U /mnt >> /mnt/etc/fstab". The generated file seems fine.
   8.4. CHROOT: arch-chroot /mnt - THIS STEP FAILS

I think that the problem is related to step 8.2, for what I have seen on the internet. But I'm not sure. The contents of /mnt are:
- dev
- etc
- lost+found
- proc
- run
- sys
- tmp
- var

What is the problem? I'm failing in some step?

UPDATE:
I have another question. I have turned off the Virtual Machine. I imagine that, when I continue with the installation process, I don't have to repeat the partitions, their formatting and the mount steps.

Last edited by lazaro92 (2021-01-04 18:16:02)

Offline

#2 2021-01-04 21:12:48

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,624
Website

Re: First attempt to install Arch Linux Failed

lazaro92 wrote:

What is the problem? I'm failing in some step?

Your steps look fine but the installed filesystem is incomplete. Where there any errors during the pacstrap stage?

You could try again while recording the output then upload that to a pastebin if it doesn't work:

# pacstrap /mnt base linux{,-firmware} > pacstrap.log 2>&1
curl -F 'f:1=<-' ix.io < pacstrap.log

The second command will return a URL that you can post here if necessary.

lazaro92 wrote:

I have turned off the Virtual Machine. I imagine that, when I continue with the installation process, I don't have to repeat the partitions, their formatting and the mount steps.

You don't have to re-create the partitions or re-format them but you will have to mount them all properly again before re-running the pacstrap command.

Offline

#3 2021-01-05 16:58:07

lazaro92
Member
Registered: 2021-01-04
Posts: 6

Re: First attempt to install Arch Linux Failed

I have done all the process again, and I have done screen captures (I don't know how to pass files from VirtualBox to my host machine):

Screen capture

It seems that it throws a Segmentation fault: I will investigate it.

EDIT: the ISO file that I downloaded is the Torrent for 2021.01.01, from the Download section.

For what I have found, it could be a problem of VirtualBox, the only configurations I have done are:
- Set a RAM of 4096MB (yes, I incremented 1GB).
- Set a new HDD of 20GB (18 for the main partition and 2 for SWAP).
- Increase the number of processors to 2 CPUs.
- Add the archLinux ISO as a CD.

Last edited by lazaro92 (2021-01-05 17:38:16)

Offline

#4 2021-01-05 18:04:10

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,624
Website

Re: First attempt to install Arch Linux Failed

Have you seen https://bbs.archlinux.org/viewtopic.php?id=262218? Compare the VM log to see if you are both experiencing the same issue and if you are then try the suggestions from that thread and perhaps also use the "report" button on your OP to request a thread merge.

Sorry but I don't know about VB myself, it is the worst virualisation platform around so I would never use it.

lazaro92 wrote:

I don't know how to pass files from VirtualBox to my host machine

You don't have to transfer any files, just use the command I listed above to upload any files to a pastebin.

Offline

#5 2021-01-06 02:15:03

jonno2002
Member
Registered: 2016-11-21
Posts: 141

Re: First attempt to install Arch Linux Failed

did you run pacman -Sy to update the pacman database before pacstrap'ing, looks like its trying to download older packages and not being able to find them.

i have virtualbox installed so i downloaded the latest arch iso and did a quick install to make sure everything was working and aside from a few typos i made everything went fine, working arch system in about 10-15 mins in virtualbox 6.1.16-3

even copied the downloaded packages out of the VM into my own pacman cache to save mirror bandwidth when i upgrade my system

Offline

#6 2021-01-06 02:23:20

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,068

Re: First attempt to install Arch Linux Failed

jonno2002 wrote:

did you run pacman -Sy to update the pacman database before pacstrap'ing, looks like its trying to download older packages and not being able to find them.

This is never required, the pacstrap script takes care of this for you.
This smells like the classic VirtualBox/Hyper-V/Arch maths bug to me...
https://bbs.archlinux.org/viewtopic.php?id=253809


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#7 2021-01-06 02:35:33

jonno2002
Member
Registered: 2016-11-21
Posts: 141

Re: First attempt to install Arch Linux Failed

good point i dont ever remember doing that when i last installed arch a looooong time ago, seemed to work fine for me today though, no harm done.

so the problem hes facing is cause of VB running on windows ? that could be the difference as all my machines run arch so i cant test that theory.

Offline

#8 2021-01-06 11:32:43

lazaro92
Member
Registered: 2021-01-04
Posts: 6

Re: First attempt to install Arch Linux Failed

I have updated virtualBox (I had installed version 5, now I have 6.1). The output of the command is here -> Output.

It thrown a segmentation fault error in the reflector step (updating the mirrors) -> Capture

My host machine is a Ubuntu and the hardware is:

- Notebook Model : HP Pavilion dv6 Notebook PC
- Product Number : A2X65EA#ABE
- Serial Number : 5CH1230N4Q
- Warranty Start Date : 08/12/2011
- System Board ID : 3388
- Product Configuration ID : 058F110000244610000620100
- System Board CT Number : PBZAU04HT1A8WU
- BIOS Version : F.17
- Processor Type : Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
- Processor Speed : 2000 MHz
- Total Memory : 8 GB
- Primary Battery SN : 07066 07/10/2011
- WLAN FCC ID : QDS-BRCM1050

Also if it is a problem of VirtualBox, which other program can I use?

Last edited by lazaro92 (2021-01-06 11:39:39)

Offline

#9 2021-01-06 12:22:40

jonno2002
Member
Registered: 2016-11-21
Posts: 141

Re: First attempt to install Arch Linux Failed

this is the problem:

error: failed retrieving file 'linux-5.10.4.arch2-1-x86_64.pkg.tar.zst' from mirror.osbeck.com : OpenSSL SSL_read: error:1408F119:SSL routines:ssl3_get_record:decryption failed or bad record mac, errno 0
downloading linux-5.10.4.arch2-1-x86_64.pkg.tar.zst...
error: failed retrieving file 'linux-5.10.4.arch2-1-x86_64.pkg.tar.zst' from mirror.mikrogravitation.org : OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 0
downloading linux-5.10.4.arch2-1-x86_64.pkg.tar.zst...
error: failed retrieving file 'linux-5.10.4.arch2-1-x86_64.pkg.tar.zst' from mirrors.niyawe.de : OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 0
error: failed retrieving file 'linux-5.10.4.arch2-1-x86_64.pkg.tar.zst' from mirror.fra10.de.leaseweb.net : OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 0
downloading linux-5.10.4.arch2-1-x86_64.pkg.tar.zst...
downloading linux-firmware-20201218.646f159-1-any.pkg.tar.zst...
error: failed retrieving file 'linux-firmware-20201218.646f159-1-any.pkg.tar.zst' from mirror.osbeck.com : OpenSSL SSL_read: error:1408F119:SSL routines:ssl3_get_record:decryption failed or bad record mac, errno 0

openssl read errors, i just tried connecting to those mirrors from the arch iso inside virtualbox and have no problems, maybe check your network config in virtualbox, also date and time can cause ssl errors too so make sure all date and times are correct on host and virtual systems. other than that i have no idea

Last edited by jonno2002 (2021-01-06 12:23:40)

Offline

#10 2021-01-07 17:37:11

lazaro92
Member
Registered: 2021-01-04
Posts: 6

Re: First attempt to install Arch Linux Failed

I have set the timezone 0n the timedatectl command.

But it fails again (although it seems that is downloading more packages).

Capture.

Offline

#11 2021-01-07 18:37:46

lazaro92
Member
Registered: 2021-01-04
Posts: 6

Re: First attempt to install Arch Linux Failed

I don't know what I have done, but it works! I see all folders when I do ls /mnt. I close this thread.

Offline

#12 2021-01-08 10:25:47

lazaro92
Member
Registered: 2021-01-04
Posts: 6

Re: First attempt to install Arch Linux Failed

I installed it! -> https://imgur.com/a/ndd4fQR

Thanks a lot for the help smile

Offline

Board footer

Powered by FluxBB