You are not logged in.

#1 2021-01-06 17:25:18

snap.ve
Member
Registered: 2020-04-02
Posts: 76

[SOLVED] idevicebackup2 isn't work

Hi there! After update iOS on version 14 and higher, idevicebackup2 isn't work. When i write command for backup my device like:

idevicebackup2 -u heremyid -d backup --full /here/my/path

I've got message in console: Could not perform backup protocol version exchange, error code -1
I was try to find with google same error, and that looks like problem is actual on device higher then iOS 13
What do you advise? I really need this utility. Maybe there is a decent replacement for the console backup utility?

Last edited by snap.ve (2021-01-07 18:24:08)

Offline

#2 2021-01-06 17:34:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,800

Re: [SOLVED] idevicebackup2 isn't work

Apple actively breaks compatibility with alternate access implementations every new major version.

Your best bet is trying a -git variant of libimobiledevice, see e.g.: https://github.com/libimobiledevice/lib … ssues/1028

Last edited by V1del (2021-01-06 19:02:07)

Offline

#3 2021-01-06 18:31:45

snap.ve
Member
Registered: 2020-04-02
Posts: 76

Re: [SOLVED] idevicebackup2 isn't work

V1del wrote:

Apple actively breaks compatibility with alternate access implementations every new major version.

Your best bet is trying a -git variant of libimobiledevice, see e.g.:https://github.com/libimobiledevice/libimobiledevice/issues/1028

Oh thank you. Just need to wait for the maintainers to update the package in the official repository.

Offline

#4 2021-01-06 18:37:50

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,069

Re: [SOLVED] idevicebackup2 isn't work

There is nothing for the maintainers to update yet.

If you want to run the latest code now then just install the -git version in the AUR.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#5 2021-01-07 17:11:48

snap.ve
Member
Registered: 2020-04-02
Posts: 76

Re: [SOLVED] idevicebackup2 isn't work

Slithery wrote:

There is nothing for the maintainers to update yet.

If you want to run the latest code now then just install the -git version in the AUR.

The AUR version is older than the build version in the official repository ( Last Updated AUR 2020-05-26 vs Pacman Build Date: Thu 12 Nov 2020) I guess the latest fixes on github did not fix the situation, because they said that in comment section bellow and that's sad

Upd: compile git version with make util will crashes with errors...

Last edited by snap.ve (2021-01-07 17:18:01)

Offline

#6 2021-01-07 17:21:47

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,069

Re: [SOLVED] idevicebackup2 isn't work

snap.ve wrote:

The AUR version is older than the build version in the official repository

No, it isn't. It will always build from git master.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#7 2021-01-07 17:24:37

loqs
Member
Registered: 2014-03-06
Posts: 12,569

Re: [SOLVED] idevicebackup2 isn't work

snap.ve wrote:

Upd: compile git version with make util will crashes with errors...

If you post the output of makepkg others might be able to help resolve the build failure.
Edit:
Or do you mean the package builds and installs correctly but the installed package crashes with errors?

Last edited by loqs (2021-01-07 17:25:52)

Offline

#8 2021-01-07 17:58:59

snap.ve
Member
Registered: 2020-04-02
Posts: 76

Re: [SOLVED] idevicebackup2 isn't work

Slithery wrote:
snap.ve wrote:

The AUR version is older than the build version in the official repository

No, it isn't. It will always build from git master.

Let me apologize, maybe I just don't understand something. But how then to perceive the lines - last update in AUR, and build date in Pacman? https://imgur.com/a/xHcC9Jy

Offline

#9 2021-01-07 18:05:44

snap.ve
Member
Registered: 2020-04-02
Posts: 76

Re: [SOLVED] idevicebackup2 isn't work

loqs wrote:
snap.ve wrote:

Upd: compile git version with make util will crashes with errors...

If you post the output of makepkg others might be able to help resolve the build failure.
Edit:
Or do you mean the package builds and installs correctly but the installed package crashes with errors?

No, the problem was with compile git, here the command line with errors:

[admin@system ~]$ cd /tmp
[admin@system tmp]$ git clone https://github.com/libimobiledevice/libimobiledevice.git
Cloning into 'libimobiledevice'...
remote: Enumerating objects: 54, done.
remote: Counting objects: 100% (54/54), done.
remote: Compressing objects: 100% (37/37), done.
remote: Total 9314 (delta 24), reused 36 (delta 17), pack-reused 9260
Receiving objects: 100% (9314/9314), 2.89 MiB | 4.83 MiB/s, done.
Resolving deltas: 100% (6587/6587), done.
[admin@system tmp]$ cd libimobiledevice/
[admin@system libimobiledevice]$ ./autogen.sh
libtoolize: putting auxiliary files in '.'.
libtoolize: linking file './ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: linking file 'm4/libtool.m4'
libtoolize: linking file 'm4/ltoptions.m4'
libtoolize: linking file 'm4/ltsugar.m4'
libtoolize: linking file 'm4/ltversion.m4'
libtoolize: linking file 'm4/lt~obsolete.m4'
configure.ac:32: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
configure.ac:32: You should run autoupdate.
m4/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:32: the top level
configure.ac:39: warning: The macro `AC_HEADER_STDC' is obsolete.
configure.ac:39: You should run autoupdate.
./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
configure.ac:39: the top level
configure.ac:78: warning: $as_echo is obsolete; use AS_ECHO(["message"]) instead
lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from...
lib/m4sugar/m4sh.m4:699: AS_IF is expanded from...
./lib/autoconf/general.m4:2248: AC_CACHE_VAL is expanded from...
./lib/autoconf/general.m4:2269: AC_CACHE_CHECK is expanded from...
m4/ax_pthread.m4:88: AX_PTHREAD is expanded from...
configure.ac:78: the top level
configure.ac:95: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:95: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:14: AS_COMPILER_FLAG is expanded from...
/usr/share/aclocal-1.16/python.m4:35: AM_PATH_PYTHON is expanded from...
configure.ac:95: the top level
configure.ac:182: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:182: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:37: AS_COMPILER_FLAGS is expanded from...
configure.ac:182: the top level
configure.ac:195: warning: AC_OUTPUT should be used without arguments.
configure.ac:195: You should run autoupdate.
configure.ac:32: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
configure.ac:32: You should run autoupdate.
m4/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:32: the top level
configure.ac:39: warning: The macro `AC_HEADER_STDC' is obsolete.
configure.ac:39: You should run autoupdate.
./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
configure.ac:39: the top level
configure.ac:78: warning: $as_echo is obsolete; use AS_ECHO(["message"]) instead
lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from...
lib/m4sugar/m4sh.m4:699: AS_IF is expanded from...
./lib/autoconf/general.m4:2248: AC_CACHE_VAL is expanded from...
./lib/autoconf/general.m4:2269: AC_CACHE_CHECK is expanded from...
m4/ax_pthread.m4:88: AX_PTHREAD is expanded from...
configure.ac:78: the top level
configure.ac:95: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:95: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:14: AS_COMPILER_FLAG is expanded from...
/usr/share/aclocal-1.16/python.m4:35: AM_PATH_PYTHON is expanded from...
configure.ac:95: the top level
configure.ac:182: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:182: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:37: AS_COMPILER_FLAGS is expanded from...
configure.ac:182: the top level
configure.ac:195: warning: AC_OUTPUT should be used without arguments.
configure.ac:195: You should run autoupdate.
configure.ac:32: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
configure.ac:32: You should run autoupdate.
m4/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:32: the top level
configure.ac:39: warning: The macro `AC_HEADER_STDC' is obsolete.
configure.ac:39: You should run autoupdate.
./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
configure.ac:39: the top level
configure.ac:78: warning: $as_echo is obsolete; use AS_ECHO(["message"]) instead
lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from...
lib/m4sugar/m4sh.m4:699: AS_IF is expanded from...
./lib/autoconf/general.m4:2248: AC_CACHE_VAL is expanded from...
./lib/autoconf/general.m4:2269: AC_CACHE_CHECK is expanded from...
m4/ax_pthread.m4:88: AX_PTHREAD is expanded from...
configure.ac:78: the top level
configure.ac:95: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:95: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:14: AS_COMPILER_FLAG is expanded from...
aclocal.m4:1173: AM_PATH_PYTHON is expanded from...
configure.ac:95: the top level
configure.ac:182: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:182: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:37: AS_COMPILER_FLAGS is expanded from...
configure.ac:182: the top level
configure.ac:195: warning: AC_OUTPUT should be used without arguments.
configure.ac:195: You should run autoupdate.
configure.ac:29: installing './compile'
configure.ac:32: installing './config.guess'
configure.ac:32: installing './config.sub'
configure.ac:6: installing './install-sh'
configure.ac:6: installing './missing'
common/Makefile.am: installing './depcomp'
configure.ac:32: warning: The macro `AC_PROG_LIBTOOL' is obsolete.
configure.ac:32: You should run autoupdate.
m4/libtool.m4:99: AC_PROG_LIBTOOL is expanded from...
configure.ac:32: the top level
configure.ac:39: warning: The macro `AC_HEADER_STDC' is obsolete.
configure.ac:39: You should run autoupdate.
./lib/autoconf/headers.m4:704: AC_HEADER_STDC is expanded from...
configure.ac:39: the top level
configure.ac:78: warning: $as_echo is obsolete; use AS_ECHO(["message"]) instead
lib/m4sugar/m4sh.m4:692: _AS_IF_ELSE is expanded from...
lib/m4sugar/m4sh.m4:699: AS_IF is expanded from...
./lib/autoconf/general.m4:2248: AC_CACHE_VAL is expanded from...
./lib/autoconf/general.m4:2269: AC_CACHE_CHECK is expanded from...
m4/ax_pthread.m4:88: AX_PTHREAD is expanded from...
configure.ac:78: the top level
configure.ac:95: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:95: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:14: AS_COMPILER_FLAG is expanded from...
aclocal.m4:1173: AM_PATH_PYTHON is expanded from...
configure.ac:95: the top level
configure.ac:182: warning: The macro `AC_TRY_COMPILE' is obsolete.
configure.ac:182: You should run autoupdate.
./lib/autoconf/general.m4:2846: AC_TRY_COMPILE is expanded from...
m4/as-compiler-flag.m4:37: AS_COMPILER_FLAGS is expanded from...
configure.ac:182: the top level
configure.ac:195: warning: AC_OUTPUT should be used without arguments.
configure.ac:195: You should run autoupdate.
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a race-free mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether the compiler supports GNU C... yes
checking whether gcc accepts -g... yes
checking for gcc option to enable C11 features... none needed
checking whether gcc understands -c and -o together... yes
checking whether make supports the include directive... yes (GNU style)
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether the compiler supports GNU C++... yes
checking whether g++ accepts -g... yes
checking for g++ option to enable C++11 features... none needed
checking dependency style of g++... gcc3
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking how to print strings... printf
checking for a sed that does not truncate output... /usr/bin/sed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking how to convert x86_64-pc-linux-gnu file names to x86_64-pc-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for a working dd... /usr/bin/dd
checking how to truncate binary pipes... /usr/bin/dd bs=4096 count=1
checking for mt... no
checking if : is a manifest tool... no
checking for stdio.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for strings.h... yes
checking for sys/stat.h... yes
checking for sys/types.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking how to run the C++ preprocessor... g++ -E
checking for ld used by g++... /usr/bin/ld -m elf_x86_64
checking if the linker (/usr/bin/ld -m elf_x86_64) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC -DPIC
checking if g++ PIC flag -fPIC -DPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking if g++ supports -c -o file.o... (cached) yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libusbmuxd... yes
checking for libplist... yes
checking for egrep... (cached) /usr/bin/grep -E
checking for stdint.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for gcrypt.h... yes
checking for an ANSI C-conforming const... yes
checking for size_t... yes
checking for ssize_t... yes
checking for uint16_t... yes
checking for uint32_t... yes
checking for uint8_t... yes
checking for asprintf... yes
checking for strcasecmp... yes
checking for strdup... yes
checking for strerror... yes
checking for strndup... yes
checking for stpcpy... yes
checking for vasprintf... yes
checking for getifaddrs... yes
checking for endian.h... yes
checking for platform-specific build settings... linux-gnu
checking how to run the C preprocessor... gcc -E
checking whether gcc is Clang... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking whether more special flags are required for pthreads... no
checking for PTHREAD_PRIO_INHERIT... yes
checking for pthread_once in -lpthread... yes
checking for struct dirent.d_type... yes
checking for cython... no
configure: WARNING: Unable to find 'cython' program. You should look at http://www.cython.org or install your distribution specific cython package.
configure: WARNING: Use the "--without-cython" option to avoid this warning.
checking for openssl... yes
checking for supported compiler flags...  -Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -fsigned-char -fvisibility=hidden
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking whether make supports nested variables... (cached) yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating common/Makefile
config.status: creating src/Makefile
config.status: creating src/libimobiledevice-1.0.pc
config.status: creating include/Makefile
config.status: creating tools/Makefile
config.status: creating cython/Makefile
config.status: creating docs/Makefile
config.status: creating doxygen.cfg
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands

Configuration for libimobiledevice 1.3.1:
-------------------------------------------

  Install prefix: .........: /usr/local
  Debug code ..............: no
  Python bindings .........: no
  SSL support backend .....: OpenSSL

  Now type 'make' to build libimobiledevice 1.3.1,
  and then 'make install' for installation.

[admin@system libimobiledevice]$ make
make  all-recursive
make[1]: Entering directory '/tmp/libimobiledevice'
Making all in common
make[2]: Entering directory '/tmp/libimobiledevice/common'
  CC       socket.lo
  CC       thread.lo
  CC       debug.lo
  CC       userpref.lo
  CC       utils.lo
  CCLD     libinternalcommon.la
make[2]: Leaving directory '/tmp/libimobiledevice/common'
Making all in src
make[2]: Entering directory '/tmp/libimobiledevice/src'
  CC       idevice.lo
  CC       service.lo
  CC       property_list_service.lo
  CC       device_link_service.lo
  CC       lockdown.lo
  CC       afc.lo
afc.c: In function ‘afc_make_link’:
afc.c:1012:11: warning: unused variable ‘type’ [-Wunused-variable]
 1012 |  uint64_t type = htole64(linktype);
      |           ^~~~
  CC       file_relay.lo
  CC       notification_proxy.lo
  CC       installation_proxy.lo
  CC       sbservices.lo
  CC       mobile_image_mounter.lo
  CC       screenshotr.lo
  CC       mobilesync.lo
  CC       mobilebackup.lo
  CC       house_arrest.lo
  CC       mobilebackup2.lo
  CC       misagent.lo
  CC       restore.lo
  CC       diagnostics_relay.lo
  CC       heartbeat.lo
  CC       debugserver.lo
  CC       webinspector.lo
  CC       mobileactivation.lo
  CC       preboard.lo
  CC       companion_proxy.lo
  CC       syslog_relay.lo
  CCLD     libimobiledevice-1.0.la
make[2]: Leaving directory '/tmp/libimobiledevice/src'
Making all in include
make[2]: Entering directory '/tmp/libimobiledevice/include'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/tmp/libimobiledevice/include'
Making all in tools
make[2]: Entering directory '/tmp/libimobiledevice/tools'
  CC       idevice_id-idevice_id.o
  CCLD     idevice_id
  CC       ideviceinfo-ideviceinfo.o
  CCLD     ideviceinfo
  CC       idevicename-idevicename.o
  CCLD     idevicename
  CC       idevicepair-idevicepair.o
  CCLD     idevicepair
  CC       idevicesyslog-idevicesyslog.o
  CCLD     idevicesyslog
  CC       ideviceimagemounter-ideviceimagemounter.o
  CCLD     ideviceimagemounter
  CC       idevicescreenshot-idevicescreenshot.o
  CCLD     idevicescreenshot
  CC       ideviceenterrecovery-ideviceenterrecovery.o
  CCLD     ideviceenterrecovery
  CC       idevicedate-idevicedate.o
  CCLD     idevicedate
  CC       idevicebackup-idevicebackup.o
  CCLD     idevicebackup
  CC       idevicebackup2-idevicebackup2.o
  CCLD     idevicebackup2
  CC       ideviceprovision-ideviceprovision.o
  CCLD     ideviceprovision
  CC       idevicedebugserverproxy-idevicedebugserverproxy.o
  CCLD     idevicedebugserverproxy
  CC       idevicediagnostics-idevicediagnostics.o
  CCLD     idevicediagnostics
  CC       idevicedebug-idevicedebug.o
  CCLD     idevicedebug
  CC       idevicenotificationproxy-idevicenotificationproxy.o
  CCLD     idevicenotificationproxy
  CC       idevicecrashreport-idevicecrashreport.o
idevicecrashreport.c: In function ‘afc_client_copy_and_remove_crash_reports’:
idevicecrashreport.c:155:4: warning: ‘strncpy’ specified bound depends on the length of the source argument [-Wstringop-overflow=]
  155 |    strncpy(((char*)target_filename) + host_directory_length, list[k], newlen);
      |    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
idevicecrashreport.c:154:17: note: length computed here
  154 |    int newlen = strlen(list[k]) - 7;
      |                 ^~~~~~~~~~~~~~~
  CCLD     idevicecrashreport
  CC       idevicesetlocation-idevicesetlocation.o
  CCLD     idevicesetlocation
make[2]: Leaving directory '/tmp/libimobiledevice/tools'
Making all in docs
make[2]: Entering directory '/tmp/libimobiledevice/docs'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/tmp/libimobiledevice/docs'
make[2]: Entering directory '/tmp/libimobiledevice'
make[2]: Leaving directory '/tmp/libimobiledevice'
make[1]: Leaving directory '/tmp/libimobiledevice'
[admin@system libimobiledevice]$ make install
Making install in common
make[1]: Entering directory '/tmp/libimobiledevice/common'
make[2]: Entering directory '/tmp/libimobiledevice/common'
make[2]: Nothing to be done for 'install-exec-am'.
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory '/tmp/libimobiledevice/common'
make[1]: Leaving directory '/tmp/libimobiledevice/common'
Making install in src
make[1]: Entering directory '/tmp/libimobiledevice/src'
make[2]: Entering directory '/tmp/libimobiledevice/src'
 /usr/bin/mkdir -p '/usr/local/lib'
/usr/bin/mkdir: cannot create directory ‘/usr/local/lib’: Permission denied
make[2]: *** [Makefile:503: install-libLTLIBRARIES] Error 1
make[2]: Leaving directory '/tmp/libimobiledevice/src'
make[1]: *** [Makefile:724: install-am] Error 2
make[1]: Leaving directory '/tmp/libimobiledevice/src'
make: *** [Makefile:455: install-recursive] Error 1
[admin@system libimobiledevice]$ sudo make install
[sudo] password for admin: 
Making install in common
make[1]: Entering directory '/tmp/libimobiledevice/common'
make[2]: Entering directory '/tmp/libimobiledevice/common'
make[2]: Nothing to be done for 'install-exec-am'.
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory '/tmp/libimobiledevice/common'
make[1]: Leaving directory '/tmp/libimobiledevice/common'
Making install in src
make[1]: Entering directory '/tmp/libimobiledevice/src'
make[2]: Entering directory '/tmp/libimobiledevice/src'
 /usr/bin/mkdir -p '/usr/local/lib'
 /bin/sh ../libtool   --mode=install /usr/bin/install -c   libimobiledevice-1.0.la '/usr/local/lib'
libtool: install: /usr/bin/install -c .libs/libimobiledevice-1.0.so.6.0.0 /usr/local/lib/libimobiledevice-1.0.so.6.0.0
libtool: install: (cd /usr/local/lib && { ln -s -f libimobiledevice-1.0.so.6.0.0 libimobiledevice-1.0.so.6 || { rm -f libimobiledevice-1.0.so.6 && ln -s libimobiledevice-1.0.so.6.0.0 libimobiledevice-1.0.so.6; }; })
libtool: install: (cd /usr/local/lib && { ln -s -f libimobiledevice-1.0.so.6.0.0 libimobiledevice-1.0.so || { rm -f libimobiledevice-1.0.so && ln -s libimobiledevice-1.0.so.6.0.0 libimobiledevice-1.0.so; }; })
libtool: install: /usr/bin/install -c .libs/libimobiledevice-1.0.lai /usr/local/lib/libimobiledevice-1.0.la
libtool: install: /usr/bin/install -c .libs/libimobiledevice-1.0.a /usr/local/lib/libimobiledevice-1.0.a
libtool: install: chmod 644 /usr/local/lib/libimobiledevice-1.0.a
libtool: install: ranlib /usr/local/lib/libimobiledevice-1.0.a
libtool: finish: PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/lib/jvm/default/bin:/usr/bin/vendor_perl:/usr/bin/core_perl:/sbin" ldconfig -n /usr/local/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the '-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the 'LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the 'LD_RUN_PATH' environment variable
     during linking
   - use the '-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to '/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /usr/bin/mkdir -p '/usr/local/lib/pkgconfig'
 /usr/bin/install -c -m 644 libimobiledevice-1.0.pc '/usr/local/lib/pkgconfig'
make[2]: Leaving directory '/tmp/libimobiledevice/src'
make[1]: Leaving directory '/tmp/libimobiledevice/src'
Making install in include
make[1]: Entering directory '/tmp/libimobiledevice/include'
make[2]: Entering directory '/tmp/libimobiledevice/include'
make[2]: Nothing to be done for 'install-exec-am'.
 /usr/bin/mkdir -p '/usr/local/include'
 /usr/bin/mkdir -p '/usr/local/include/libimobiledevice'
 /usr/bin/install -c -m 644  libimobiledevice/libimobiledevice.h libimobiledevice/lockdown.h libimobiledevice/afc.h libimobiledevice/file_relay.h libimobiledevice/notification_proxy.h libimobiledevice/installation_proxy.h libimobiledevice/sbservices.h libimobiledevice/mobile_image_mounter.h libimobiledevice/screenshotr.h libimobiledevice/mobilesync.h libimobiledevice/mobilebackup.h libimobiledevice/house_arrest.h libimobiledevice/mobilebackup2.h libimobiledevice/misagent.h libimobiledevice/restore.h libimobiledevice/webinspector.h libimobiledevice/heartbeat.h libimobiledevice/diagnostics_relay.h libimobiledevice/debugserver.h libimobiledevice/syslog_relay.h libimobiledevice/mobileactivation.h libimobiledevice/preboard.h libimobiledevice/companion_proxy.h libimobiledevice/property_list_service.h libimobiledevice/service.h '/usr/local/include/libimobiledevice'
make[2]: Leaving directory '/tmp/libimobiledevice/include'
make[1]: Leaving directory '/tmp/libimobiledevice/include'
Making install in tools
make[1]: Entering directory '/tmp/libimobiledevice/tools'
make[2]: Entering directory '/tmp/libimobiledevice/tools'
 /usr/bin/mkdir -p '/usr/local/bin'
  /bin/sh ../libtool   --mode=install /usr/bin/install -c idevice_id ideviceinfo idevicename idevicepair idevicesyslog ideviceimagemounter idevicescreenshot ideviceenterrecovery idevicedate idevicebackup idevicebackup2 ideviceprovision idevicedebugserverproxy idevicediagnostics idevicedebug idevicenotificationproxy idevicecrashreport idevicesetlocation '/usr/local/bin'
libtool: install: /usr/bin/install -c .libs/idevice_id /usr/local/bin/idevice_id
libtool: install: /usr/bin/install -c .libs/ideviceinfo /usr/local/bin/ideviceinfo
libtool: install: /usr/bin/install -c .libs/idevicename /usr/local/bin/idevicename
libtool: install: /usr/bin/install -c .libs/idevicepair /usr/local/bin/idevicepair
libtool: install: /usr/bin/install -c .libs/idevicesyslog /usr/local/bin/idevicesyslog
libtool: install: /usr/bin/install -c .libs/ideviceimagemounter /usr/local/bin/ideviceimagemounter
libtool: install: /usr/bin/install -c .libs/idevicescreenshot /usr/local/bin/idevicescreenshot
libtool: install: /usr/bin/install -c .libs/ideviceenterrecovery /usr/local/bin/ideviceenterrecovery
libtool: install: /usr/bin/install -c .libs/idevicedate /usr/local/bin/idevicedate
libtool: install: /usr/bin/install -c .libs/idevicebackup /usr/local/bin/idevicebackup
libtool: install: /usr/bin/install -c .libs/idevicebackup2 /usr/local/bin/idevicebackup2
libtool: install: /usr/bin/install -c .libs/ideviceprovision /usr/local/bin/ideviceprovision
libtool: install: /usr/bin/install -c .libs/idevicedebugserverproxy /usr/local/bin/idevicedebugserverproxy
libtool: install: /usr/bin/install -c .libs/idevicediagnostics /usr/local/bin/idevicediagnostics
libtool: install: /usr/bin/install -c .libs/idevicedebug /usr/local/bin/idevicedebug
libtool: install: /usr/bin/install -c .libs/idevicenotificationproxy /usr/local/bin/idevicenotificationproxy
libtool: install: /usr/bin/install -c .libs/idevicecrashreport /usr/local/bin/idevicecrashreport
libtool: install: /usr/bin/install -c .libs/idevicesetlocation /usr/local/bin/idevicesetlocation
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory '/tmp/libimobiledevice/tools'
make[1]: Leaving directory '/tmp/libimobiledevice/tools'
Making install in docs
make[1]: Entering directory '/tmp/libimobiledevice/docs'
make[2]: Entering directory '/tmp/libimobiledevice/docs'
make[2]: Nothing to be done for 'install-exec-am'.
 /usr/bin/mkdir -p '/usr/local/share/man/man1'
/usr/bin/mkdir: cannot create directory ‘/usr/local/share/man’: File exists
make[2]: *** [Makefile:387: install-man1] Error 1
make[2]: Leaving directory '/tmp/libimobiledevice/docs'
make[1]: *** [Makefile:481: install-am] Error 2
make[1]: Leaving directory '/tmp/libimobiledevice/docs'
make: *** [Makefile:455: install-recursive] Error 1
[admin@system libimobiledevice]$ 

Offline

#10 2021-01-07 18:09:28

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,069

Re: [SOLVED] idevicebackup2 isn't work

snap.ve wrote:

maybe I just don't understand something. But how then to perceive the lines - last update in AUR, and build date in Pacman? https://imgur.com/a/xHcC9Jy

You don't understand how -git packages work. The PKGBUILD on the AUR hasn't been updated since 26th of April last year, but it doesn't need to be.
Every time you build the package it downloads the latest sources and builds them. Just try it and see which version you end up with before stating that it's older.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#11 2021-01-07 18:13:05

snap.ve
Member
Registered: 2020-04-02
Posts: 76

Re: [SOLVED] idevicebackup2 isn't work

Slithery wrote:
snap.ve wrote:

maybe I just don't understand something. But how then to perceive the lines - last update in AUR, and build date in Pacman? https://imgur.com/a/xHcC9Jy

You don't understand how -git packages work. The PKGBUILD on the AUR hasn't been updated since 26th of April last year, but it doesn't need to be.
Every time you build the package it downloads the latest sources and builds them. Just try it and see which version you end up with before stating that it's older.

Thanks for the clarification, didn't know this

Upd: I was install AUR git version, and it works! Thank's all for response! It would be great if the update arrived in the official repository soon

Last edited by snap.ve (2021-01-07 18:26:26)

Offline

#12 2021-01-07 18:13:13

loqs
Member
Registered: 2014-03-06
Posts: 12,569

Re: [SOLVED] idevicebackup2 isn't work

https://github.com/libimobiledevice/lib … device.git is the source repository of the project libimobiledevice building that using autogen is not using makepkg.
https://aur.archlinux.org/packages/libi … evice-git/ is the AUR repository containing the PKGBUILD that will build the master branch of the above project.

Last edited by loqs (2021-01-07 18:13:40)

Offline

#13 2021-01-07 18:25:46

snap.ve
Member
Registered: 2020-04-02
Posts: 76

Re: [SOLVED] idevicebackup2 isn't work

loqs wrote:

https://github.com/libimobiledevice/lib … device.git is the source repository of the project libimobiledevice building that using autogen is not using makepkg.
https://aur.archlinux.org/packages/libi … evice-git/ is the AUR repository containing the PKGBUILD that will build the master branch of the above project.

Yes, thank you. I have already been explained

Offline

#14 2021-01-07 18:27:23

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,069

Re: [SOLVED] idevicebackup2 isn't work

snap.ve wrote:

It would be great if the update arrived in the official repository soon

I'm sure that whenever upstream decide to release the next stable version then Arch will package it.
It's upstream that you are waiting for, not Arch.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#15 2021-01-07 18:40:31

loqs
Member
Registered: 2014-03-06
Posts: 12,569

Re: [SOLVED] idevicebackup2 isn't work

If you want to try the libimobiledevice-git 1:1.3.0.r34.g12d3a07-1 package in the mean time it builds and installs without issue.  I have not tested if it functions.

Last edited by loqs (2021-01-07 18:40:47)

Offline

#16 2021-01-07 18:48:26

snap.ve
Member
Registered: 2020-04-02
Posts: 76

Re: [SOLVED] idevicebackup2 isn't work

loqs wrote:

If you want to try the libimobiledevice-git 1:1.3.0.r34.g12d3a07-1 package in the mean time it builds and installs without issue.  I have not tested if it functions.

He is working, i was try backup my device. Didn't know what about restore honestly...

Last edited by snap.ve (2021-01-07 18:49:17)

Offline

Board footer

Powered by FluxBB