You are not logged in.

#1 2021-01-07 18:35:10

WorLord
Member
Registered: 2015-04-06
Posts: 4

[SOLVED] GDM starts large -- VERY large -- the first time

Greetings.  This isn't exactly a massive problem, but as I haven't been able to solve it yet, I thought I'd ask. 

I have an older Intel-based desktop with proprietary nVidia drivers.  Recently -- I'd say sometime in the last two weeks of December -- GDM has taken to starting at a very low resolution when my computer first boots.  The widgets, top bar, even mouse cursor are all HUGE.

Big GDM

Bear in mind, that's a 36" monitor. 

All _subsequent_ visits to GDM to not exhibit this issue.  Just the first time. 

I've read what I could, and none of the proposed solutions seem to work.  I've copied .monitors into /var/lib/gdm3/.config, made sure X and not Wayland are starting, checked everything I can.  The Xorg.0.log logs lead me to believe that it's using a framebuffer driver for X -- or nouveau, I can't really tell at first glance -- but those should be disabled and are in a blacklist list. 

Anyone else know what's up?  It won't kill me if this doesn't get fixed but I've generally been able to address things like this prior to now.  It seems the .monitor.xml trick was the thing to do but that's stopped working for me and others as well.

Last edited by WorLord (2021-01-08 18:31:13)

Offline

#2 2021-01-07 21:07:26

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,186

Re: [SOLVED] GDM starts large -- VERY large -- the first time

That usually happens due to race conditions and the graphics device not being ready before xorg/gdm tries to start, see https://wiki.archlinux.org/index.php/NV … de_setting for how to set up early loading of nvidia modules (the kernel parameter isn't quite necessary but the modules into mkinitcpio part)

Maybe also post that xorg log so that we have the relevant information as well.

Online

#3 2021-01-08 05:21:14

WorLord
Member
Registered: 2015-04-06
Posts: 4

Re: [SOLVED] GDM starts large -- VERY large -- the first time

Well, gosh.  That did it.  I must have been trying to read too fast, I had the kernel parameter but not this. 

Thanks!

Offline

Board footer

Powered by FluxBB