You are not logged in.

#1 2021-01-10 14:06:10

falsealarm
Member
Registered: 2012-11-16
Posts: 4

Wireless network controller detected but can't start

I was recently having a trouble with system freezes.
it caused me to switch kernel a few times, and caused a bunch of abrupt shutdowns.
Today, after a reboot I couldn't see the wifi device on

ip link

(I think I tried to come back from hiberantion but it rebooted, happens sometimes)

lspci finds the network controller

00:14.3 Network controller: Intel Corporation Cannon Point-LP CNVi [Wireless-AC] (rev 30)

looking in dmesg I found the following error

[    2.311501] iwlwifi: probe of 0000:00:14.3 failed with error -22

also:

$ lsmod|grep wifi
iwlwifi               430080  0
cfg80211             1011712  1 iwlwifi

I rebooted into windows, but it also couldn't start the network device,
I tried to power cycle the laptop (shutting down to 30+ secs, with and without forcing power off with long press of power button) but it didn't work.

tried all kinds of different kernels
and tried

# echo 1 > /sys/bus/pci/devices/0000\:00\:14.3/remove
# echo 1 > /sys/bus/pci/rescan

Is there still hope?

Offline

Board footer

Powered by FluxBB