You are not logged in.

#1 2021-01-10 21:36:28

yodermk
Member
Registered: 2012-07-17
Posts: 82

no audio device for external monitors

Before a week or so ago everything was fine.
Now, external monitors that do have speakers (one LG monitor via DisplayPort and one TV via HDMI) work for video, but have no audio output device displayed in Pavucontrol.  Only the internal laptop audio and headphones port are shown.

Laptop is a Dell Precision 7530 with nVidia, and I am using the proprietary nVidia driver.

Just booted into Windows, and it's OK there.

Has this happened to anyone else, or any ideas?

thanks

Last edited by yodermk (2021-01-10 21:37:01)

Offline

#2 2021-01-10 22:00:23

yodermk
Member
Registered: 2012-07-17
Posts: 82

Re: no audio device for external monitors

what do  you know it's now coming out the monitor even though Pavucontrol is set to Speakers (normally internal audio) and the DP audio device isn't showing up.

Offline

#3 2021-01-14 18:02:33

yodermk
Member
Registered: 2012-07-17
Posts: 82

Re: no audio device for external monitors

Previous comment was just after a reboot, then it reverted to internal speakers even without suspend.  However, this seems to have done it.

pulseaudio -k && pactl load-module module-detect

Will try on the TV before marking this as solved.

Offline

#4 2021-01-14 20:58:37

yodermk
Member
Registered: 2012-07-17
Posts: 82

Re: no audio device for external monitors

Not tried on TV yet, but this is still reverting.  After running it, HDMI/DP appears in Pavucontrol and sound properly goes out the monitor. Later, I think after the screen blanks, sound reverts to internal speakers and HDMI/DP is not even shown as an option. Run it again and it works again.

Any idea what could be causing this?  Didn't happen until recently.

Offline

Board footer

Powered by FluxBB