You are not logged in.

#1 2021-01-18 13:35:04

Registered: 2021-01-18
Posts: 1

Wireless adapter can't find networks after booting Arch install drive.

First of all, thank you all for reading this.

I've owned and used this laptop (ASUS TUF GAMING FX504GD_FX80GD) for about a year and a half without ever encountering any similar issues. Up until now, I was running Windows 10 on it, but I decided to switch to Linux for productivity reasons. Arch seemed like the most customizable one, so that's what I went with. My plan was nevertheless to dual boot Windows and Arch.

I followed the installation guide from the wiki with no issue until I was required to connect to the internet. At the time I had no Ethernet connection available so I went with the wireless option, using iwctl.
The problem arose when searching for available networks, as none were being detected (mind that this is a very populated area, I could detect around 40 different networks on my smartphone). None of my other devices were having any issues either.

Now, I unfortunately wasn't taking logs at that time, so I am unable to present them here. Anyways, I ran ifconfig to check the status of the wlan0 device, which was up (yes, inside the brackets) and powered. I tried turning it off and on again to no avail and checked rfkill for blockings.
At that point I decided to abort the installation and reboot to windows, as I needed a connection to complete the installation anyways.

The weird part is that when starting Windows, it couldn't detect any networks either: image .

I reinstalled drivers, reset the device and even reset the computer to factory state with the Windows utility. Ethernet connection is working correctly.
I also checked the device's settings on Windows' Device Manager and nothing seems out of place.

After that, I tried booting the Arch install medium again to review the iwctl help in case I was missing something. I didn't find anything, but I got logs:

ip link output

root@archiso ~ # ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisk noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisk fq_codel state UP mode DEFAULT group default qlen 1000
link/ether hh:hh:hh:hh:hh:hh brd ff:ff:ff:ff:ff:ff
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisk noqueue state DOWN mode DORMANT group default qlen 1000
link/ether hh:hh:hh:hh:hh:hh brd ff:ff:ff:ff:ff:ff

Note that the MAC addresses are censored, the real ones are valid and correct.
Also, mind that this was with an Ethernet connection active, thus the state of enp4s0.

rfkill output

root@archiso ~ # rfkill
0  wlan phy0 unblocked unblocked

iwctl steps

root@archiso ~ # iwctl
[iwd]# device list
Name Address Powered Adapter Mode
wlan0 <omitted> on phy0 station

[iwd]# station wlan0 scan
[iwd]# station wlan0 get-networks
Available networks
Network name Security Signal
No networks available

The network adapter I'm using is the model's original adapter: Realtek 8821CE Wireless LAN 802.11ac PCI-E NIC, 5GHz and 2'4GHz
I don't even know if it is possible, but my theory is that the adapter's firmware was overwritten during installation. It might also be a hardware problem with the antenna, but I doubt it is a coincidence it happened right after booting the install medium.
I checked my BIOS options and there is no setting related to wireless.
Also, wireless connections work with external USB dongles.

Thank you all in advance.

Last edited by yxtpumpkin (2021-01-18 13:36:52)


Board footer

Powered by FluxBB