You are not logged in.

#1 2021-01-21 11:27:14

wuwei
Member
Registered: 2021-01-21
Posts: 14

Install package epson-inkjet-printer-201211w failed

Hi, I've installed and configured a fresh setup of Arch Linux with Cinnamon desktop.

I need to install epson-inkjet-printer-201211w driver for my Epson WorkForce WF-2010w (wireless version), so when I try to do a makepkg -si from the downloaded git repo (https://aur.archlinux.org/epson-inkjet- … 01211w.git) it returns the following error:

running CONFIG_SHELL=/bin/sh /bin/sh ./configure LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,--no-as-needed --prefix=/opt/epson-inkjet-printer-201211w CFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fno-plt CPPFLAGS=-D_FORTIFY_SOURCE=2 --no-create --no-recursion
configure: error: cannot find required auxiliary files: compile
make: *** [Makefile:290: config.status] Error 1
==> ERROR: A failure occurred in build().
    Aborting...

previously i get the following warning:

WARNING: `automake-1.11' is missing on your system.  You should only need it if
         you modified `Makefile.am', `acinclude.m4' or `configure.ac'.
         You might want to install the `Automake' and `Perl' packages.
         Grab them from any GNU archive site.

in my system is installed automake-1.16.2-3.

So I can't successufully compile and install this package.
How can I resolve this issue?
Please help, I would appreciate it very much, I am a arch linux newbie!
Thanks so much!

Offline

#2 2021-01-21 12:06:27

Lone_Wolf
Forum Moderator
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 12,330

Re: Install package epson-inkjet-printer-201211w failed

https://stackoverflow.com/questions/217 … e#21773816 gave a clue that makes the build continue.

Add automake --add-missing to the PKGBUILD between libtoolize / chmod commands so it looks like this :

  libtoolize
  automake --add-missing
  chmod +x configure

Keep in mind this driver is very old (2012), the generated compile-file is very generic and the resulting package may not be functional.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-01-21 12:43:07

progandy
Member
Registered: 2012-05-17
Posts: 5,215

Re: Install package epson-inkjet-printer-201211w failed

You should add a call to automake-1.16 like this to the PKGBUILD:

  libtoolize
  automake-1.16 -a
  chmod +x configure

Edit: Sorry, forgot to reload. Maybe calling the 1.16 version explicitly would still be necessary.

Last edited by progandy (2021-01-21 12:44:14)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#4 2021-01-21 14:19:58

wuwei
Member
Registered: 2021-01-21
Posts: 14

Re: Install package epson-inkjet-printer-201211w failed

Thanks so much!!! Now works like a charm! Driver installed, make me print a lot!!!

Offline

Board footer

Powered by FluxBB