You are not logged in.

#1 2021-01-21 16:01:03

louisld
Member
Registered: 2020-10-24
Posts: 17

Japanese input in KDE

Hello,

I'm trying to add a Japanese keyboard layout in KDE.

According to the Japanese page on the arch wiki, I installed the mozc-ut2 package. After that I installed fcitx-mozc and fcitx.

On the fcitx wiki page, there is a subsection for KDE. It says :

Disable stuff related to KDE:

    At System settings > Input devices > Layouts (tab) make sure that Configure layouts is unchecked.
    At System settings > Input devices > Advanced (tab) make sure that Configure keyboard options is unchecked

I'm able to disable "configure keyboard" but each time I disable "configure layouts" in KDE when I open again the window it's enabled. I don't undestand why and because of this I can't use fcitx.

Do you have any idea where this problem can come from ?

Offline

#2 2021-01-21 16:20:07

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,043

Re: Japanese input in KDE

The configuration you're trying to do is listed under Troubleshooting. I was just wondering if you can try using the kcm-fcitx package. I assume this will be a more straightforward way of configuring your layout directly via the KDE Settings.

Offline

#3 2021-01-21 16:36:08

louisld
Member
Registered: 2020-10-24
Posts: 17

Re: Japanese input in KDE

Thank you for your answer.

I have already configured fcitx with kcm-fcitx.

Screenshot-20210121-173306.png

I have both the icon of KDE keyboard and fcitx keyboard in the taskbar.

Offline

#4 2021-01-21 16:52:01

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,043

Re: Japanese input in KDE

So are you not able to generate Japanese characters from your keyboard? I'm merely guessing but am quite intrigued on how to enable a foreign keys in KDE.

EDIT: You can perhaps try amending or temporarily delete ~/.config/kglobalshortcutrc. I believe that's the file KDE writes for the keyboard configuration.

Last edited by d_fajardo (2021-01-21 17:02:18)

Offline

#5 2021-01-21 17:11:16

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: Japanese input in KDE

Wild guess (I use none of this) but do you also have multiple layouts configured in the regular™ keyboard kcm/layouts tab?
Edit, the implication being: remove them.

Last edited by seth (2021-01-21 17:11:38)

Online

#6 2021-01-21 17:45:14

louisld
Member
Registered: 2020-10-24
Posts: 17

Re: Japanese input in KDE

I won't delete ~/.config/kglobalshortcutrc because it stores every shortcut of KDE apps and not the keyboard configurations.

I tried to remove the keyboard from KDE buth when I close the window it gets back...

Here is a screenshot (sorry it's in French). Each time I unckeck the checkbox or remove the keyboard layouts it gets back.

Screenshot-20210121-184013.png

Offline

#7 2021-01-21 20:13:15

d_fajardo
Member
Registered: 2017-07-28
Posts: 1,043

Re: Japanese input in KDE

I meant to say a temporary delete - putting it somewhere safe and regenerating it by reboot. You can always refer back to it, But it might just be sufficient to comment out the KDE Layout Switcher stanza on that file. Again you can do so by making a backup first.

Offline

#8 2021-01-21 21:14:52

louisld
Member
Registered: 2020-10-24
Posts: 17

Re: Japanese input in KDE

I move the file then reboot my computer but I'm still unable to disable it.I reinstalled fcixt and nothing changed.

Offline

#9 2021-01-21 21:17:28

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: Japanese input in KDE

Did you set the layouts using localectl?

ls -lR /{etc,usr/share}/X11/xorg.conf*

Online

#10 2021-01-21 21:52:15

louisld
Member
Registered: 2020-10-24
Posts: 17

Re: Japanese input in KDE

Here is the output :

-rw-r--r-- 1 root root 2181 27 déc.  23:29 /etc/X11/xorg.conf

/etc/X11/xorg.conf.d:
total 0

/usr/share/X11/xorg.conf.d:
total 8
-rw-r--r-- 1 root root 1350 14 déc.  13:10 10-quirks.conf
-rw-r--r-- 1 root root 1429 19 mai    2020 40-libinput.conf

Offline

#11 2021-01-21 22:28:25

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: Japanese input in KDE

Nope, but what's the contents of /etc/X11/xorg.conf ?
Can you add/remove a single layout to/from the stack?

Online

#12 2021-01-21 22:48:22

louisld
Member
Registered: 2020-10-24
Posts: 17

Re: Japanese input in KDE

Yes I can remove item from the stack but only if there is on item left. If there is only one it come back after.

#/etc/X11/xorg.conf
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/misc"
        FontPath     "/usr/share/fonts/TTF"
        FontPath     "/usr/share/fonts/OTF"
        FontPath     "/usr/share/fonts/Type1"
        FontPath     "/usr/share/fonts/100dpi"
        FontPath     "/usr/share/fonts/75dpi"
EndSection

Section "Module"
        Load  "glx"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"                  # [<bool>]
        #Option     "kmsdev"                    # <str>
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "AccelMethod"               # <str>
        #Option     "PageFlip"                  # [<bool>]
        #Option     "ZaphodHeads"               # <str>
        #Option     "DoubleShadow"              # [<bool>]
        #Option     "Atomic"                    # [<bool>]
        Identifier  "Card0"
        Driver      "modesetting"
        BusID       "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
        Option "RandRRotation" "on"
EndSection

Offline

#13 2021-01-21 23:02:53

seth
Member
Registered: 2012-09-03
Posts: 18,781

Re: Japanese input in KDE

Nope…

Are the layouts in ~/.config/kxkbrc (possbily dated info) and does that file update with your changes?

Online

#14 2021-01-22 01:01:21

louisld
Member
Registered: 2020-10-24
Posts: 17

Re: Japanese input in KDE

#.config/kxkbrc 
[Layout]
DisplayNames=
LayoutList=fr(oss)
LayoutLoopCount=-1
Model=pc86
ResetOldOptions=false
ShowFlag=false
ShowLabel=true
ShowLayoutIndicator=true
ShowSingle=false
SwitchMode=Global
Use=true

I tried to set Use to false but when I login it turns back to true.

To install fcitx, do I have just to install packages, edit the config of fcitx and then it works or is there any more configuration to do ?

Offline

#15 2021-01-22 09:09:13

louisld
Member
Registered: 2020-10-24
Posts: 17

Re: Japanese input in KDE

It finally works, I don't know why but it works. I removed mozc-ut2 and installed fcitx-mozc-ut2 from aur.

I also changed the file .pam_environment.

Here is the packages I have installed to make it works if it can help someone else :

fcitx 4.2.9.8-1
fcitx-mozc-ut2 2.23.2815.102.20171008-3
fcitx-qt4 4.2.9.6-1
fcitx-qt5 1.2.5-3
kcm-fcitx 0.5.6-1

Thank you for your help.

Offline

Board footer

Powered by FluxBB