You are not logged in.

#1 2021-01-21 19:40:16

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 955

"No irq handler for vector" messages during boot with AMD CPU

With a very recent AMD machine with the Ryzen 4750GE CPU (APU), on an Asrock X300m-STX motherboard, when booting the system (current Linux kernel is version 5.10.9 but the same occurred with earlier kernel versions including 5.10.7), there are log messages during the first stage of the boot as follows:

Jan 17 15:17:24 saplinux kernel: smp: Bringing up secondary CPUs ...
Jan 17 15:17:24 saplinux kernel: x86: Booting SMP configuration:
Jan 17 15:17:24 saplinux kernel: .... node #0, CPUs: #1
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 1.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #2
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 2.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #3
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 3.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #4
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 4.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #5
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 5.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #6
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 6.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #7
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 7.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #8
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 8.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #9
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 9.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #10
Jan 17 15:17:24 saplinux kernel: __common_interrupt: 10.55 No irq handler for vector
Jan 17 15:17:24 saplinux kernel: #11 #12 #13 #14 #15
Jan 17 15:17:24 saplinux kernel: smp: Brought up 1 node, 16 CPUs

The system continues to complete the boot process and then runs normally, I have seen similar boot messages, on forums and mailing lists for other distributions, as well as earlier posts for Arch, for recent AMD  Ryzen CPUs of various designations, and not just the 4750GE, and it is suggested the messages are not a problem with the kernel, but are due to a bug in the BIOS UEFI code. I have been told there is likely to be an updated BIOS released in the near future that 'might' fix this issue?

In the meantime does anyone else who has a recent Ryzen AMD CPU and sees similar log messages at the start of the boot process, have a workaround, that does not impact performance, but removes the messages from the log - also if logging out from the desktop the set 'No irq handler for vector' message lines stay on the screen for a second before the sddm login greeter returns, which looks untidy! I would appreciate it if anyone with the same issue has found a solution.


Mike C

Offline

#2 2021-01-21 20:00:28

loqs
Member
Registered: 2014-03-06
Posts: 12,949

Re: "No irq handler for vector" messages during boot with AMD CPU

Offline

#3 2021-01-21 20:25:36

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 955

Re: "No irq handler for vector" messages during boot with AMD CPU

Thanks - hopefully a fixed BIOS will be released before too long.


Mike C

Offline

Board footer

Powered by FluxBB