You are not logged in.

#1 2021-02-02 15:54:19

beardoof
Member
Registered: 2019-11-13
Posts: 14

Python's poetry hangs while solving dependencies

Yesterday poetry was working just fine on my system. Today, I can't do pretty much anything with it. Almost every command I try simply hangs my terminal until I hit ctrl+c.

I'm trying to do a

poetry update

on a particular project, but it does not work. Also, I'm using pacman's default poetry, which is a bit outdated, so I tried installing it the recommended way from their site, by running

`curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python -

Which also doesn't work and hangs the terminal until I hit ctrl+c.

Whenever I try

poetry add [package name]

or even

poetry remove [package name]

, it simply says "Resolving dependencies" and never moves on from that. I have waited up to 900s and given up.

This is the output:

Updating dependencies
Resolving dependencies... (258.7s)^C

Is this some recent server issue? My colleagues that use other distros (Ubuntu, Manjaro, Mint) are not having this problem, which is why I came here to check if it was arch-related.

I'm using python's most recent version (3.9.0) but for this particular program I use python 3.6.9 with pyenv locally set for compatibility reasons. Yesterday everything worked just fine on both versions of python.

Offline

#2 2021-02-02 17:12:47

dmerej
Member
From: Paris
Registered: 2016-04-09
Posts: 97
Website

Re: Python's poetry hangs while solving dependencies

poetry works fine here.

You may want to run `poetry` with `-vvv` and post the output here.

Also, you can look at `/var/log/pacman.log` to see if new packages were updated and try if downgrading them fixes the problem (if so, open an issue at bugs.archlinux.org)


Responsible Coder, Python Fan, Rust enthusiast

Offline

#3 2021-02-03 21:21:55

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 4,097

Re: Python's poetry hangs while solving dependencies

FWIW my experience is poetry tends to be unpredictably slow. 15 minutes might not be long enough. And it might depend on what it's resolving.

Anyway, I've just recently updated poetry in the official repos after getting the tests to work...


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB