You are not logged in.

#1 2021-02-13 11:22:23

foobat
Member
Registered: 2021-02-13
Posts: 5

[SOLVED] Arduino IDE fails to start after system upgrade

Arduino IDE fails to start after recent system upgrade. It seems that it fails to load board information.
Console output :
Picked up JAVA_TOOL_OPTIONS:
Set log4j store directory /home/scratcher/.arduino15
java.lang.NullPointerException: Cannot invoke "processing.app.debug.TargetBoard.getContainerPlatform()" because "board" is null
    at processing.app.Base.rebuildProgrammerMenu(Base.java:1705)
    at processing.app.Base.<init>(Base.java:286)
    at processing.app.Base.main(Base.java:150)
Return value: 255
Java runtime: jre-openjdk

Last edited by foobat (2021-02-13 13:09:26)

Offline

#2 2021-02-13 11:42:44

foobat
Member
Registered: 2021-02-13
Posts: 5

Re: [SOLVED] Arduino IDE fails to start after system upgrade

Arduino version: 1:1.8.13-2
jre-openjdk version: 15.0.2.u7-1

Offline

#3 2021-02-13 12:14:56

foobat
Member
Registered: 2021-02-13
Posts: 5

Re: [SOLVED] Arduino IDE fails to start after system upgrade

I find that this problem might not be caused by this upgrade after reading pacman logfile.

Last edited by foobat (2021-02-13 13:03:54)

Offline

#4 2021-02-13 13:01:10

foobat
Member
Registered: 2021-02-13
Posts: 5

Re: [SOLVED] Arduino IDE fails to start after system upgrade

It works after installing arduino-avr-core. Deleting ~/.arduino* may also help.

Last edited by foobat (2021-02-13 13:21:22)

Offline

Board footer

Powered by FluxBB