You are not logged in.

#1 2021-02-16 05:53:47

tea_niugnep
Member
Registered: 2021-02-16
Posts: 3

[SOLVED] SLIM jump "Failed to execute login command"

Im a newbie of ArchLinux, and this is the first time I try to install Arch by myself following the guide.

I chose slim as my displayer manager with xfce de, but when I reboot, im stuck at login...

And I have found some issues about this error `Failed to execute login command`, but my situation is a little different..

I followed the wiki, installed the xfce4 package and slim, and write the following `~/.xinstrc`:
`
#!/bin/sh

#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#

exec startxfce4
`

Also, I edited `/etc/slim.conf`, set default username (not root user), and enable autologin, then I reboot

The problem is, I go to the terminal tty1 directly, and every 3~5 seconds the screen jump to error message "Failed to execute login command" then jump back to login interface. The time is too short to finish root user login (normal user login without pw didnt work)

I tried ALT+CTRL+F1~6, as advised in other simliar issues, not work, terminal switch from tty1 to tty6, but still frequently jump to the error message

I also tried exit, reboot,poweroff in name box, not work, the terminal asks me for pw only

I guess maybe I should modify the `login_cmd` in `slim.conf`, but now i cant escape from the "Failed to execute login command" message, what should I do? If possible, I dont want to repeat the installation...

==========================================================
Update: I found although the error message jumps, I can login as root. After login in, I close the slim service, it is ok.

Last edited by tea_niugnep (2021-02-16 06:05:27)

Offline

Board footer

Powered by FluxBB