You are not logged in.

#1 2021-02-17 04:57:46

callmer
Member
Registered: 2021-01-07
Posts: 80

[SOLVED]Can't unmask pulseaudio service with systemctl

Here what Am I getting

systemctl unmask pulseaudio
Unit pulseaudio.service does not exist, proceeding anyway.
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-unit-files ====
Authentication is required to manage system service or unit files.
Authenticating as: ararat
Password: 
==== AUTHENTICATION COMPLETE ====

systemctl --user status pulseaudio
● pulseaudio.service
     Loaded: masked (Reason: Unit pulseaudio.service is masked.)
     Active: inactive (dead)

systemctl status pulseaudio
Unit pulseaudio.service could not be found.

solution: unmask without sudo and with --user both service and socket

Last edited by callmer (2021-02-17 08:48:05)

Offline

#2 2021-02-17 05:03:38

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,816
Website

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

You really don't read any of the output you post here, do you? Why are you using Arch if you are so allergic to reading terminal output?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Online

#3 2021-02-17 05:48:17

Ropid
Member
Registered: 2015-03-09
Posts: 1,068

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

You need to add "--user" to your 'unmask' command line, same as what you did on your 'status' command line.

The "--user" makes systemctl work on your user account's services. Without the "--user" you are working on the system services.

Offline

#4 2021-02-17 05:58:24

callmer
Member
Registered: 2021-01-07
Posts: 80

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

Ropid wrote:

You need to add "--user" to your 'unmask' command line, same as what you did on your 'status' command line.

The "--user" makes systemctl work on your user account's services. Without the "--user" you are working on the system services.

sudo systemctl --user unmask pulseaudio
Failed to connect to bus: $DBUS_SESSION_BUS_ADDRESS and $XDG_RUNTIME_DIR not defined (consider using --machine=<user>@.host --user to connect to bus of other user)

printenv XDG_RUNTIME_DIR
/run/user/1000

printenv DBUS_SESSION_BUS_ADDRESS
unix:path=/run/user/1000/bus

edit: what should I change?

sudo systemctl --machine=ararat@.host --user unmask pulseaudio
[sudo] password for ararat: 
Cannot access user instance remotely.

Last edited by callmer (2021-02-17 06:02:01)

Offline

#5 2021-02-17 06:01:44

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,447

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

callmer wrote:

edit: what should I change?

Did you try without sudo?

Offline

#6 2021-02-17 06:04:07

callmer
Member
Registered: 2021-01-07
Posts: 80

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

skunktrader wrote:
callmer wrote:

edit: what should I change?

Did you try without sudo?

yeah that's worked!!! I still don't understand how applications work in linux. Thanks.

Offline

#7 2021-02-17 07:22:50

callmer
Member
Registered: 2021-01-07
Posts: 80

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

skunktrader wrote:
callmer wrote:

edit: what should I change?

Did you try without sudo?

I was wrong, it is still masked!!! It seems like t is still masked, and why is it dead/inactive?

systemctl --user unmask pulseaudio

systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
     Active: inactive (dead)

systemctl --user restart pulseaudio
Failed to restart pulseaudio.service: Unit pulseaudio.socket is masked.

Offline

#8 2021-02-17 08:22:48

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,447

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

You need to unmask the .socket as well as the .service

Offline

#9 2021-02-17 08:37:06

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,031

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

The socket is masked. I gave you a command in the last thread

systemctl --user mask pulseaudio.{service,socket} --now #unmask to revert

So what you should be doing to unmask is run this exact command just with unmask instead

systemctl --user unmask pulseaudio.{service,socket} --now 

Offline

#10 2021-02-17 08:48:24

callmer
Member
Registered: 2021-01-07
Posts: 80

Re: [SOLVED]Can't unmask pulseaudio service with systemctl

V1del wrote:

The socket is masked. I gave you a command in the last thread

systemctl --user mask pulseaudio.{service,socket} --now #unmask to revert

So what you should be doing to unmask is run this exact command just with unmask instead

systemctl --user unmask pulseaudio.{service,socket} --now 

Thank you all, very very very much

Offline

Board footer

Powered by FluxBB