You are not logged in.

#1 2021-02-17 12:23:39

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Cannot install php74 'No package 'libsystemd' found

Hello,

I am (of course) using Arch with KDE as user interface and trizen as package manager. I attempted installing PHP 7.4 (package "php74") but I got this error message: No package 'libsystemd' found. However, the package systemd-libs is indeed installed (when I launch "trizen -S systemd-libs" to install it, I am proposed to reinstall it so I must have it). Anyone has an idea? I have no lead since the error message seems contradictory in my case.

Thank you

Offline

#2 2021-02-17 12:29:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,211

Re: Cannot install php74 'No package 'libsystemd' found

reads like a trizen bug, can you reproduce with just makepkg?

Mod note moving to AUR issues

Last edited by V1del (2021-02-17 12:29:23)

Offline

#3 2021-02-17 12:33:24

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,924

Re: Cannot install php74 'No package 'libsystemd' found

The PKGBUILD in the AUR does not mention libsystemd at all, and it is anyways a duplicate of https://archlinux.org/packages/extra/x86_64/php7/

Please show the *entire* error message, rather than only one line of it!


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#4 2021-02-17 12:41:12

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

I never used makepkg, I am figuring out how I should do it. Thank you for the reply.

Offline

#5 2021-02-17 12:43:55

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

Here are details of the output of the command "trizen -S php74":
Configuring SAPI modules
checking for Apache 2 handler module support via DSO through APXS... no
checking for setproctitle... no
checking sys/pstat.h usability... no
checking sys/pstat.h presence... no
checking for sys/pstat.h... no
checking for PS_STRINGS... no
checking for CLI build... yes
checking for embedded SAPI library support... shared
checking for FPM build... yes
checking for clearenv... yes
checking for setproctitle... (cached) no
checking for setproctitle_fast... no
checking for library containing socket... none required
checking for library containing inet_addr... none required
checking for prctl... yes
checking for clock_gettime... yes
checking for ptrace... yes
checking whether ptrace works... yes
checking for proc mem file... mem
checking if gcc supports __sync_bool_compare_and_swap... yes
checking for TCP_INFO... yes
checking for sysconf... yes
checking for times... yes
checking for kqueue... no
checking for port framework... no
checking for /dev/poll... no
checking for epoll... yes
checking for select... yes
checking for apparmor... no
checking for libsystemd >= 209... no
configure: error: Package requirements (libsystemd >= 209) were not met:

No package 'libsystemd' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SYSTEMD_CFLAGS
and SYSTEMD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
    Aborting...
:: Unable to build php74 - makepkg exited with code: 4

Offline

#6 2021-02-17 12:59:53

progandy
Member
Registered: 2012-05-17
Posts: 4,132

Re: Cannot install php74 'No package 'libsystemd' found

The headers and pkg-config data for libsystemd are part of the systemd package, not systemd-libs.  I am not completely sure why that is so.

I wonder if you removed systemd and now use a different init system. (Or maybe you are not using arch at all)

Last edited by progandy (2021-02-17 13:00:18)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#7 2021-02-17 13:02:36

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

I am sure I have Arch, and on the wiki it is said that systemd can be called with systemctl, which I regularly use. The problem seems to be : configure: error: Package requirements (libsystemd >= 209) were not met
However I do not know how to solve this.

Offline

#8 2021-02-17 13:02:46

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,325

Re: Cannot install php74 'No package 'libsystemd' found

Jaylan wrote:

I never used makepkg, I am figuring out how I should do it. Thank you for the reply.

Then how did you install Trizen?

Offline

#9 2021-02-17 13:03:44

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,924

Re: Cannot install php74 'No package 'libsystemd' found

That's not a pacman error message, it is a pkg-config error message.

https://bugs.archlinux.org/task/66762


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#10 2021-02-17 13:09:33

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

It says it needs systemd >= 209, but I seem to be up to date according to this output:
core/systemd-libs 247.3-1 [installed]

Offline

#11 2021-02-17 13:10:42

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,924

Re: Cannot install php74 'No package 'libsystemd' found

Again, that's a pkg-config error message, not a pacman one. See my bug report link.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#12 2021-02-17 13:14:32

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

I read your bug report page, but I don't see a solution or did I miss it ? Thank you a lot again.

Offline

#13 2021-02-17 13:15:49

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,894

Re: Cannot install php74 'No package 'libsystemd' found

post

$ pacman -Qs base-devel
$ pacman -Qo /usr/lib/pkgconfig/libsystemd.pc

Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#14 2021-02-17 13:19:06

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

pacman -Qs base-devel
local/autoconf 2.71-1 (base-devel)
    A GNU tool for automatically configuring source code
local/automake 1.16.3-1 (base-devel)
    A GNU tool for automatically creating Makefiles
local/binutils 2.36-3 (base-devel)
    A set of programs to assemble and manipulate binary and object files
local/bison 3.7.3-1 (base-devel)
    The GNU general-purpose parser generator
local/fakeroot 1.25.3-2 (base-devel)
    Tool for simulating superuser privileges
local/file 5.39-1 (base-devel)
    File type identification utility
local/findutils 4.8.0-1 (base-devel)
    GNU utilities to locate files
local/flex 2.6.4-3 (base-devel)
    A tool for generating text-scanning programs
local/gawk 5.1.0-1 (base-devel)
    GNU version of awk
local/gcc 10.2.0-6 (base-devel)
    The GNU Compiler Collection - C and C++ frontends
local/gettext 0.21-1 (base-devel)
    GNU internationalization library
local/grep 3.6-1 (base-devel)
    A string search utility
local/groff 1.22.4-4 (base-devel)
    GNU troff text-formatting system
local/gzip 1.10-3 (base-devel)
    GNU compression utility
local/libtool 2.4.6+42+gb88cebd5-14 (base-devel)
    A generic library support script
local/m4 1.4.18-3 (base-devel)
    The GNU macro processor
local/make 4.3-3 (base-devel)
    GNU make utility to maintain groups of programs
local/pacman 5.2.2-2 (base-devel)
    A library-based package manager with dependency support
local/patch 2.7.6-8 (base-devel)
    A utility to apply patch files to original sources
local/pkgconf 1.7.3-1 (base-devel)
    Package compiler and linker metadata toolkit
local/sed 4.8-1 (base-devel)
    GNU stream editor
local/sudo 1.9.5.p2-1 (base-devel)
    Give certain users the ability to run some commands as root
local/texinfo 6.7-3 (base-devel)
    GNU documentation system for on-line information and printed output
local/which 2.21-5 (base-devel)
    A utility to show the full path of commands



=================

pacman -Qo /usr/lib/pkgconfig/libsystemd.pc
/usr/lib/pkgconfig/libsystemd.pc is owned by systemd 247.3-1

Offline

#15 2021-02-17 13:33:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,211

Re: Cannot install php74 'No package 'libsystemd' found

Please wrap outputs in

[code]code tags[/code]

Offline

#16 2021-02-17 13:37:51

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

Ok I will next time, thanks. How do you interpret the outputs ?

Offline

#17 2021-02-17 13:40:19

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,894

Re: Cannot install php74 'No package 'libsystemd' found

The output of those 2 commands match what they should be.

create a temporary directory somewhere under your home folder and navigate to it.

$ git clone https://aur.archlinux.org/php74.git
$ cd php74
$ makepkg -Crs --log

Post the content of the log files  (if they're large, use a pastebin client ) .

Last edited by Lone_Wolf (2021-02-17 13:40:45)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#18 2021-02-17 13:45:06

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

makepkg -Crs --log
==> Making package: php74 7.4.15-1 (Wed Feb 17 14:44:22 2021)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading php-7.4.15.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--    100   161  100   161    0     0   1025      0 --:--:-- --:--:-- --:--:--  1025
 21  9.8M   21 2127k    0     0  2235k      0  0:00:04 --:--:--  0:00:04 223 95  9.8M   95 9663k    0     0  5377k      0  0:00:01  0:00:01 --:--:-- 891100  9.8M  100  9.8M    0     0  5489k      0  0:00:01  0:00:01 --:--:-- 8986k
  -> Downloading php-7.4.15.tar.xz.asc...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--    100   161  100   161    0     0    947      0 --:--:-- --:--:-- --:--:--   947
100   833  100   833    0     0   2687      0 --:--:-- --:--:-- --:--:--  2687
  -> Found apache.patch
  -> Found apache.conf
  -> Found php-fpm.patch
  -> Found php-fpm.tmpfiles
  -> Found php.ini.patch
  -> Found phpize.m4.patch
  -> Found enchant-2.patch
==> Validating source files with sha256sums...
    php-7.4.15.tar.xz ... Passed
    php-7.4.15.tar.xz.asc ... Skipped
    apache.patch ... Passed
    apache.conf ... Passed
    php-fpm.patch ... Passed
    php-fpm.tmpfiles ... Passed
    php.ini.patch ... Passed
    phpize.m4.patch ... Passed
    enchant-2.patch ... Passed
==> Verifying source file signatures with gpg...
    php-7.4.15.tar.xz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting php-7.4.15.tar.xz with bsdtar
bsdtar: Failed to set default locale
==> Starting prepare()...
patching file sapi/apache2handler/config.m4
patching file sapi/fpm/Makefile.frag
patching file sapi/fpm/php-fpm.conf.in
patching file sapi/fpm/www.conf.in
patching file sapi/fpm/php-fpm.service.in
Hunk #1 succeeded at 8 with fuzz 1.
patching file php.ini-production
patching file scripts/phpize.m4
patching file ext/enchant/config.m4
patching file ext/enchant/enchant.c
==> Starting build()...
configure: creating cache config.cache
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for pkg-config... /home/linuxbrew/.linuxbrew/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking how to run the C preprocessor... cc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether ln -s works... yes
checking for system library directory... lib
checking whether to enable runpaths... no
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for gawk... gawk
checking for bison... bison
checking for bison version... 3.7.5 (ok)
checking for re2c... re2c
checking for re2c version... 2.0.3 (ok)
checking whether to enable computed goto gcc extension with re2c... no
checking whether C compiler accepts -fvisibility=hidden... yes
checking whether to force non-PIC code in shared modules... no
checking whether /dev/urandom exists... yes
checking for global register variables support... yes
checking whether atof() accepts NAN... no
checking whether atof() accepts INF... no
checking whether HUGE_VAL == INF... yes
checking whether HUGE_VAL + -HUGEVAL == NAN... no
checking whether __cpuid_count is available... yes
checking for pthreads_cflags... -pthread
checking for pthreads_lib... pthread

Configuring SAPI modules
checking for Apache 2 handler module support via DSO through APXS... no
checking for setproctitle... no
checking sys/pstat.h usability... no
checking sys/pstat.h presence... no
checking for sys/pstat.h... no
checking for PS_STRINGS... no
checking for CLI build... yes
checking for embedded SAPI library support... shared
checking for FPM build... yes
checking for clearenv... yes
checking for setproctitle... (cached) no
checking for setproctitle_fast... no
checking for library containing socket... none required
checking for library containing inet_addr... none required
checking for prctl... yes
checking for clock_gettime... yes
checking for ptrace... yes
checking whether ptrace works... yes
checking for proc mem file... mem
checking if gcc supports __sync_bool_compare_and_swap... yes
checking for TCP_INFO... yes
checking for sysconf... yes
checking for times... yes
checking for kqueue... no
checking for port framework... no
checking for /dev/poll... no
checking for epoll... yes
checking for select... yes
checking for apparmor... no
checking for libsystemd >= 209... no
configure: error: Package requirements (libsystemd >= 209) were not met:

No package 'libsystemd' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SYSTEMD_CFLAGS
and SYSTEMD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
    Aborting...

Last edited by Jaylan (2021-02-17 13:45:38)

Offline

#19 2021-02-17 13:49:17

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

[br] php74-7.4.15-1-x86_64-build.log [/br]

configure: creating cache config.cache
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking target system type... x86_64-pc-linux-gnu
checking for pkg-config... /home/linuxbrew/.linuxbrew/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking how to run the C preprocessor... cc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether ln -s works... yes
checking for system library directory... lib
checking whether to enable runpaths... no
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for gawk... gawk
checking for bison... bison
checking for bison version... 3.7.5 (ok)
checking for re2c... re2c
checking for re2c version... 2.0.3 (ok)
checking whether to enable computed goto gcc extension with re2c... no
checking whether C compiler accepts -fvisibility=hidden... yes
checking whether to force non-PIC code in shared modules... no
checking whether /dev/urandom exists... yes
checking for global register variables support... yes
checking whether atof() accepts NAN... no
checking whether atof() accepts INF... no
checking whether HUGE_VAL == INF... yes
checking whether HUGE_VAL + -HUGEVAL == NAN... no
checking whether __cpuid_count is available... yes
checking for pthreads_cflags... -pthread
checking for pthreads_lib... pthread

[1mConfiguring SAPI modules[m
checking for Apache 2 handler module support via DSO through APXS... no
checking for setproctitle... no
checking sys/pstat.h usability... no
checking sys/pstat.h presence... no
checking for sys/pstat.h... no
checking for PS_STRINGS... no
checking for CLI build... yes
checking for embedded SAPI library support... shared
checking for FPM build... yes
checking for clearenv... yes
checking for setproctitle... (cached) no
checking for setproctitle_fast... no
checking for library containing socket... none required
checking for library containing inet_addr... none required
checking for prctl... yes
checking for clock_gettime... yes
checking for ptrace... yes
checking whether ptrace works... yes
checking for proc mem file... mem
checking if gcc supports __sync_bool_compare_and_swap... yes
checking for TCP_INFO... yes
checking for sysconf... yes
checking for times... yes
checking for kqueue... no
checking for port framework... no
checking for /dev/poll... no
checking for epoll... yes
checking for select... yes
checking for apparmor... no
checking for libsystemd >= 209... no
configure: error: Package requirements (libsystemd >= 209) were not met:

No package 'libsystemd' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SYSTEMD_CFLAGS
and SYSTEMD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
[1m[31m==> ERROR:(B[m[1m A failure occurred in build().(B[m
[1m    Aborting...(B[m

Last edited by Jaylan (2021-02-17 13:50:47)

Offline

#20 2021-02-17 13:50:26

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

[br]php74-7.4.15-1-x86_64-prepare.log[/br]

patching file sapi/apache2handler/config.m4
patching file sapi/fpm/Makefile.frag
patching file sapi/fpm/php-fpm.conf.in
patching file sapi/fpm/www.conf.in
patching file sapi/fpm/php-fpm.service.in
Hunk #1 succeeded at 8 with fuzz 1.
patching file php.ini-production
patching file scripts/phpize.m4
patching file ext/enchant/config.m4
patching file ext/enchant/enchant.c

Offline

#21 2021-02-17 13:50:41

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,894

Re: Cannot install php74 'No package 'libsystemd' found

bsdtar: Failed to set default locale

Something is wrong with your locale setup, but that's not the reason of the build fail .

checking for pkg-config... /home/linuxbrew/.linuxbrew/bin/pkg-config

That's the reason for the build failure, you are not using the system pkgconf .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#22 2021-02-17 13:52:28

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

Should I just install the package pkgconf or pkg-config with Trizen ?

Offline

#23 2021-02-17 13:58:13

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,894

Re: Cannot install php74 'No package 'libsystemd' found

pacman -Qs base-devel wrote:

local/pkgconf 1.7.3-1 (base-devel)
    Package compiler and linker metadata toolkit

You already have the correct pkgconf installed.

Remove the one you installed in /home/linuxbrew/.linuxbrew/bin/
OR
change your PATH variable so it looks in /usr/bin before it checks /home/linuxbrew/.linuxbrew/bin/ .

Last edited by Lone_Wolf (2021-02-17 13:58:36)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#24 2021-02-17 14:15:15

Jaylan
Member
Registered: 2021-02-17
Posts: 13

Re: Cannot install php74 'No package 'libsystemd' found

Thank you a lot Lone-Wolf, it is finally installed ! I am gonna mark the thread as SOLVED.
Edit: Can I edit the title of my thread to mark it as SOLVED ?

Last edited by Jaylan (2021-02-17 14:17:55)

Offline

#25 2021-02-17 14:45:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,211

Re: Cannot install php74 'No package 'libsystemd' found

edit your first post then you can edit the title.

Offline

Board footer

Powered by FluxBB