You are not logged in.

#1 2021-02-19 23:01:08

madrafa
Member
Registered: 2021-02-19
Posts: 13

Fresh install ERROR: device '/dev/sdb3' not found. [SOLVED]

I installed Arch linux as a secondary OS on my main disk, everything went as supposed without errors. I have to say that I installed Arch without grub or anything like that since I already had another Linux OS as the host machine and it has grub installed.

After installing I booted into Linux Mint (which is the host) and updated grub. This is the output:

Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.4.0-65-generic
Found initrd image: /boot/initrd.img-5.4.0-65-generic
Found linux image: /boot/vmlinuz-5.4.0-64-generic
Found initrd image: /boot/initrd.img-5.4.0-64-generic
Found linux image: /boot/vmlinuz-5.4.0-26-generic
Found initrd image: /boot/initrd.img-5.4.0-26-generic
Found Arch Linux on /dev/sda3
Adding boot menu entry for UEFI Firmware Settings
done

I have the Arch entry in the grub, but when booting into it, I get this:

:: running early hook [udev]
Starting version 247.3-1-arch
:: running early hook [udev]
:: Triggering uevents...
Waiting 10 seconds for device /dev/sdb3 ...
ERROR: device '/dev/sdb3' not found. Skipping fsck.
:: mounting '/dev/sdb3' on real root
mount: /new_root: no filesystem type specified.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

I didn't install it with encryption. And all of the other post that have seen with this problem have encrypted installations.

I can access Arch from inside Linux Mint without issues. Doing

arch-chroot /path/to/filesystem

I can do everything from there as I was on Arch (using pacman,updating,etc..). Also, the Arch filesystem is automatically mounted when booting into linux Mint, and I can access everything that's on Arch from my file manager. I don't think there's anything wrong with the installation.

Links:
lsblk -f
fstab
mkinitcpio.conf
grub.cfg

Can anyone help me solve this ? or point me in the right direction?

UPDATE:

So I have solved this by modifying the grub.cfg installed in Linux Mint, the problem was the menu entry for Arch Linux setting the root with the name of the device instead of the UUID.

This was the line I've modified in the grub.cfg

linux /boot/vmlinuz-linux-lts root=/dev/sda3

I change it to:

# instead of XXXX use UUID of partition 
linux /boot/vmlinuz-linux-lts root=UUID=XXX

leaving this here in case anyone has the same problem.

Last edited by madrafa (2021-02-20 01:05:46)

Offline

Board footer

Powered by FluxBB