You are not logged in.

#1 2021-02-20 20:07:22

kolana
Member
Registered: 2021-02-12
Posts: 25

WIFI keeps disconnecting in intel wifi card

Hi, I'm encountering annoying WIFI random disconnections on my Arch with Gnome 3 from a while (even the same problem when I used Ubuntu with gnome also).

So, I tried and found many solutions/articles but I dunno what is my exact problem and I wanna a help from experts to figure out the root cause of those random disconnections.

My kernel : 5.10.13-arch1-1

Here is the exact model of my wireless card obtained with "lspci -k"

06:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83) Subsystem: Intel Corporation Dual Band Wireless AC 3160 Kernel driver in use: iwlwifi Kernel modules: iwlwifi

I found that link if it could help : https://wireless.wiki.kernel.org/en/use … rs/iwlwifi

and found that for mine (3160) in that link ?


Those devices will not be supported by the newest firmware versions: the
last firmware that was released for 3160, 7260 and 7265 is -17.ucode.
Bug fixes will be ported to -17.ucode. 7265D, 3165 and 3168's latest
firmware version is -29.ucode. In order to determine if your 7265 device
is a 'D' version, you can check the dmesg output:


As you may already noticed the line "wlp6s0: deauthenticating from c8:94:bb:36:0e:ac by local choice (Reason: 3=DEAUTH_LEAVING)" indicating deauthentication, and i found that link containing the error code explanation https://aboutcher.co.uk/2012/07/linux-w … son-codes/

The access point went offline deauthenticating the client.

found
those solutions on wiki : https://wiki.archlinux.org/index.php/Ne … ctions(but

Please, I've already tried and done many searches for months to no avail.

Thanks!

Last edited by kolana (2021-02-22 17:41:08)

Offline

#2 2021-02-20 20:15:53

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,194
Website

Re: WIFI keeps disconnecting in intel wifi card

Edit your post and wrap the output in code tags: https://wiki.archlinux.org/index.php/Co … s_and_code


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2021-02-20 21:16:56

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

Actually just remove that wall of text and post the output of "sudo journalctl -b", not some random greps.
Also use the tip in the first link of my signature, rather than a unreadable no-newline mess.

Random guess based on the context: Disable https://wiki.archlinux.org/index.php/Ne … domization

Offline

#4 2021-02-21 11:00:46

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

please, see your mail.

Offline

#5 2021-02-21 13:33:59

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

Those logs in usually don't contain really private information, though xdman.desktop is very talky…
There'e only NM & wpa_supplicant, no conflicting services,

1. Did you try to disable the MAC randomization?
If yes,
2. take the vmware bridge of the device (basically try whether you can reproduce this w/o vmware)

3.

Feb 21 11:28:24 Unknown NetworkManager[461]: <info>  [1613903304.1196] device (wlp6s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Feb 21 11:28:24 Unknown NetworkManager[461]: <info>  [1613903304.1200] device (wlp6s0): Activation: (wifi) access point 'Test_nomap' has security, but secrets are required.
Feb 21 11:28:24 Unknown NetworkManager[461]: <info>  [1613903304.1200] device (wlp6s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Feb 21 11:28:24 Unknown NetworkManager[461]: <warn>  [1613903304.1239] device (wlp6s0): no secrets: No agents were available for this request.
Feb 21 11:28:24 Unknown NetworkManager[461]: <info>  [1613903304.1240] device (wlp6s0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Feb 21 11:28:24 Unknown NetworkManager[461]: <info>  [1613903304.1244] manager: NetworkManager state is now DISCONNECTED
Feb 21 11:28:24 Unknown NetworkManager[461]: <warn>  [1613903304.1252] device (wlp6s0): Activation: failed for connection 'Test_nomap'
Feb 21 11:28:24 Unknown NetworkManager[461]: <info>  [1613903304.1254] device (wlp6s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')

MN wanted to ask for the wifi password, but could not (pre-session, GDM, no polkit agent)

4.

Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8359] agent-manager: agent[1835ee0e081bfef1,:1.49/org.gnome.Shell.NetworkAgent/1000]: agent registered
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8360] policy: auto-activating connection 'Test_nomap' (75246a47-76c9-4e33-8487-9e8f81cbd914)
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8364] device (wlp6s0): Activation: starting connection 'Test_nomap' (75246a47-76c9-4e33-8487-9e8f81cbd914)
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8365] device (wlp6s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8368] manager: NetworkManager state is now CONNECTING
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8380] device (wlp6s0): set-hw-addr: reset MAC address to 78:0C:B8:38:9C:6C (preserve)
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8453] device (wlp6s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8460] device (wlp6s0): Activation: (wifi) access point 'Test_nomap' has security, but secrets are required.
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8460] device (wlp6s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8565] device (wlp6s0): supplicant interface state: inactive -> interface_disabled
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8565] device (p2p-dev-wlp6s0): supplicant management interface state: inactive -> interface_disabled
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8848] device (wlp6s0): supplicant interface state: interface_disabled -> inactive
Feb 21 11:29:00 Unknown NetworkManager[461]: <info>  [1613903340.8849] device (p2p-dev-wlp6s0): supplicant management interface state: interface_disabled -> inactive
…
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6062] device (wlp6s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6069] device (wlp6s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6074] device (wlp6s0): Activation: (wifi) connection 'Test_nomap' has security, and secrets exist.  No new secrets needed.
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6075] Config: added 'ssid' value 'Test_nomap'
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6075] Config: added 'scan_ssid' value '1'
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6075] Config: added 'bgscan' value 'simple:30:-70:86400'
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6075] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK'
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6075] Config: added 'psk' value '<hidden>'
…
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6310] device (wlp6s0): supplicant interface state: inactive -> scanning
Feb 21 11:29:02 Unknown NetworkManager[461]: <info>  [1613903342.6310] device (p2p-dev-wlp6s0): supplicant management interface state: inactive -> scanning
…
Feb 21 11:29:06 Unknown wpa_supplicant[575]: wlp6s0: SME: Trying to authenticate with c8:94:bb:36:0e:ac (SSID='Test_nomap' freq=2462 MHz)
Feb 21 11:29:06 Unknown kernel: wlp6s0: authenticate with c8:94:bb:36:0e:ac
Feb 21 11:29:06 Unknown kernel: wlp6s0: send auth to c8:94:bb:36:0e:ac (try 1/3)
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.0393] device (wlp6s0): supplicant interface state: scanning -> authenticating
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.0393] device (p2p-dev-wlp6s0): supplicant management interface state: scanning -> authenticating
Feb 21 11:29:06 Unknown wpa_supplicant[575]: wlp6s0: Trying to associate with c8:94:bb:36:0e:ac (SSID='Test_nomap' freq=2462 MHz)
Feb 21 11:29:06 Unknown kernel: wlp6s0: authenticated
Feb 21 11:29:06 Unknown kernel: wlp6s0: associate with c8:94:bb:36:0e:ac (try 1/3)
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.0452] device (wlp6s0): supplicant interface state: authenticating -> associating
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.0452] device (p2p-dev-wlp6s0): supplicant management interface state: authenticating -> associating
Feb 21 11:29:06 Unknown wpa_supplicant[575]: RRM: Ignoring radio measurement request: Not associated
Feb 21 11:29:06 Unknown kernel: wlp6s0: RX AssocResp from c8:94:bb:36:0e:ac (capab=0x431 status=0 aid=2)
Feb 21 11:29:06 Unknown kernel: wlp6s0: associated
Feb 21 11:29:06 Unknown wpa_supplicant[575]: wlp6s0: Associated with c8:94:bb:36:0e:ac
Feb 21 11:29:06 Unknown wpa_supplicant[575]: wlp6s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Feb 21 11:29:06 Unknown vmnet-natd[539]: RTM_NEWLINK: name:wlp6s0 index:3 flags:0x00011003
Feb 21 11:29:06 Unknown vmnetBridge[508]: RTM_NEWLINK: name:wlp6s0 index:3 flags:0x00011003
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.0576] device (wlp6s0): supplicant interface state: associating -> associated
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.0576] device (p2p-dev-wlp6s0): supplicant management interface state: associating -> associated
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.3026] device (wlp6s0): supplicant interface state: associated -> 4way_handshake
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.3031] device (p2p-dev-wlp6s0): supplicant management interface state: associated -> 4way_handshake
Feb 21 11:29:06 Unknown wpa_supplicant[575]: wlp6s0: WPA: Key negotiation completed with c8:94:bb:36:0e:ac [PTK=CCMP GTK=TKIP]
Feb 21 11:29:06 Unknown wpa_supplicant[575]: wlp6s0: CTRL-EVENT-CONNECTED - Connection to c8:94:bb:36:0e:ac completed [id=0 id_str=]
Feb 21 11:29:06 Unknown kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp6s0: link becomes ready
Feb 21 11:29:06 Unknown vmnetBridge[508]: RTM_NEWLINK: name:wlp6s0 index:3 flags:0x00011043
Feb 21 11:29:06 Unknown vmnet-natd[539]: RTM_NEWLINK: name:wlp6s0 index:3 flags:0x00011043
Feb 21 11:29:06 Unknown vmnetBridge[508]: Adding interface wlp6s0 index:3
Feb 21 11:29:06 Unknown vmnetBridge[508]: Started bridge wlp6s0 to virtual network 0.
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.3968] device (wlp6s0): supplicant interface state: 4way_handshake -> completed
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.3968] device (wlp6s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "Test_nomap"
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.3968] device (p2p-dev-wlp6s0): supplicant management interface state: 4way_handshake -> completed
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.3970] device (wlp6s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.3974] dhcp4 (wlp6s0): activation: beginning transaction (timeout in 45 seconds)

You're connected to the wifi and query a lease.

Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.6081] dhcp4 (wlp6s0): state changed unknown -> expire
Feb 21 11:29:07 Unknown dbus-daemon[854]: [session uid=1000 pid=854] Successfully activated service 'org.freedesktop.FileManager1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5256] dhcp4 (wlp6s0): option dhcp_lease_time      => '86400'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5256] dhcp4 (wlp6s0): option domain_name          => 'Home'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option domain_name_servers  => '9.9.9.9 149.112.112.112'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option expiry               => '1613989746'
Feb 21 11:29:08 Unknown vmnet-natd[539]: RTM_NEWADDR: index:3, addr:192.168.1.11
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option ip_address           => '192.168.1.11'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_broadcast_address => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_domain_name => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_domain_name_servers => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_domain_search => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_host_name  => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_interface_mtu => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_ms_classless_static_routes => '1'
Feb 21 11:29:08 Unknown vmnet-natd[539]: RTM_NEWROUTE: index:3
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_nis_domain => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_nis_servers => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_ntp_servers => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_rfc3442_classless_static_routes => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_root_path  => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_routers    => '1'
Feb 21 11:29:08 Unknown vmnetBridge[508]: RTM_NEWROUTE: index:3
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_static_routes => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option requested_subnet_mask => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option requested_time_offset => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option requested_wpad       => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option routers              => '192.168.1.1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option subnet_mask          => '255.255.255.0'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): state changed expire -> bound
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5288] device (wlp6s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
…
Feb 21 11:29:06 Unknown NetworkManager[461]: <info>  [1613903346.6081] dhcp4 (wlp6s0): state changed unknown -> expire
Feb 21 11:29:07 Unknown dbus-daemon[854]: [session uid=1000 pid=854] Successfully activated service 'org.freedesktop.FileManager1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5256] dhcp4 (wlp6s0): option dhcp_lease_time      => '86400'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5256] dhcp4 (wlp6s0): option domain_name          => 'Home'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option domain_name_servers  => '9.9.9.9 149.112.112.112'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option expiry               => '1613989746'
Feb 21 11:29:08 Unknown vmnet-natd[539]: RTM_NEWADDR: index:3, addr:192.168.1.11
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option ip_address           => '192.168.1.11'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_broadcast_address => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_domain_name => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_domain_name_servers => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_domain_search => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5257] dhcp4 (wlp6s0): option requested_host_name  => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_interface_mtu => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_ms_classless_static_routes => '1'
Feb 21 11:29:08 Unknown vmnet-natd[539]: RTM_NEWROUTE: index:3
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_nis_domain => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_nis_servers => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_ntp_servers => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_rfc3442_classless_static_routes => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_root_path  => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_routers    => '1'
Feb 21 11:29:08 Unknown vmnetBridge[508]: RTM_NEWROUTE: index:3
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5258] dhcp4 (wlp6s0): option requested_static_routes => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option requested_subnet_mask => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option requested_time_offset => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option requested_wpad       => '1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option routers              => '192.168.1.1'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): option subnet_mask          => '255.255.255.0'
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5259] dhcp4 (wlp6s0): state changed expire -> bound
Feb 21 11:29:08 Unknown NetworkManager[461]: <info>  [1613903348.5288] device (wlp6s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')

Congrats, you've internet.

Feb 21 11:33:38 Unknown wpa_supplicant[575]: wlp6s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-60 noise=9999 txrate=81000

Next and last network status (signal strength change)

=> Is this journal supposed to have covered a disconnection? How do you determine those?

Offline

#6 2021-02-21 17:38:38

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

For MAC randomization, there is no file under /etc/NetworkManager/conf.d/. Should I create It ?

=> Is this journal supposed to have covered a disconnection? How do you determine those?

Reply : yes it covered a disconnection.

How do you determine those?

Reply: what do you mean ?

take the vmware bridge of the device

Reply : how can achieve that and why?

Last edited by kolana (2021-02-21 17:43:26)

Offline

#7 2021-02-21 18:42:32

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

You can use quote tags, https://bbs.archlinux.org/help.php#bbcode

[qutoe]Should I create It ?[/qutoe]
"Obviously"

what do you mean?

How do you notice that the wifi disconnects? What's the output of "ip a; ip r" when this happens?

how can achieve that and why?

Simply don't use vmware for a trial period.

Offline

#8 2021-02-21 18:57:18

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

How do you notice that the wifi disconnects? What's the output of "ip a; ip r" when this happens?

I notice when WiFi icon in above gnome panel disappear or become green, then i ping an address such 1.1.1.1 to test connectivity until it came back.

Simply don't use vmware for a trial period.

Ok, I won't use vmware those days to test if it causes the problem, but should run any command to guarantee that there is no service associated to it running ?


But, what about mac randomization, should i create that file ? (I told you that the directory doesn't contain any file)

Last edited by kolana (2021-02-21 19:01:13)

Offline

#9 2021-02-21 19:07:38

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

But, what about mac randomization, should i create that file ?

and seth to that wrote:

Obviously

I notice when WiFi icon in above gnome panel disappear or become green, then i ping an address such 1.1.1.1 to test connectivity until it came back.

That's not a very good test to check the wifi status, your ISP could take a nap.

Offline

#10 2021-02-21 19:17:08

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

For the mac random, i did it, but you haven't responded me for what i wrote about vmware

That's not a very good test to check the wifi status, your ISP could take a nap.

what's the best way then ?

Offline

#11 2021-02-21 19:23:33

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

Check the output of "ip a; ip r", it'll tell you whetehr you've route, lease, carrier and the NIC is up.

About vmware, see above - you don't want the vmware bridge in "ip a".

Offline

#12 2021-02-21 19:32:13

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

this is the out of both ip -a, -r

default via 192.168.1.1 dev wlp6s0 proto dhcp metric 600 
172.16.162.0/24 dev vmnet8 proto kernel scope link src 172.16.162.1 
192.168.1.0/24 dev wlp6s0 proto kernel scope link src 192.168.1.11 metric 600 
192.168.240.0/24 dev vmnet1 proto kernel scope link src 192.168.240.1 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether f8:ca:b8:03:aa:4d brd ff:ff:ff:ff:ff:ff
3: wlp6s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 78:0c:b8:38:9c:6c brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.11/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp6s0
       valid_lft 83792sec preferred_lft 83792sec
    inet6 fdc8:94bb:360e:a500:4e0e:6a5a:6c4a:274c/64 scope global dynamic noprefixroute 
       valid_lft 6919sec preferred_lft 3319sec
    inet6 fe80::a245:b651:3e7d:a0d2/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
4: vmnet1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 00:50:56:c0:00:01 brd ff:ff:ff:ff:ff:ff
    inet 192.168.240.1/24 brd 192.168.240.255 scope global vmnet1
       valid_lft forever preferred_lft forever
    inet6 fe80::250:56ff:fec0:1/64 scope link 
       valid_lft forever preferred_lft forever
5: vmnet8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 00:50:56:c0:00:08 brd ff:ff:ff:ff:ff:ff
    inet 172.16.162.1/24 brd 172.16.162.255 scope global vmnet8
       valid_lft forever preferred_lft forever
    inet6 fe80::250:56ff:fec0:8/64 scope link 
       valid_lft forever preferred_lft forever

How can i remove vmware entry in ip -a ?

Offline

#13 2021-02-21 19:44:53

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

vmware adds /etc/xdg/autostart/vmware-user.desktop, shadow that and hide it, https://wiki.archlinux.org/index.php/XDG_Autostart
Also some systemd services that you should probably not have enabled.

Offline

#14 2021-02-21 19:56:37

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

Ok, i haven't found  /etc/xdg/autostart/vmware-user.desktop then i created it and put Hidden=true inside, what should i do next ?

Offline

#15 2021-02-21 20:31:52

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

Remove it again.
How did you install vmware? (which package)

Offline

#16 2021-02-21 20:40:49

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

Offline

#17 2021-02-21 20:42:22

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

Disable vmware-networks.service

Offline

#18 2021-02-21 20:52:06

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

done with sudo systemctl stop vmware-networks.service

Offline

#19 2021-02-21 21:00:44

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

If you don't disable it, it'll restart w/ the next reboot.

Offline

#20 2021-02-21 21:08:49

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

ok done sudo systemctl disable vmware-networks.service after stopping it, is that fine ?

Offline

#21 2021-02-22 10:14:23

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

the problem reoccurred today, here is the log

here is the log : https://www.sendspace.com/file/m7vqvb (size exceeded forum+pastebin limit for that i uploaded here )

Last edited by kolana (2021-02-22 10:15:01)

Offline

#22 2021-02-22 13:09:58

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

this is a recent log file : https://www.sendspace.com/file/v9zo11

To let you know I have the same problem in ubuntu with gnome before switching to arch.

Offline

#23 2021-02-22 13:54:50

seth
Member
Registered: 2012-09-03
Posts: 18,969

Re: WIFI keeps disconnecting in intel wifi card

In both logs you run wireshark and then later lose the beacon and cannot recover from that (you do actually associate but are immediately cut again)
The arch log has several successful connections previous to the wireshark invocation (mostly from sleep/resume)

=> is wireshark the trigger for this?

Offline

#24 2021-02-22 15:43:57

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

yeah, i opened wireshark today but i dunno if he is the cause of that disconnecting

So, i will not use it anymore and if the problem will happen again i'll upload the log.

Last edited by kolana (2021-02-22 15:46:14)

Offline

#25 2021-02-22 15:51:01

kolana
Member
Registered: 2021-02-12
Posts: 25

Re: WIFI keeps disconnecting in intel wifi card

it happened again here is the log : https://www.sendspace.com/file/v9huv9

Offline

Board footer

Powered by FluxBB