You are not logged in.

#1 2021-03-05 15:15:35

AugustineC
Member
Registered: 2021-03-04
Posts: 12

[Solved] Microphone on XPS 9700

Hi guys.

Thanks to driver makers, since PulseAudio 14.0 and Linux 5.10, according to the Wiki, speaker works fine after simply installing pulseaudio and sof-firmware.

However, I still found microphone not working.

The situation is

0 I have already installed pulseaudio (14.2) and sof-firmware, with arch linux of kernel 5.11.2 on device XPS 17 9700.

1. I am able to detect the microphone

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Comet Lake PCH cAVS [8086:06c8]
	Subsystem: Dell Device [1028:098f]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64
	Interrupt: pin A routed to IRQ 228
	Region 0: Memory at 609b218000 (64-bit, non-prefetchable) [size=16K]
	Region 4: Memory at 609b100000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: <access denied>
	Kernel driver in use: sof-audio-pci
	Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci

2. I am able to select between microphones
One is "Comet Lake PCH cAVS SoundWire microphones",
and another is "Comet Lake PCH cAVS Headset Microphone"

3. When using the microphone, there is a microphone usage sign in the system tray
(Comet Lake PCH cAVS SoundWire microphones)

4. BUT I still cannot input any sound

5. The situation remains the same when I use either built-in microphone or bluetooth device.

Any suggestions? Thanks in advance.

Sorry if this question is dumb. When it comes to hardware, I am totally unexperienced.

Last edited by AugustineC (2021-03-15 20:03:17)

Offline

#2 2021-03-10 01:41:45

masonj188
Member
Registered: 2021-03-10
Posts: 1

Re: [Solved] Microphone on XPS 9700

I'm having the same issue, everything worked fine a couple weeks ago but I can't narrow it down to a kernel or pulseaudio update that caused it to stop working again.

Offline

#3 2021-03-10 14:37:14

AugustineC
Member
Registered: 2021-03-04
Posts: 12

Re: [Solved] Microphone on XPS 9700

Hi, than that is interesting. I thought that it was me who failed to install something. If there is any update, please reply here. I will do so as well.

Offline

#4 2021-03-15 20:02:48

AugustineC
Member
Registered: 2021-03-04
Posts: 12

Re: [Solved] Microphone on XPS 9700

Hi, I think that I have figured it out. Here are links to screenshots of my configurations:
https://www.dropbox.com/s/hmnjyvycaqy6e … 1.png?dl=0
https://www.dropbox.com/s/isq8jhks2pgkm … 2.png?dl=0

Offline

#5 2021-06-11 09:01:14

avanderbergh
Member
Registered: 2021-06-05
Posts: 2

Re: [Solved] Microphone on XPS 9700

I had the same issue.

Adding the following to /etc/modprobe.d/snd-hda-intel.conf did the trick for me.

options snd-hda-intel enable_msi=1

Offline

Board footer

Powered by FluxBB