You are not logged in.

#1 2021-03-09 12:49:38

Gregosky
Member
From: UK
Registered: 2013-07-26
Posts: 143

Bluetooth audio disconnects after update

I was using my bluetooth headphones with pulse audio without any issues until a few weeks ago.
After updating the system a few weeks ago audio works for some time and then disconnects, it happens after similar time  when I listen to the music. When I do not listen to the music (i.e. leave my laptop running overnight) then strangely bluetooth does not disconnect.
I was hoping that I'm not the only one with this issue and that it will be fixed in next update but I updated the system recently and even though there were updates for bluetooth packages the behavior is still the same.

This is how I start bluetooth:

sudo systemctl start bluetooth
sleep 5
echo -e "power on\nagent on\ndefault-agent\nconnect XX:XX:XX:XX:XX:XX" | bluetoothctl

Some time passes (usually about an hour) and I get disconnect with following log in journal:

mar 09 13:02:06 lenovo bluetoothd[103250]: profiles/audio/avdtp.c:handle_unanswered_req() No reply to Suspend request
mar 09 13:02:06 lenovo pulseaudio[1392]: Failed to release transport /org/bluez/hci0/dev_FC_58_FA_00_BB_DA/sep1/fd5: Input/output error
mar 09 13:02:06 lenovo plasmashell[1353]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:153: TypeError: Value is undefined and could not be converted to an object
mar 09 13:02:06 lenovo plasmashell[1353]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:153: TypeError: Value is undefined and could not be converted to an object
mar 09 13:02:06 lenovo dbus-daemon[894]: [system] Rejected send message, 0 matched rules; type="method_return", sender=":1.43" (uid=1000 pid=1392 comm="/usr/bin/pulseaudio --daemonize=no --log-target=jo") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.148" (uid=0 pid=103250 comm="/usr/lib/bluetooth/bluetoothd ")
mar 09 13:02:06 lenovo plasmashell[1353]: org.kde.plasma.pulseaudio: No object for name "bluez_sink.FC_58_FA_00_BB_DA.a2dp_sink"
mar 09 13:02:08 lenovo bluetoothd[103250]: src/service.c:btd_service_connect() a2dp-sink profile connect failed for FC:58:FA:00:BB:DA: Device or resource busy
mar 09 13:02:08 lenovo bluetoothd[103250]: plugins/policy.c:reconnect_timeout() Reconnecting services failed: Device or resource busy (16)
mar 09 13:02:08 lenovo bluetoothd[103250]: profiles/audio/a2dp.c:a2dp_select_capabilities() Unable to select SEP
mar 09 13:02:09 lenovo kernel: input: BT1002 (AVRCP) as /devices/virtual/input/input38
mar 09 13:02:09 lenovo systemd-logind[899]: Watching system buttons on /dev/input/event28 (BT1002 (AVRCP))
mar 09 13:02:14 lenovo plasmashell[1353]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:231:37: Unable to assign [undefined] to QPulseAudio::VolumeObject*
mar 09 13:02:14 lenovo plasmashell[1353]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:231: TypeError: Cannot read property 'visible' of null
mar 09 13:02:14 lenovo plasmashell[1353]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:231: TypeError: Cannot read property 'visible' of null

What I would like to ask is if above log indicates some obvious problems and for some guidance how can I debug it further.

Many thanks!

Last edited by Gregosky (2021-03-09 12:52:08)

Offline

#2 2021-03-10 10:22:13

impaler33
Member
Registered: 2021-03-10
Posts: 3

Re: Bluetooth audio disconnects after update

I am having a very very very similar issue, although it is with a pair of earbuds, but I am glad that I am not the only one.
I even tried changing distro, however the problem persists.

Downgrading the linux firmware did not seem to resolve the issue either, but perhaps this is something you can look into as well? I mean, it is worth a shot (I have the intel ax2000 network card in my machine, which also serves bluetooth).
Tomorrow I will be getting a bluetooth  usb dongle. I will report back if that resolves the issue.

Other than that I have no clue what the issue may be.
It could be anything, and debugging pulseaudio itself also seems like a hassle, if the problem is with pulseaudio that is.

Offline

#3 2021-03-10 20:58:09

thomasdh
Member
Registered: 2021-03-10
Posts: 3

Re: Bluetooth audio disconnects after update

I am also facing this issue for about a week now. I am on Arch based 5.10.19-1-MANJARO.

Offline

#4 2021-03-10 21:17:12

Gregosky
Member
From: UK
Registered: 2013-07-26
Posts: 143

Re: Bluetooth audio disconnects after update

I updated today, since there was some updates related to bluetooth - still no improvement.

I guess this might be a bug that needs to be reported somewhere - would anybody have any idea? My guess would be binaries laying underneath bluetoothd.

Offline

#5 2021-03-12 16:57:36

filotek
Member
Registered: 2018-08-15
Posts: 8

Re: Bluetooth audio disconnects after update

A few people were successful in solving the problem by downgrading their linux-firmware package from 20210208.b79d239-1 down to 20201218.646f159-1.   Largely for users of the AX200 (or AX201) chipset, as there was an update to this chipset on the 8th of February.

https://bbs.archlinux.org/viewtopic.php?id=263040

I myself have a Lenovo T14s with the AX201 chipset and reverting this firmware completely solved the problem for me.  Though it seems there are still some with the same chipset still having random bluetooth audio disconnect problems so you're mileage may vary.

Offline

#6 2021-03-16 19:54:28

thomasdh
Member
Registered: 2021-03-10
Posts: 3

Re: Bluetooth audio disconnects after update

That is great to hear, thank you for responding! Could you give me some directions on how to downgrade this firmware? I found this, but I was wondering if there is a way to just downgrade the firmware, instead of all the packages.

Last edited by thomasdh (2021-03-17 08:36:40)

Offline

#7 2021-03-18 21:32:34

filotek
Member
Registered: 2018-08-15
Posts: 8

Re: Bluetooth audio disconnects after update

Hey @thomasdh

Any repo dated prior to 2021-02-08 should give you the package you need to downgrade to the previous version.  For the following URL, I just picked 2021-01-01 and that pointed to the linux-firmware package released on Dec 18th, 2020.

https://archive.archlinux.org/repos/202 … kg.tar.zst

If you let pacman install the package using the url, I believe it'll auto-fetch the signature and verify it for you as well.

sudo pacman --cachedir=/tmp -U https://archive.archlinux.org/repos/2021/01/01/core/os/x86_64/linux-firmware-20201218.646f159-1-any.pkg.tar.zst

The --cachedir=tmp argument is usually not necessary unless the package is already in your cache, at which point it'll avoid downloading the .sig file then cause an error.  It's a known bug in pacman.  Using this argument repoints the cache directory to /tmp and avoids the issue altogether.

EDIT:  GACK... I see you're using Manjaro.  I can't recommend the above... you're mileage may vary.

Last edited by filotek (2021-03-18 21:34:23)

Offline

#8 2021-03-19 19:22:15

mokkurkalve
Member
From: Bergen, Norway
Registered: 2009-08-29
Posts: 45

Re: Bluetooth audio disconnects after update

I have a Klipsch KMC1 bluetooth speaker I connect to (which are seen as headphones by pulseaudio). The bluetooth chip in my laptop are on Intel AX201NGW.
The speaker are regulary disconnected and reconnected with the two last versions of package linux-firmware. There are a period of time between disconnects.
Downgrading to linux-firmware 20201218.646f159-1 fixes the issue totally.
Are there any bugreports filed for this issue as seemingly more people than me experience this?


"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
- Oceania Association of Autonomous Astronauts

Offline

#9 2021-03-20 21:00:36

Gregosky
Member
From: UK
Registered: 2013-07-26
Posts: 143

Re: Bluetooth audio disconnects after update

There was an update to linux-firmware package, after updating I left my headphones playing music for whole day and had disconnects followed by automatic reconnects - normally I would see them disconnected after an hour and not reconnected again. It's still annoying but at least I don't have to reconnect manually...

Last edited by Gregosky (2021-03-20 22:20:16)

Offline

#10 2021-03-20 22:40:27

mokkurkalve
Member
From: Bergen, Norway
Registered: 2009-08-29
Posts: 45

Re: Bluetooth audio disconnects after update

Gregosky wrote:

There was an update to linux-firmware package, after updating I left my headphones playing music for whole day and had disconnects followed by automatic reconnects - normally I would see them disconnected after an hour and not reconnected again. It's still annoying but at least I don't have to reconnect manually...

Yes, this is what happens to me too with latest firmware. Reconnects 1 - 4 times per hour. However that's still annoying, especially if your listening to radio or an podcast, trying to follow a train of thought. Losing whole sentences.
So I'll prefer linux-firmware 20201218.646f159-1. No disconnects in the first place.


"ONLY THOSE WHO ATTEMPT THE IMPOSSIBLE WILL ACHIEVE THE ABSURD"
- Oceania Association of Autonomous Astronauts

Offline

#11 2021-03-24 22:30:25

thomasdh
Member
Registered: 2021-03-10
Posts: 3

Re: Bluetooth audio disconnects after update

@filotek thank you very much for your kind help! I tried your suggestion, but it did not solve the problem (like you already expected). I 'solved' it by putting back my old intel 3165ac, haha.

Offtopic: would you recommend to trade Manjaro for Arch? I have another problem with 'oldroot not being able to be unmounted when shutting down', which has something to do with the nvidia drivers I guess. The problem annoys me that much that I am thinking about swapping distro, but I really like the documentation and AUR of an Arch based system, so that I don't want to swap.

Offline

#12 2021-03-24 22:51:07

Gregosky
Member
From: UK
Registered: 2013-07-26
Posts: 143

Re: Bluetooth audio disconnects after update

I noticed I get more disconnects of my Bluetooth headset if I'm more active with my Bluetooth mouse. Tomorrow I'll work on my wired mouse for the whole day, maybe I won't get disconnects smile

Offline

#13 2021-03-25 09:48:31

Gregosky
Member
From: UK
Registered: 2013-07-26
Posts: 143

Re: Bluetooth audio disconnects after update

Nope, switching away from my bluetooth mouse did not improve the situation with breaking audio..

Offline

#14 2021-03-28 18:27:34

bestfriend
Member
Registered: 2020-08-04
Posts: 1

Re: Bluetooth audio disconnects after update

Same issue for the last month or two. Bluetooth devices disconnect and reconnect within a minute or so. This happens several times a day. Hah - it happened right now. Not too familiar with what's going on here:

journalctl -b | grep bluetoothd

2021-03-28T11:02:05-0700 bestfriend dbus-daemon[839]: [system] Rejected send message, 0 matched rules; type="method_return", sender=":1.34" (uid=1000 pid=1790 comm="/usr/bin/pulseaudio --daemonize=no --log-target=jo" label="unconfined") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.12" (uid=0 pid=1488 comm="/usr/lib/bluetooth/bluetoothd " label="unconfined")
2021-03-28T11:02:07-0700 bestfriend bluetoothd[1488]: plugins/policy.c:reconnect_timeout() Reconnecting services failed: Operation already in progress (114)
2021-03-28T11:02:10-0700 bestfriend bluetoothd[1488]: /org/bluez/hci0/dev_F4_4E_FC_D7_40_43/fd5: fd(41) ready

Offline

#15 2021-04-10 10:57:55

tejohnso
Member
Registered: 2014-01-23
Posts: 4

Re: Bluetooth audio disconnects after update

Same issue here every 20mins or so, starting with

> bluetoothd: profiles/audio/avdtp.c:handle_unanswered_req() No reply to Suspend request
> pulseaudio: Failed to release transport /org/bluez/hci0/dev_B4_1A_1D_59_07_8F/sep1/fd0: Input/output error

Started happening after an update about a month ago and was not corrected after several subsequent updates.
Currently on 5.11.12-arch1-1

Offline

#16 2021-04-24 23:06:55

jadelord
Member
Registered: 2015-10-12
Posts: 24

Re: Bluetooth audio disconnects after update

I experience something similar for at least a few months now: bluetooth headset stays connected for several minutes. Then it disconnects for a minute or two and reconnects again. I am using KDE and running the linux-lts kernel 5.10.31-1-lts.

Excerpt from journalctl when the connection dropped:

Apr 25 00:52:33 archmage bluetoothd[941]: profiles/audio/avdtp.c:handle_unanswered_req() No reply to Suspend request
Apr 25 00:52:33 archmage bluetoothd[941]: src/profile.c:ext_io_disconnected() Unable to get io data for Headset Voice gateway: getpeername: Transport endpoint is not connected (107)
Apr 25 00:52:33 archmage pulseaudio[1350]: Failed to release transport /org/bluez/hci0/dev_00_16_94_45_6D_28/sep1/fd1: Input/output error
Apr 25 00:52:33 archmage dbus-daemon[547]: [system] Rejected send message, 0 matched rules; type="method_return", sender=":1.57" (uid=1001 pid=1350 comm="/usr/bin/pulseaudio --daemonize=no>
Apr 25 00:52:33 archmage kdeconnectd[1347]: org.kde.pulseaudio: No object for name "bluez_sink.00_16_94_45_6D_28.a2dp_sink"
Apr 25 00:52:33 archmage plasmashell[1138743]: org.kde.plasma.pulseaudio: No object for name "bluez_sink.00_16_94_45_6D_28.a2dp_sink"
Apr 25 00:52:33 archmage plasmashell[1138743]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:231: TypeError: Cannot read property 'visible' of null
Apr 25 00:52:33 archmage plasmashell[1138743]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:231: TypeError: Cannot read property 'visible' of null
Apr 25 00:52:34 archmage bluetoothd[941]: src/service.c:btd_service_connect() a2dp-sink profile connect failed for 00:16:94:45:6D:28: Device or resource busy
Apr 25 00:52:34 archmage bluetoothd[941]: plugins/policy.c:reconnect_timeout() Reconnecting services failed: Device or resource busy (16)
Apr 25 00:52:35 archmage bluetoothd[941]: /org/bluez/hci0/dev_00_16_94_45_6D_28/sep1/fd2: fd(40) ready
Apr 25 00:52:36 archmage bluetoothd[941]: profiles/audio/avctp.c:uinput_create() Can't open input device: No such file or directory (2)
Apr 25 00:52:36 archmage bluetoothd[941]: profiles/audio/avctp.c:init_uinput() AVRCP: failed to init uinput for HD 4.50BTNC

EDIT: Downgrading to linux-firmware 20201218.646f159-1 has worked for me.

Last edited by jadelord (2021-04-29 11:18:52)

Offline

#17 2021-04-26 08:29:25

jadelord
Member
Registered: 2015-10-12
Posts: 24

Re: Bluetooth audio disconnects after update

It seems the package linux-firmware in the testing repo has some patches for Intel AX201. See this commit. I however have AX200 in my laptop.

Offline

Board footer

Powered by FluxBB