You are not logged in.

#1 2021-03-10 14:33:44

brooqs
Member
Registered: 2015-06-12
Posts: 4

heimdal-gssapi package

Hi everybody,

I am currently trying to compile Openvas software. I cannot find a required package in archlinux during the compile process of the Openvas-smb package. I have tried gssapi and similar packages but have not been successful. Could someone tell me the name of this package or equivalent package that previously compiled openvas?

This package is available for ubuntu. However, I do not want to leave the place where I feel safe.

- Checking for module 'heimdal-gssapi> = 1.6.0'
- Package 'heimdal-gssapi', required by 'virtual: world', not found

Thanks.

Offline

#2 2021-03-11 11:23:29

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,024

Re: heimdal-gssapi package

I can't find a PKGBUILD for openvas-smb in aur or official repos.

If you are using a PKGBUILD please post it. If not, please link to the build instructions you followed.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-03-12 06:45:09

brooqs
Member
Registered: 2015-06-12
Posts: 4

Re: heimdal-gssapi package

Hello Lone_Wolf,

Thank you for answering. I follow the instructions you can reach it at https://github.com/greenbone/openvas-sm … INSTALL.md.

Thanks.

Offline

#4 2021-03-15 20:50:07

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,024

Re: heimdal-gssapi package

Looked at those instructions and the problem appears to be archlinux switched from heimdal to krb5 years ago.
Even AUR doesn't have heimdal packages.

krb5 does provide pkgconfig files for gssapi, but those are not enough for openvas detection .

$ pacman -Ql krb5 | grep gssapi
krb5 /usr/include/gssapi.h
krb5 /usr/include/gssapi/
krb5 /usr/include/gssapi/gssapi.h
krb5 /usr/include/gssapi/gssapi_alloc.h
krb5 /usr/include/gssapi/gssapi_ext.h
krb5 /usr/include/gssapi/gssapi_generic.h
krb5 /usr/include/gssapi/gssapi_krb5.h
krb5 /usr/include/gssapi/mechglue.h
krb5 /usr/include/gssrpc/auth_gssapi.h
krb5 /usr/lib/libgssapi_krb5.so
krb5 /usr/lib/libgssapi_krb5.so.2
krb5 /usr/lib/libgssapi_krb5.so.2.2
krb5 /usr/lib/pkgconfig/krb5-gssapi.pc
krb5 /usr/lib/pkgconfig/mit-krb5-gssapi.pc
$ 

I suggest you check with openvas-smb developers and ask whether openvas-smb can be used with krb5 .


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

Board footer

Powered by FluxBB