You are not logged in.

#1 2021-03-14 16:37:33

harukai
Member
From: Japan
Registered: 2021-03-14
Posts: 2

[SOLVED] ERROR: device 'UUID=...' not found. Skipping fsck.

I'm getting this error after following arch installation from the wiki for EFI systems, as I am dual booting Arch from a windows laptop (ASUS Zenbook 13) that has a 1TB nvme SSD in it.
I've modified some steps from other sources that also use a nvme ssd in their examples.

Starting version 247.3-1-arch
ERROR: device 'UUID=...' not found. Skipping fsck.
mount: /new_root: can't find UUID=...
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

My devices with `fdisk -l`:

Disk /dev/sda: 14.44GiB * bytes, * sectors
Disk model: DataTraveler 3.0
...
Disklabel type: gpt
Disk identifier: *

Device        Start     End              Sectors       Size       Type
/dev/sda1    2048    30277598    30275551    14.4G    Microsoft basic data


Disk /dev/loop0: 602.61MiB, * bytes * sectors


Disk /dev/nvme0n1: 953.87GiB, * bytes, * sectors
Disk model: INTEL SSDPEKNW010TB
...
Disklabel type: gpt
Disk identifier: *

/dev/nvme0n1p1     260M        EFI System
/dev/nvme0n1p2     16M          Microsoft Reserved
/dev/nvme0n1p3     269.1G     Microsoft Basic Data
/dev/nvme0n1p4     950M        Windows recovery environment

Partitioning:
I use fdisk to create:
  - /dev/nvme0n1p5 - 512M - EFI System
  - /dev/nvme0n1p6 - 600GB - Linux filesystem
  - /dev/nvme0n1p7 - 16GB - Swap

Formatting:

mkfs.fat -F32 /dev/nvme0n1p5
mkfs.ext4 /dev/nvme0n1p6
mkswap /dev/nvme0n1p7
swapon /dev/nvme0n1p7

Mounting:

mount /dev/nvme0n1p6 /mnt
mkdir /mnt/boot
mount /dev/nvme0n1p5 /mnt/boot

`genfstab -U /mnt >> /mnt/etc/fstab`

fstab file has all 3 new partitions with UUID label.

I arch-chroot /mnt and go through setting up timezone/other settings.

Grub Bootloader:

pacman -S grub efibootmgr os-prober
grub-install --target=x86_64-efi - - efi-directory=/boot  --bootloader-id=GRUB
mkdir /mnt/windows10
mount /dev/nvme0n1p1 /mnt/windows10
grub-mkconfig -o /boot/grub/grub.cfg

Then I reboot and upon selecting arch from grub, I get greeted with the error.

Something I've noticed from the emergency shell is that i'm actually inside Disk /dev/sda, and not /dev/nvme0n1.
I can confirm this by trying to `mount /dev/nvme0n1p6 new_root`, and then checking blkid showing none of my ssd partitions.
I cannot pinpoint which step has the configuration to load the correct partition, does it have to do with my fstab? or my grub.cfg?
Both my fstab and grub.cfg point to /dev/nvme0n1 device's partition UUID labels, so I get the feeling I am missing something else.

I've already nuked my partitions 3 times and trying out refind and using cfdisk, I'm hoping someone can help point out if I'm doing something wrong with a device setup like in my `fdisk -l` description.

Thanks in advance.

EDIT 3/15/2021

The problem was that this laptop's bios cannot switch the nvme drive to UEFI mode. I remounted my partitions through my bootable usb, arch-chrooted, and edited + remade the mkinitcpio.conf with MODULES=( vmd ). Rebooted into grub, and the arch boot works now.

Credit goes to u/V1del from reddit.

Last edited by harukai (2021-03-15 12:32:15)

Offline

#2 2021-03-14 16:45:26

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,632

Re: [SOLVED] ERROR: device 'UUID=...' not found. Skipping fsck.

Why create the 2nd EFI partition? You should share the one that you already have for your Windows install...
https://wiki.archlinux.org/index.php/Du … FI_systems


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2021-03-15 00:54:08

harukai
Member
From: Japan
Registered: 2021-03-14
Posts: 2

Re: [SOLVED] ERROR: device 'UUID=...' not found. Skipping fsck.

I've just tried using the window's EFI boot partition as /boot instead of making a new one on a new install, and it still drops me into the emergency shell.

Offline

#4 2021-07-22 18:49:43

some1
Member
Registered: 2021-07-22
Posts: 1

Re: [SOLVED] ERROR: device 'UUID=...' not found. Skipping fsck.

As you mentioned in your EDIT, unless you need VMD just turn it off in BIOS/UEFI at it worked for me.

Offline

#5 2022-06-01 18:45:28

c4sc4deb4dge
Member
Registered: 2021-10-14
Posts: 1

Re: [SOLVED] ERROR: device 'UUID=...' not found. Skipping fsck.

hey thanks so much for posting this solution! It helped me immensely, I've been pulling my hair out trying to get this done!

Offline

#6 2022-06-01 18:50:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,668

Re: [SOLVED] ERROR: device 'UUID=...' not found. Skipping fsck.

Hmm I was under the impression the vmd module woes should've been solved a while ago with an update to mkinitcpio? In any case, while I'm glad you found a solution, I'll be closing this old solved thread.

Offline

Board footer

Powered by FluxBB