You are not logged in.

#1 2021-03-19 08:47:40

_aayan
Member
Registered: 2021-03-19
Posts: 3

Cannot boot from USB in UEFI, only legacy

I used rufus to flash the ISO (DD image mode). Secure boot is disabled in the BIOS, and in Windows, fast startup and hibernating is disabled. But when I try to boot as UEFI, it says "Secure boot falied; invalid operating system". When I change boot mode to legacy in the BIOS, it boots fine.
I am trying to dual boot with Windows (which is also installed as UEFI).
PS: I have already installed Arch before, but as single boot and in legacy mode.
PPS: This is my first forum post, so if I did something wrong, let me know!

Offline

#2 2021-03-19 09:10:29

headkase
Member
Registered: 2011-12-06
Posts: 1,879

Re: Cannot boot from USB in UEFI, only legacy

In your BIOS look for a setting called "Compatibility Support Module" - CSM.  Make sure that is disabled.  Enabled = BIOS/MBR boot, disabled = UEFI boot.  This is usually a separate setting from Secure Boot.

Offline

#3 2021-03-19 13:21:40

_aayan
Member
Registered: 2021-03-19
Posts: 3

Re: Cannot boot from USB in UEFI, only legacy

headkase wrote:

In your BIOS look for a setting called "Compatibility Support Module" - CSM.  Make sure that is disabled.  Enabled = BIOS/MBR boot, disabled = UEFI boot.  This is usually a separate setting from Secure Boot.

here are my bios settings. (text box at the end is the error i was talking about)
https://pays.host/uploads/fe8e3b12-6e3a … 0zuMdl.mp4

Offline

#4 2021-03-19 13:50:46

headkase
Member
Registered: 2011-12-06
Posts: 1,879

Re: Cannot boot from USB in UEFI, only legacy

Under the "Security" tab, the "Secure Boot Mode" option which is set to "Standard".  What other options are in that setting?

Offline

#5 2021-03-19 13:56:15

_aayan
Member
Registered: 2021-03-19
Posts: 3

Re: Cannot boot from USB in UEFI, only legacy

headkase wrote:

Under the "Security" tab, the "Secure Boot Mode" option which is set to "Standard".  What other options are in that setting?

There's standard and custom. The description of custom is "The contents of Secure Boot signature and the PK can be customized in Custom mode."

Last edited by _aayan (2021-03-19 13:57:12)

Offline

#6 2021-04-04 05:39:41

LiNkz
Member
Registered: 2020-11-25
Posts: 9

Re: Cannot boot from USB in UEFI, only legacy

_aayan wrote:
headkase wrote:

Under the "Security" tab, the "Secure Boot Mode" option which is set to "Standard".  What other options are in that setting?

There's standard and custom. The description of custom is "The contents of Secure Boot signature and the PK can be customized in Custom mode."


No option to just disable secure boot anywhere?

Offline

Board footer

Powered by FluxBB