You are not logged in.

#1 2021-03-23 17:22:25

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

[Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Whenever I load 5.11 kernel, I get stuck in "loading initial ramdisk" screen.

Here is the image: https://i.imgur.com/8dg1NVk.jpg

What exactly is going on here?

And here is my laptop's information:

OS: Arch Linux
Kernel: x86_64 Linux 5.10.25-1-lts
Uptime: 14h 20m
Packages: 1858
Shell: zsh 5.8
Resolution: 1366x768
DE: KDE 5.80.0 / Plasma 5.21.3
WM: KWin
GTK Theme: Breeze [GTK2/3]
Icon Theme: Papirus-Light
Disk: 163G / 451G (38%)
CPU: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G @ 2x 3GHz
GPU: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] (rev da)
RAM: 2984MiB / 5518MiB

Last edited by designergaze (2021-03-26 21:26:54)


"The most personal is the most creative." - Bong Joon-ho

Offline

#2 2021-03-23 18:16:48

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,419

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Does the fallback image work?

Offline

#3 2021-03-23 18:28:28

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Head_on_a_Stick wrote:

Does the fallback image work?

How can I do that?


"The most personal is the most creative." - Bong Joon-ho

Offline

#4 2021-03-23 18:37:53

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 6,419

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Select it from your bootloader. I would be more specific if you had been.

Offline

#5 2021-03-23 22:27:53

seth
Member
Registered: 2012-09-03
Posts: 30,941

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Also remove plymouth and the quiet parameter.

Offline

#6 2021-03-23 23:52:33

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Head_on_a_Stick wrote:

Select it from your bootloader. I would be more specific if you had been.

Nope. Still the same.


"The most personal is the most creative." - Bong Joon-ho

Offline

#7 2021-03-24 00:14:43

loqs
Member
Registered: 2014-03-06
Posts: 15,101

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

If there was no more output with plymouth and quiet removed,  add ignore_loglevel earlyprintk=efi.keep if there is still no output add acpi=off iommu=soft

Offline

#8 2021-03-24 00:26:20

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

seth wrote:

Also remove plymouth and the quiet parameter.

I don't have them installed.


"The most personal is the most creative." - Bong Joon-ho

Offline

#9 2021-03-24 00:26:52

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

loqs wrote:

If there was no more output with plymouth and quiet removed,  add ignore_loglevel earlyprintk=efi.keep if there is still no output add acpi=off iommu=soft

Add to where?


"The most personal is the most creative." - Bong Joon-ho

Offline

#10 2021-03-24 00:32:24

loqs
Member
Registered: 2014-03-06
Posts: 15,101

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

See kernel parameters.  Start with removing quiet and splash as seth requested then add the ones I suggested.

Last edited by loqs (2021-03-24 00:32:33)

Offline

#11 2021-03-24 01:21:13

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Now it let me to this (even with the lts one): https://i.imgur.com/YiQiXtJ.jpg

Looks like I borked it. So much so that I had to reset grub to "loglevel=3 quiet".

Last edited by designergaze (2021-03-24 01:46:10)


"The most personal is the most creative." - Bong Joon-ho

Offline

#12 2021-03-24 02:38:12

loqs
Member
Registered: 2014-03-06
Posts: 15,101

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

The image shows 5.11.8 booted and loaded the initrd but the initrd could not load the root file-system so dropped you to a rescue shell.

Offline

#13 2021-03-24 03:02:24

dkaylor
Member
Registered: 2015-04-10
Posts: 7

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Encountered a similiar problem on AMD Stoney hardware running OpenSUSE Tumbleweed, kernel appeared to boot but couldn't load initramfs.

Upstream report: https://bugzilla.kernel.org/show_bug.cgi?id=212133

Related to IOMMU changes for 5.11 series. Using iommu=soft kernel parameter, I can get that system to boot and load initramfs without issue.

You have Stoney Ridge hardware also, so it's worth a try.

Offline

#14 2021-03-24 04:23:50

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

loqs wrote:

The image shows 5.11.8 booted and loaded the initrd but the initrd could not load the root file-system so dropped you to a rescue shell.

What would be your suggestion?


"The most personal is the most creative." - Bong Joon-ho

Offline

#15 2021-03-24 07:02:52

seth
Member
Registered: 2012-09-03
Posts: 30,941

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

Boot from a usb key (eg. your installation iso or grml), mount your root partition to /mnt, conditionally the boot partition to /mnt/boot  and compare "lsblk -f" w/  /mnt/etc/fstab and /mnt/boot/grub/grub.cfg entries.
You can use the tip in the first link in my signature to upload files and output from the console.

If the UUIDs match, the device might just be slow to appear, try the "rootdelay" and/or "rootwait" kernel parameters, https://raw.githubusercontent.com/torva … meters.txt

Offline

#16 2021-03-26 20:57:26

designergaze
Member
From: New York
Registered: 2020-11-02
Posts: 40
Website

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

dkaylor wrote:

Encountered a similiar problem on AMD Stoney hardware running OpenSUSE Tumbleweed, kernel appeared to boot but couldn't load initramfs.

Upstream report: https://bugzilla.kernel.org/show_bug.cgi?id=212133

Related to IOMMU changes for 5.11 series. Using iommu=soft kernel parameter, I can get that system to boot and load initramfs without issue.

You have Stoney Ridge hardware also, so it's worth a try.

I added "iommu=soft" right next to "loglevel=3 quiet" and it worked!

Thank you very much.


"The most personal is the most creative." - Bong Joon-ho

Offline

#17 2021-03-26 22:29:51

loqs
Member
Registered: 2014-03-06
Posts: 15,101

Re: [Solved] Whenever I load 5.11 kernel, I get stuck in "loading ini...

The patches for the linked bug report are in 5.11.9 if you want to remove iommu=soft

Offline

Board footer

Powered by FluxBB