You are not logged in.

#1 2006-10-29 19:43:05

drakosha
Member
Registered: 2006-01-03
Posts: 253
Website

[SOLVED] 4,5,6 on the keypad not functional :(

Look at the subject smile. 1,2,3 and 7,8,9 are ok. I don't know what info is needed, please tell me and i'll supply.

Offline

#2 2006-10-30 00:11:20

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: [SOLVED] 4,5,6 on the keypad not functional :(

does this happen in tty and X? If it is the case, try the fallback.img

Offline

#3 2006-10-30 05:14:14

drakosha
Member
Registered: 2006-01-03
Posts: 253
Website

Re: [SOLVED] 4,5,6 on the keypad not functional :(

Some more info:
it happens in X only, it's ok in console and in windows run in vmware!

Offline

#4 2006-10-30 06:50:46

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: [SOLVED] 4,5,6 on the keypad not functional :(

Since it is X related, show your device section of xorg. It may help

Offline

#5 2006-10-30 10:35:05

drakosha
Member
Registered: 2006-01-03
Posts: 253
Website

Re: [SOLVED] 4,5,6 on the keypad not functional :(

i Think that's what you asked:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Driver "keyboard"
        Option "XkbModel" "pc104"
        Option "XkbLayout" "us,ru,il"
        Option "XkbOptions" "compose:rwin,grp:alt_shift_toggle"
    #                   compose:rwin,
        Option "XkbVariant" ",winkeys,"
        Option "XkbRules" "xorg"
EndSection
....
....
....
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

        Option  "BlankTime"  "5"  # Blank the screen after 5 minutes (Fake)
        Option  "StandbyTime"  "10"  # Turn off screen after 10 minutes (DPMS)
        Option  "SuspendTime"  "20"  # Full suspend after 20 minutes
        Option  "OffTime"  "30"  # Turn off after half an hour
EndSection

Offline

#6 2006-10-30 10:46:15

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: [SOLVED] 4,5,6 on the keypad not functional :(

mine is

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "es"
    Option         "XkbRules" "xorg"
EndSection

so, try comenting:
Driver      "kbd"

comenting:
Option "XkbVariant" ",winkeys,"

and setting XkbLayout to just on of the list us,ru,il

Offline

#7 2006-10-30 10:46:47

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: [SOLVED] 4,5,6 on the keypad not functional :(

also comment:
Option "XkbOptions" "compose:rwin,grp:alt_shift_toggle"

Offline

#8 2006-10-30 12:01:18

drakosha
Member
Registered: 2006-01-03
Posts: 253
Website

Re: [SOLVED] 4,5,6 on the keypad not functional :(

i'll try it when i'm home, thanks a lot!

Offline

#9 2006-11-05 17:13:00

drakosha
Member
Registered: 2006-01-03
Posts: 253
Website

Re: [SOLVED] 4,5,6 on the keypad not functional :(

i'm sorry it takes so much time, i have very few options to restart X currently sad
1. it works on in the KDM
2. when replaced "Driver "keyboard"" instead of "kbd" it did not help
3. commented: "Option "XkbVariant" ",winkeys," " - no change

Offline

#10 2006-11-05 20:52:47

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: [SOLVED] 4,5,6 on the keypad not functional :(

if it works in kdm it means that an application changes it later.

If your are using kde go to:

kcontrol -> Regional and accessibility ->Country/Region language.

Offline

#11 2006-11-06 05:10:12

drakosha
Member
Registered: 2006-01-03
Posts: 253
Website

Re: [SOLVED] 4,5,6 on the keypad not functional :(

I'm using gnome!

That did the trick, i changed keyboard type in the keyboard preferences and it now works! 10x a lot!

Offline

Board footer

Powered by FluxBB