You are not logged in.

#1 2021-03-31 12:35:23

Robin Candau
Member
Registered: 2021-03-31
Posts: 2
Website

[SOLVED] Bluetooth suddenly not working after last kernel update

Hi everyone,

I had an issue with bluetooth after updating to the last Kernel (Linux 5.11.11-arch1-1).
Indeed, after applying the update and rebooting, bluetooth suddenly stopped working.

I was able to solve the problem myself with the precious help of the Arch Wiki, but I haven't seen any news about this so far (something like : Be careful, last update kernel breaks bluetooth for "some reasons").
So I thought to myself that it could be interesting to share the resolution I applied with you (Hope you're all okay with that).


Configuration :

- Desktop PC
- Arch Linux running normal Linux Kernel (not LTS I mean)
- Gnome DE
- Asus BT500 USB bluetooth dongle


Problem :

- The problem cause : Updating Kernel from Linux 5.10.11-arch1 to Linux 5.11.11-arch1-1 (looks like the most likely cause)
- The problem consequence : Bluetooth suddenly not working after applying the update and rebooting


Analyses :

I wasn't able to activate the bluetooth through the Gnome Setting anymore, the on/off switch was "greyed" and the setting page said that Bluetooth was not activated (even though my bluetooth service is enabled via systemd).

I tried to relaunch it manually via :

sudo systemctl start bluetooth

But it didn't worked.

The service status showed the following :

sudo systemctl status bluetooth
[...]
"mars 31 13:11:18 Arch-Linux systemd[1]: Condition check resulted in Bluetooth service being skipped."

Fix :

According to this page on the Arch Wiki, it looks like the /sys/class/bluetooth directory has been deleted for some reasons (?).
This prevents bluetooth service to launch correctly.

So you can re-create this directory with :

sudo modprobe btusb

and then you'll be able to restart the bluetooth service correctly :

sudo systemctl restart bluetooth

I also had to reinstall my USB bluetooth dongle drivers. And then, everything worked correctly again.


I'm not trying to just give you a link to the Arch Wiki there (help vampirism), but also warning that this kernel update breaks bluetooth for some reasons (by deleting the /sys/class/bluetooth directory).
As it happened to me, I assume it will happen to someones else.... Just trying to help !

Anyway I'm also keeping a document with all the problems I had since I installed Arch-Linux and how I fixed them. Just like a personal knowledge base that I'm keeping up to date and that I share with others smile
You can consult it here.

Thank you for reading this ! Hope I helped someone smile

Last edited by Robin Candau (2021-03-31 12:39:27)

Offline

#2 2021-04-03 15:36:55

Auracle
Member
Registered: 2021-01-12
Posts: 6

Re: [SOLVED] Bluetooth suddenly not working after last kernel update

Thank you. Your solution worked the second time I tried it. I think complete hardware restart is necessary.
For reference below is my hardware configuration.

Operating System: Arch Linux
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.11-arch1-1
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × 11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics.
Laptop Model Name and Number: Asus Zenbook UX425EA

Edit: Upon further usage, the bluetooth does not work reliably and there is a connection drop observed multiple times during an hour's session. This loss of connection is random, hence cannot get ready beforehand. Moreover, if you find the "Enable Bluetooth" greyed out a

sudo systemctl restrart bluetooth 

usually works well.

Last edited by Auracle (2021-04-05 05:19:09)

Offline

#3 2021-04-04 03:23:35

Robin Candau
Member
Registered: 2021-03-31
Posts: 2
Website

Re: [SOLVED] Bluetooth suddenly not working after last kernel update

Glad it helps someone ! smile

Thanks for the shared information about your system !
Hopefully this post will help anyone else smile

Offline

Board footer

Powered by FluxBB