You are not logged in.

#1 2021-04-05 05:10:33

thoth
Member
Registered: 2010-01-10
Posts: 53

[SOLVED] Sunrise Point-LP HD audio quit working after update

My audio card just quit working after a recent update.  The card shows up in lspci, but apparently alsa no longer recognizes it as a card?

$ aplay -l
aplay: device_list:274: no soundcards found...

$ sudo alsactl -f /var/lib/alsa/asound.state store
alsactl: save_state:1595: No soundcards found...

$ sudo fuser -v /dev/snd/*

$ groups|grep audio
root bin daemon sys tty mem ftp mail log smmsp proc http named games lock uuidd dbus network floppy scanner power polkitd gdm rtkit usbmux sddm realtime docker git geoclue flatpak libvirt brlapi colord avahi systemd-coredump systemd-timesync systemd-resolve systemd-network systemd-journal-remote rfkill systemd-journal users video uucp storage render optical lp kvm input disk audio utmp kmem wheel

$ ls -alh /dev/snd/
total 0
drwxr-xr-x   2 root root       80 Apr  4 23:45 .
drwxr-xr-x  21 root root     4.2K Apr  4 23:45 ..
crw-rw----+  1 root audio 116,  1 Apr  4 23:45 seq
crw-rw----+  1 root audio 116, 33 Apr  4 23:45 timer

the usual alsa info:

wget -O alsa-info.sh [url]http://www.alsa-project.org/alsa-info.sh[/url]
bash alsa-info.sh --upload

produces these results:

http://alsa-project.org/db/?f=5f20fc07c … f77cda4891

lspci -nn 
00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:590c] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 615 [8086:591c] (rev 02)
00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 02)
00:08.0 System peripheral [0880]: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model [8086:1911]
00:13.0 Non-VGA unclassified device [0000]: Intel Corporation Sunrise Point-LP Integrated Sensor Hub [8086:9d35] (rev 21)
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
00:15.0 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 [8086:9d60] (rev 21)
00:15.1 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 [8086:9d61] (rev 21)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 [8086:9d10] (rev f1)
00:1c.4 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 [8086:9d14] (rev f1)
00:1d.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #10 [8086:9d19] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:9d4b] (rev 21)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21)
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
01:00.0 PCI bridge [0604]: Intel Corporation JHL6540 Thunderbolt 3 Bridge (C step) [Alpine Ridge 4C 2016] [8086:15d3] (rev 02)
02:00.0 PCI bridge [0604]: Intel Corporation JHL6540 Thunderbolt 3 Bridge (C step) [Alpine Ridge 4C 2016] [8086:15d3] (rev 02)
02:01.0 PCI bridge [0604]: Intel Corporation JHL6540 Thunderbolt 3 Bridge (C step) [Alpine Ridge 4C 2016] [8086:15d3] (rev 02)
02:02.0 PCI bridge [0604]: Intel Corporation JHL6540 Thunderbolt 3 Bridge (C step) [Alpine Ridge 4C 2016] [8086:15d3] (rev 02)
02:04.0 PCI bridge [0604]: Intel Corporation JHL6540 Thunderbolt 3 Bridge (C step) [Alpine Ridge 4C 2016] [8086:15d3] (rev 02)
03:00.0 System peripheral [0880]: Intel Corporation JHL6540 Thunderbolt 3 NHI (C step) [Alpine Ridge 4C 2016] [8086:15d2] (rev 02)
37:00.0 USB controller [0c03]: Intel Corporation JHL6540 Thunderbolt 3 USB Controller (C step) [Alpine Ridge 4C 2016] [8086:15d4] (rev 02)
6c:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961/SM963 [144d:a804]
6d:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)

However, if I boot to windows sound works just fine, so I at least know the card and speakers still work.

Last edited by thoth (2021-04-05 15:03:09)

Offline

#2 2021-04-05 08:37:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,505

Re: [SOLVED] Sunrise Point-LP HD audio quit working after update

Likely a switch over to SoF firmware, check

sudo dmesg | grep sof

and if it mentions that the device is trying to be identified via sof try installing the sof-firmware and alsa-ucm-conf packages.

Offline

#3 2021-04-05 13:50:26

thoth
Member
Registered: 2010-01-10
Posts: 53

Re: [SOLVED] Sunrise Point-LP HD audio quit working after update

It doesn't look like it:

$ sudo dmesg|grep -i sof                    
[    0.513765] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    0.812095] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.812097] software IO TLB: mapped [mem 0x000000001bbb3000-0x000000001fbb3000] (64MB)

$ sudo dmesg|grep snd_hda
[   16.559996] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[   16.560005] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SST driver

$ sudo dmesg|grep -i audio
[    0.157392] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[   17.123384] snd_soc_skl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   17.557164] HDMI HDA Codec ehdaudio0D2: Max dais supported: 3

I went ahead and installed both anyhow to no effect:

$ sudo pacman -Sy sof-firmware alsa-ucm-conf

Last edited by thoth (2021-04-05 13:59:43)

Offline

#4 2021-04-05 14:42:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,505

Re: [SOLVED] Sunrise Point-LP HD audio quit working after update

Half-half, it does start to load the relevant modules that I'd associate with said switch over  but doesn't appear to have the other relevant bits and pieces for actually enabling it via sof, potentially an accidentally added vid/pid combination to the SoC/SoF compat. Try a  /etc/modprobe.d/inteldsp.conf

options snd-intel-dspcfg dsp_driver=1

Other than that the most likely culprit here is a kernel update, what kernel did you use before the problematic update?

Offline

#5 2021-04-05 14:56:52

thoth
Member
Registered: 2010-01-10
Posts: 53

Re: [SOLVED] Sunrise Point-LP HD audio quit working after update

Success!  Now, how do I add [SOLVED] to the subject?  I can't seem to find an 'edit' button for that?

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC285 Analog [ALC285 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ cat /etc/modprobe.d/inteldsp.conf   
options snd-intel-dspcfg dsp_driver=1

$ uname -a
Linux spectre 5.11.11-arch1-1 #1 SMP PREEMPT Tue, 30 Mar 2021 14:10:17 +0000 x86_64 GNU/Linux

I am using the mainline arch linux kernel, I had also used the lts kernel (which is also broken by default here on the current kernel, I'll test it next).

Last edited by thoth (2021-04-05 15:02:39)

Offline

#6 2021-04-05 15:01:21

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,691

Re: [SOLVED] Sunrise Point-LP HD audio quit working after update

If you edit your original post, there is an option to change the thread title.  Prepend [SOLVED].


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2021-04-05 15:13:47

thoth
Member
Registered: 2010-01-10
Posts: 53

Re: [SOLVED] Sunrise Point-LP HD audio quit working after update

added SOLVED to subject, and tested LTS kernel as well with success:

$ uname -a
Linux spectre 5.10.27-1-lts #1 SMP Tue, 30 Mar 2021 13:22:29 +0000 x86_64 GNU/Linux

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC285 Analog [ALC285 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Offline

Board footer

Powered by FluxBB