You are not logged in.

#1 2021-04-05 09:39:23

abject
Member
Registered: 2021-04-05
Posts: 2

[SOLVED] XFCE 4.16 black screen after upgrade & reboot

Hi all,

I had a freshly installed Arch + XFCE4 OS that was working fine.

Today (5th of april 2021) I upgrade the system doing a:

$ pacman -Syu

Notable thing that were upgraded are:

  • Nvidia and mesa driver

  • Linux kernel

  • xfce4 battery-plugin and systemload-plugin

Then after reboot and login I got a black screen with only the mouse pointer. After searching for a solution I found that removing:

$ rm -r ~/.cache 
$ mv ~/.config/xfce4 ~/.config/xfce4_crash

allow the environment to show up fine. But after a reboot the black screen is back sad.

My problem is similar to the one exposed here : https://forum.manjaro.org/t/xfce-4-16-doesnt-work/46045 So I tried to remove the whiskermenu menu, then remove cache and config folder and reboot. But the problem remains sad.

Here is the xsessions-errors content (sorry there are some part in French):

/usr/bin/iceauth:  creating new authority file /run/user/1000/ICEauthority
gpg-agent: une instance de gpg-agent fonctionne déjà —
pas de démarrage d'une nouvelle instance

** (xfce4-screensaver:510): WARNING **: 11:08:24.224: économiseur d’écran déjà lancé dans cette session

** (xfce4-power-manager:519): WARNING **: 11:08:24.300: Failed to get name owner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.freedesktop.PowerManagement': no such name


** (xfce4-power-manager:519): WARNING **: 11:08:24.300: Failed to get name owner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.xfce.PowerManager': no such name


(xfce4-panel:493): garcon-CRITICAL **: 11:08:24.409: garcon_gtk_menu_get_desktop_actions_menu: assertion 'actions != NULL' failed

(xfce4-panel:493): garcon-CRITICAL **: 11:08:24.439: garcon_gtk_menu_get_desktop_actions_menu: assertion 'actions != NULL' failed

(xfce4-power-manager:519): GLib-GObject-WARNING **: 11:08:24.456: ../glib/gobject/gsignal.c:2614: signal 'Changed' is invalid for instance '0x563bc192aaf0' of type 'GDBusProxy'

(xfce4-panel:493): garcon-CRITICAL **: 11:08:24.463: garcon_gtk_menu_get_desktop_actions_menu: assertion 'actions != NULL' failed

(xfce4-power-manager:519): xfce4-power-manager-WARNING **: 11:08:24.474: could not map keysym 1008ffa8 to keycode


(xfce4-power-manager:519): xfce4-power-manager-WARNING **: 11:08:24.485: Failed to get keyboard max brightness level : GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: L’interface « org.freedesktop.UPower.KbdBacklight » n’existe pas pour l’objet à l’emplacement /org/freedesktop/UPower/KbdBacklight

(xfce4-panel:493): garcon-CRITICAL **: 11:08:24.486: garcon_gtk_menu_get_desktop_actions_menu: assertion 'actions != NULL' failed

(wrapper-2.0:525): GLib-GIO-CRITICAL **: 11:08:24.585: g_file_new_for_path: assertion 'path != NULL' failed

(wrapper-2.0:525): GLib-GIO-CRITICAL **: 11:08:24.585: g_file_monitor_file: assertion 'G_IS_FILE (file)' failed

(wrapper-2.0:525): GLib-GObject-WARNING **: 11:08:24.585: invalid (NULL) pointer instance

(wrapper-2.0:525): GLib-GObject-CRITICAL **: 11:08:24.585: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(wrapper-2.0:525): Gtk-WARNING **: 11:08:24.585: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.

(wrapper-2.0:558): Gtk-WARNING **: 11:08:24.650: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner XfceArrowButton)

(wrapper-2.0:518): Gtk-WARNING **: 11:08:24.675: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

(wrapper-2.0:525): Gtk-WARNING **: 11:08:24.681: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:522): Gtk-WARNING **: 11:08:24.686: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PowerManagerButton)

(wrapper-2.0:518): pulseaudio-plugin-WARNING **: 11:09:02.060: Disconected from the PulseAudio server. Attempting to reconnect in 5 seconds.

(xfce4-power-manager:519): libxfce4ui-WARNING **: 11:09:02.066: ICE I/O Error

(xfdesktop:503): libxfce4ui-WARNING **: 11:09:02.066: ICE I/O Error

(xfce4-power-manager:519): libxfce4ui-WARNING **: 11:09:02.066: Disconnected from session manager.

(xfdesktop:503): libxfce4ui-WARNING **: 11:09:02.066: Disconnected from session manager.
Gdk-Message: 11:09:02.071: xfwm4: Fatal IO error 4 (Appel système interrompu) on X server :0.

In case you need it here is the pacman log file content for the upgrade:

[2021-04-05T08:38:34+0200] [PACMAN] Running 'pacman -Syu'
[2021-04-05T08:38:34+0200] [PACMAN] synchronizing package lists
[2021-04-05T08:39:07+0200] [PACMAN] starting full system upgrade
[2021-04-05T09:48:54+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2021-04-05T09:48:54+0200] [ALPM] transaction started
[2021-04-05T09:48:54+0200] [ALPM] upgraded glib2 (2.66.7-1 -> 2.68.0-5)
[2021-04-05T09:48:54+0200] [ALPM] upgraded gdk-pixbuf2 (2.42.2-1 -> 2.42.4-1)
[2021-04-05T09:48:54+0200] [ALPM] upgraded fontconfig (2:2.13.91+48+gfcb0420-2 -> 2:2.13.93-4)
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET] Creating fontconfig configuration...
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET] 
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET] >>> If you have configured NoExtract to prevent symlinks in /etc/fonts/conf.d/
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET]     from being restored, these symlinks have been recreated one last time. You
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET]     can now delete the symlinks and remove the paths from NoExtract and they
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET]     will not be created again.
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET] 
[2021-04-05T09:48:54+0200] [ALPM-SCRIPTLET] Rebuilding fontconfig cache...
[2021-04-05T09:48:57+0200] [ALPM] upgraded pango (1:1.48.3-1 -> 1:1.48.4-1)
[2021-04-05T09:48:57+0200] [ALPM] upgraded gtk-update-icon-cache (1:4.0.3-1 -> 1:4.2.0-2)
[2021-04-05T09:48:58+0200] [ALPM] upgraded adwaita-icon-theme (3.38.0-1 -> 40rc-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded openssl (1.1.1.j-1 -> 1.1.1.k-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded libldap (2.4.57-1 -> 2.4.58-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded krb5 (1.18.3-1 -> 1.19.1-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded libgpg-error (1.41-1 -> 1.42-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded systemd-libs (247.4-2 -> 248-3)
[2021-04-05T09:48:58+0200] [ALPM] upgraded at-spi2-core (2.38.0-1 -> 2.40.0-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded babl (0.1.84-1 -> 0.1.86-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded bison (3.7.3-1 -> 3.7.6-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded blas (3.9.0-3 -> 3.9.1-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded bluez-libs (5.56-2 -> 5.58-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded btrfs-progs (5.11-1 -> 5.11.1-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded cblas (3.9.0-3 -> 3.9.1-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded cryptsetup (2.3.5-1 -> 2.3.5-2)
[2021-04-05T09:48:58+0200] [ALPM] upgraded libssh2 (1.9.0-2 -> 1.9.0-3)
[2021-04-05T09:48:58+0200] [ALPM] upgraded curl (7.75.0-1 -> 7.76.0-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded file (5.39-1 -> 5.40-1)
[2021-04-05T09:48:58+0200] [ALPM] upgraded systemd (247.4-2 -> 248-3)
[2021-04-05T09:48:58+0200] [ALPM-SCRIPTLET] Creating group sgx with gid 973.
[2021-04-05T09:48:58+0200] [ALPM-SCRIPTLET] Creating group systemd-oom with gid 972.
[2021-04-05T09:48:58+0200] [ALPM-SCRIPTLET] Creating user systemd-oom (systemd Userspace OOM Killer) with uid 972 and gid 972.
[2021-04-05T09:48:59+0200] [ALPM] upgraded libpulse (14.2-2 -> 14.2-3)
[2021-04-05T09:48:59+0200] [ALPM] upgraded mesa (20.3.4-3 -> 21.0.1-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded nettle (3.7.1-1 -> 3.7.2-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded libinput (1.17.0-1 -> 1.17.1-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded libva (2.10.0-1 -> 2.11.0-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded libvpx (1.9.0-1 -> 1.10.0-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded x264 (3:0.160.r3011.cde9a93-1 -> 3:0.161.r3039.544c61f-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded x265 (3.4-1 -> 3.5-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded ffmpeg (2:4.3.2-2 -> 2:4.3.2-5)
[2021-04-05T09:48:59+0200] [ALPM] upgraded sqlite (3.35.2-1 -> 3.35.4-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded libfilezilla (0.19.3-2 -> 0.27.1-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded libxkbcommon (1.1.0-2 -> 1.2.0-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded js78 (78.8.0-1 -> 78.9.0-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded gsettings-desktop-schemas (3.38.0-1 -> 40.0-2)
[2021-04-05T09:48:59+0200] [ALPM] upgraded glib-networking (2.66.0-1 -> 1:2.68.0-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded libsoup (2.72.0+5+g0b094bff-3 -> 2.72.0+10+gfe1e295d-1)
[2021-04-05T09:48:59+0200] [ALPM] upgraded gtk3 (1:3.24.27-4 -> 1:3.24.28-1)
[2021-04-05T09:49:00+0200] [ALPM] upgraded filezilla (3.46.3-1 -> 3.53.1-1)
[2021-04-05T09:49:00+0200] [ALPM] upgraded firefox (86.0.1-1 -> 87.0-1)
[2021-04-05T09:49:00+0200] [ALPM] upgraded openmpi (4.0.5-2 -> 4.0.5-3)
[2021-04-05T09:49:00+0200] [ALPM] upgraded python-pillow (8.1.0-1 -> 8.1.2-1)
[2021-04-05T09:49:00+0200] [ALPM] upgraded lapack (3.9.0-3 -> 3.9.1-1)
[2021-04-05T09:49:00+0200] [ALPM] upgraded python-matplotlib (3.3.4-1 -> 3.4.1-2)
[2021-04-05T09:49:00+0200] [ALPM] installed python-ply (3.11-7)
[2021-04-05T09:49:00+0200] [ALPM] upgraded libxkbcommon-x11 (1.1.0-2 -> 1.2.0-1)
[2021-04-05T09:49:00+0200] [ALPM] upgraded qt5-svg (5.15.2-1 -> 5.15.2-2)
[2021-04-05T09:49:01+0200] [ALPM] installed qt5-xmlpatterns (5.15.2-1)
[2021-04-05T09:49:01+0200] [ALPM] upgraded jasper (2.0.25-1 -> 2.0.27-1)
[2021-04-05T09:49:01+0200] [ALPM] upgraded freecad (0.18.5-6 -> 0.19.1-2)
[2021-04-05T09:49:01+0200] [ALPM] upgraded gcr (3.38.1-1 -> 3.40.0-1)
[2021-04-05T09:49:01+0200] [ALPM] upgraded poppler (21.03.0-1 -> 21.04.0-1)
[2021-04-05T09:49:01+0200] [ALPM] upgraded poppler-glib (21.03.0-1 -> 21.04.0-1)
[2021-04-05T09:49:01+0200] [ALPM] upgraded gegl (0.4.28-2 -> 0.4.30-1)
[2021-04-05T09:49:02+0200] [ALPM] upgraded ghostscript (9.53.3-3 -> 9.54.0-2)
[2021-04-05T09:49:02+0200] [ALPM] upgraded libheif (1.11.0-1 -> 1.11.0-2)
[2021-04-05T09:49:02+0200] [ALPM] upgraded gtk2 (2.24.33-1 -> 2.24.33-2)
[2021-04-05T09:49:02+0200] [ALPM] upgraded libxaw (1.0.13-3 -> 1.0.14-1)
[2021-04-05T09:49:02+0200] [ALPM] upgraded gsfonts (20200910-1 -> 20200910-2)
[2021-04-05T09:49:02+0200] [ALPM] upgraded graphviz (2.46.1-1 -> 2.47.0-1)
[2021-04-05T09:49:03+0200] [ALPM] upgraded gimp (2.10.22-2 -> 2.10.24-1)
[2021-04-05T09:49:03+0200] [ALPM] upgraded git (2.31.0-1 -> 2.31.1-1)
[2021-04-05T09:49:03+0200] [ALPM] upgraded gobject-introspection-runtime (1.66.1-3 -> 1.68.0-1)
[2021-04-05T09:49:03+0200] [ALPM] upgraded groff (1.22.4-4 -> 1.22.4-5)
[2021-04-05T09:49:03+0200] [ALPM] upgraded mpg123 (1.26.3-2 -> 1.26.5-1)
[2021-04-05T09:49:03+0200] [ALPM] upgraded gst-plugins-good (1.18.4-1 -> 1.18.4-2)
[2021-04-05T09:49:03+0200] [ALPM] upgraded libinih (52-2 -> 53-1)
[2021-04-05T09:49:03+0200] [ALPM] upgraded xfsprogs (5.10.0-2 -> 5.11.0-1)
[2021-04-05T09:49:03+0200] [ALPM] upgraded libassuan (2.5.4-2 -> 2.5.5-1)
[2021-04-05T09:49:04+0200] [ALPM] upgraded pinentry (1.1.0-5 -> 1.1.1-1)
[2021-04-05T09:49:04+0200] [ALPM] upgraded gvfs (1.48.0-1 -> 1.48.0-2)
[2021-04-05T09:49:04+0200] [ALPM] upgraded gvfs-mtp (1.48.0-1 -> 1.48.0-2)
[2021-04-05T09:49:04+0200] [ALPM] upgraded vim-runtime (8.2.2489-1 -> 8.2.2653-1)
[2021-04-05T09:49:04+0200] [ALPM] upgraded gvim (8.2.2489-1 -> 8.2.2653-1)
[2021-04-05T09:49:04+0200] [ALPM] upgraded less (563-1 -> 1:563-1)
[2021-04-05T09:49:04+0200] [ALPM] upgraded libcdr (0.1.6-3 -> 0.1.7-1)
[2021-04-05T09:49:04+0200] [ALPM] upgraded libdazzle (3.38.0-1 -> 3.40.0-1)
[2021-04-05T09:49:04+0200] [ALPM] upgraded libpeas (1.28.0-3 -> 1.30.0-1)
[2021-04-05T09:49:06+0200] [ALPM] upgraded libreoffice-still (7.0.5-1 -> 7.0.5-2)
[2021-04-05T09:49:06+0200] [ALPM] upgraded libupnp (1.14.2-1 -> 1.14.4-1)
[2021-04-05T09:49:06+0200] [ALPM] upgraded libwpe (1.8.0-1 -> 1.10.0-1)
[2021-04-05T09:49:06+0200] [ALPM] upgraded libxres (1.2.0-2 -> 1.2.1-1)
[2021-04-05T09:49:06+0200] [ALPM] upgraded mkinitcpio-busybox (1.32.1-2 -> 1.32.1-3)
[2021-04-05T09:49:07+0200] [ALPM] upgraded linux (5.11.7.arch1-1 -> 5.11.11.arch1-1)
[2021-04-05T09:49:07+0200] [ALPM] upgraded man-pages (5.10-1 -> 5.11-1)
[2021-04-05T09:49:07+0200] [ALPM] installed gtksourceview4 (4.8.1-1)
[2021-04-05T09:49:07+0200] [ALPM] upgraded mousepad (0.5.3-1 -> 0.5.4-1)
[2021-04-05T09:49:07+0200] [ALPM] upgraded nvidia (460.67-1 -> 460.67-5)
[2021-04-05T09:49:07+0200] [ALPM] upgraded openimageio (2.2.12.0-1 -> 2.2.13.0-1)
[2021-04-05T09:49:07+0200] [ALPM] upgraded openshadinglanguage (1.11.12.0-1 -> 1.11.13.0-1)
[2021-04-05T09:49:07+0200] [ALPM] upgraded opensubdiv (3.4.3-5 -> 3.4.4-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded pulseaudio (14.2-2 -> 14.2-3)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-setuptools (1:54.1.1-1 -> 1:54.2.0-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-chardet (3.0.4-7 -> 4.0.0-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-gobject (3.40.0-1 -> 3.40.1-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-idna (2.10-3 -> 3.1-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-lxml (4.6.2-2 -> 4.6.3-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-regex (2020.11.13-2 -> 2021.3.17-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-soupsieve (2.2-1 -> 2.2.1-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded python-urllib3 (1.26.3-1 -> 1.26.4-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded re2 (1:20210202-1 -> 1:20210401-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded systemd-sysvcompat (247.4-2 -> 248-3)
[2021-04-05T09:49:08+0200] [ALPM] upgraded thunar (4.16.5-1 -> 4.16.6-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded thunderbird (78.8.1-1 -> 78.9.0-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded vlc (3.0.12-2 -> 3.0.12-3)
[2021-04-05T09:49:08+0200] [ALPM] upgraded vte-common (0.62.3-1 -> 0.64.0-1)
[2021-04-05T09:49:08+0200] [ALPM] upgraded vte3 (0.62.3-1 -> 0.64.0-1)
[2021-04-05T09:49:08+0200] [ALPM] installed libmanette (0.2.6-1)
[2021-04-05T09:49:09+0200] [ALPM] upgraded webkit2gtk (2.30.6-1 -> 2.32.0-1)
[2021-04-05T09:49:09+0200] [ALPM] upgraded xfce4-battery-plugin (1.1.3-2 -> 1.1.4-1)
[2021-04-05T09:49:09+0200] [ALPM] upgraded xfce4-systemload-plugin (1.3.0-1 -> 1.3.1-1)
[2021-04-05T09:49:09+0200] [ALPM] upgraded xterm (366-1 -> 367-1)
[2021-04-05T09:49:09+0200] [ALPM] upgraded zeromq (4.3.3-2 -> 4.3.4-1)
[2021-04-05T09:49:09+0200] [ALPM] transaction completed
[2021-04-05T09:49:10+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2021-04-05T09:49:10+0200] [ALPM] running '30-systemd-catalog.hook'...
[2021-04-05T09:49:10+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2021-04-05T09:49:10+0200] [ALPM] running '30-systemd-hwdb.hook'...
[2021-04-05T09:49:11+0200] [ALPM] running '30-systemd-sysctl.hook'...
[2021-04-05T09:49:11+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2021-04-05T09:49:11+0200] [ALPM] running '30-systemd-udev-reload.hook'...
[2021-04-05T09:49:11+0200] [ALPM] running '30-systemd-update.hook'...
[2021-04-05T09:49:11+0200] [ALPM] running '40-fontconfig-config.hook'...
[2021-04-05T09:49:11+0200] [ALPM] running '60-depmod.hook'...
[2021-04-05T09:49:20+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.11.11-arch1-1
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-04-05T09:49:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.11.11-arch1-1
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2021-04-05T09:49:21+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2021-04-05T09:49:22+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2021-04-05T09:49:23+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2021-04-05T09:49:24+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2021-04-05T09:49:25+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2021-04-05T09:49:26+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2021-04-05T09:49:27+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2021-04-05T09:49:28+0200] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2021-04-05T09:49:28+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2021-04-05T09:49:28+0200] [ALPM] running 'dbus-reload.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'detect-old-perl-modules.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'fontconfig.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'gio-querymodules.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'glib-compile-schemas.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'gtk-query-immodules-2.0.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'gvfsd.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'texinfo-install.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'update-desktop-database.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'update-mime-database.hook'...
[2021-04-05T09:49:28+0200] [ALPM] running 'update-vlc-plugin-cache.hook'...
[2021-04-05T09:49:29+0200] [ALPM] running 'xorg-mkfontscale.hook'...
[2021-04-05T10:43:32+0200] [PACMAN] Running 'pacman -Syu'
[2021-04-05T10:43:32+0200] [PACMAN] synchronizing package lists
[2021-04-05T10:43:58+0200] [PACMAN] starting full system upgrade
[2021-04-05T10:53:24+0200] [PACMAN] Running 'pacman -Sy tree'
[2021-04-05T10:53:24+0200] [PACMAN] synchronizing package lists
[2021-04-05T10:53:27+0200] [ALPM] transaction started
[2021-04-05T10:53:27+0200] [ALPM] installed tree (1.8.0-2)
[2021-04-05T10:53:27+0200] [ALPM] transaction completed
[2021-04-05T10:53:27+0200] [ALPM] running '30-systemd-update.hook'...
[2021-04-05T11:00:46+0200] [PACMAN] Running 'pacman -R xfce4-whiskermenu-plugin'
[2021-04-05T11:00:48+0200] [ALPM] transaction started
[2021-04-05T11:00:48+0200] [ALPM] removed xfce4-whiskermenu-plugin (2.5.3-1)
[2021-04-05T11:00:48+0200] [ALPM] transaction completed
[2021-04-05T11:00:48+0200] [ALPM] running '30-systemd-update.hook'...
[2021-04-05T11:00:48+0200] [ALPM] running 'gtk-update-icon-cache.hook'...

I can provide more info if need, just ask smile.

Last edited by abject (2021-04-06 11:40:16)

Offline

#2 2021-04-05 09:56:15

Trevor_B
Member
Registered: 2019-12-28
Posts: 18

Re: [SOLVED] XFCE 4.16 black screen after upgrade & reboot

It sounds like my problem a couple of days ago, I had exactly the same problem as you

"mesa driver" update, this screws things up

With help I got it sorted, check out my post, I noted all things that I had to done, Scroll down to the last few posts, I listed what needs to be changed, 1 to 6

https://bbs.archlinux.org/viewtopic.php?id=265098

Trevor

Last edited by Trevor_B (2021-04-05 11:10:22)

Offline

#3 2021-04-06 11:39:46

abject
Member
Registered: 2021-04-05
Posts: 2

Re: [SOLVED] XFCE 4.16 black screen after upgrade & reboot

You are totally right. After following the steps 1. to 6. I get my Arch system working again. It was probably a "mesa" driver issue conflicting with the Nvidia one.

Thanks for the tip, I will never find your solution with the symptoms of my problem.

Offline

Board footer

Powered by FluxBB