You are not logged in.

#1 2021-04-06 10:11:44

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 211

Forum and Wiki header bar not adapting correctly

https://streamable.com/2i8stj

You can see the behavior.

Offline

#2 2021-04-06 11:28:33

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,461

Re: Forum and Wiki header bar not adapting correctly

No , I can't see it without disabling a large part of my protection .

It looks like an mp4 video, can you upload that video somewhere it can be downloaded ?


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#3 2021-04-06 11:48:55

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 211

Re: Forum and Wiki header bar not adapting correctly

Offline

#4 2021-04-06 12:16:48

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,461

Re: Forum and Wiki header bar not adapting correctly

Requires JS, but that's the case for many sites nowadays.

Not sure which browser that is, but firefox on my system shows the same behaviour when narrowing the window.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#5 2021-04-06 12:28:29

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 211

Re: Forum and Wiki header bar not adapting correctly

It's Firefox.

Is there a way to make the devs of archweb notice this?

Offline

#6 2021-04-06 12:47:38

a821
Member
Registered: 2012-10-31
Posts: 277

Re: Forum and Wiki header bar not adapting correctly

I observe the same issue with the nav-bar in the forums (on firefox). I would submit a bug if you want the devs to notice.

Here is my attempt to reproduce the issue if you don't want to see the video. It happens when you narrow the firefox window.

# nav-bar normal view
---------------------------------------------------------------------+
[logo] archlinux       home packages wiki bugs security aur download |
---------------------------------------------------------------------+

# nav-bar in a narrow window (expected behaviour)
--------------------------------------------------------+
[logo] archlinux       home packages wiki bugs security |
                                           aur download |
--------------------------------------------------------+

# nav-bar in the forums in a narrow window
--------------------------------------------------------+
[logo] archlinux                                        |
--------------------------------------------------------+
                  home packages wiki bugs security

Offline

#7 2021-04-06 13:51:59

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 25,648
Website

Re: Forum and Wiki header bar not adapting correctly

I gather this is browser dependent as I can't replicate it on a webengine browser.

EDIT: nevermind - I *can* replicate this issue in my browser, but only on the wiki.  I previously tested on the home page which - as per below - is not the same project / code base (which is a bit surprising).  I have not tested on the forums at all as I'd have to either change my theme or log out as the 'cobalt' theme doesn't use the default nav bar.

Last edited by Trilby (2021-04-06 14:57:55)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Online

#8 2021-04-06 14:05:43

seth
Member
Registered: 2012-09-03
Posts: 23,413

Re: Forum and Wiki header bar not adapting correctly

In chromium the padding and ultimately logo collapse with "@media (max-width: somepx)" - there's no linebreak.

Offline

#9 2021-04-06 14:19:42

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 702

Re: Forum and Wiki header bar not adapting correctly

icar wrote:

Is there a way to make the devs of archweb notice this?

There is already a report for the wiki: https://bugs.archlinux.org/task/61253 You might submit another one for "{bbs}" as I don't see anything relevant.

Also note that the forum and wiki are not part of archweb.

Offline

#10 2021-04-06 21:22:54

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,315

Re: Forum and Wiki header bar not adapting correctly

The only sub-page that is actually scaling correct until I can no longer narrow the browser (firefox) any further is 'security' the rest all gets mangled in some way, all different!

edit: I'm pretty sure the reason why is in this CSS (see) https://security.archlinux.org/static/normalize.css
I'm not the one to make sure the other style sheets inherit the behavior from the one I pasted but the answer is in there.

Last edited by qinohe (2021-04-06 22:01:14)

Offline

Board footer

Powered by FluxBB