You are not logged in.

#1 2021-04-22 21:33:13

Registered: 2021-02-27
Posts: 5

[SOLVED]Installing Arch Linux on MacbookPro 2019: freeze after bootctl

I'm trying to dual boot arch with macOS.
I followed this guide . Everything works fine until I have to install intel-ucode: it says that It can't installing it cause a intel-ucode.img already exists, so I tried to remove it and it seems the installation was successful.
If I go ahead and try

 bootctl --path=/<bootLoaderDir> install

it freeze saying it's a cpu problem.

I'm using a MacBook Pro 2019, so intel-based
running BigSur 11.2.3 version
I use rEFInd as bootloader (should I use it? can I just use the Mac base bootloader?)

I read online that it's hard to install linux on late MBP 2016 and onwards, now I would like to know if I'm doing something wrong or if it isn't already possible to do it.

on this wiki: , it says that I need to edit " boot options in /boot/refind_linux.conf and add initrd=boot\cpu_manufacturer-ucode.img ".
I look for refind_linux.conf file but I can't find a file with the same name, just similar.

Last edited by Gio200023 (2021-04-29 13:23:45)


#2 2021-09-29 03:16:37

Registered: 2021-09-27
Posts: 2

Re: [SOLVED]Installing Arch Linux on MacbookPro 2019: freeze after bootctl

That freeze is probably bootctl writing to nvram, which the t2 chip doesn't like. You can use --no-variables to prevent bootctl touching nvram. You might also want to take a look at


Board footer

Powered by FluxBB