You are not logged in.

#1 2021-04-27 17:03:20

amatika
Member
Registered: 2016-03-17
Posts: 52

Huawei USB-C audio adapter not working

Huawei USB-C to 3.5mm headphone jack adapter does not work out of the box, but the sound just comes from the computer speakers.
https://www.giztop.com/official-huawei- … cable.html

What can I do to make it work?


XPS 9350 13.3" FHD | i5-6200U | 8GB | 256GB

Offline

#2 2021-04-27 17:24:56

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,344

Re: Huawei USB-C audio adapter not working

Have you selected it as your audio output?


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2021-04-27 18:13:08

amatika
Member
Registered: 2016-03-17
Posts: 52

Re: Huawei USB-C audio adapter not working

I cannot select anything, at least in GUI, but "Speakers Built-in audio".

Screenshot-from-2021-04-27-20-51-501.png


XPS 9350 13.3" FHD | i5-6200U | 8GB | 256GB

Offline

#4 2021-04-29 22:13:00

possessedbysatan
Member
Registered: 2018-01-11
Posts: 9

Re: Huawei USB-C audio adapter not working

Some dmesg output would be useful to debug this.

My best guess is that it's a passive audio adapter. Passive adapters mostly never work on laptops/desktop PCs, since their USB-C ports lack the necessary circuitry, and thus won't ever show in dmesg. If it does show up in dmesg then it's probably unsupported or maybe it's gnome messing things up. In this case you could use alsamixer and manually change your output.

Offline

#5 2021-05-02 12:27:48

amatika
Member
Registered: 2016-03-17
Posts: 52

Re: Huawei USB-C audio adapter not working

Indeed dmesg is not giving any output when plugging the adapter in. Thank you for your reply, learned something new.


XPS 9350 13.3" FHD | i5-6200U | 8GB | 256GB

Offline

Board footer

Powered by FluxBB