You are not logged in.

#1 2021-05-01 08:56:24

WildCat
Member
Registered: 2021-05-01
Posts: 2

OpenGL rendering incomplete surfaces after Arch update April 2021

I am working on a Dell Optiplex 7010 with Intel Core i5 vPro running 64 bit Arch linux. I did a regular -Syyu OS update to version 5.11.9-arch1-1 recently (April 2021) and noticed that anything that uses OpenGL shows incomplete filling of surfaces such that you get multiple 'see through' triangles and rectangles. This picture illustrates the problem:

https://i.stack.imgur.com/W4wbq.png

Here is what i have tried so far:

1. Looking at different software to see if it was an issue with a particular package rather than OpenGL itself. Result: This is not limited to the X-Screen saver or any particular software package - the same corruption occurs in Cura and FreeCAD.
2. As per the Arch Wiki OpenGL page, I tried manually overriding the mesa loader driver using 'export MESA_LOADER_DRIVER_OVERRIDE=<various options here>' but none of the available drivers made a difference to the problem.
3. I checked my graphics card status. Result:

$ sudo lspci -vnn | grep VGA -A 12
 00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09) (prog-if 00 [VGA controller])

    DeviceName:  Onboard IGD
    Subsystem: Dell Device [1028:0577]
    Flags: bus master, fast devsel, latency 0, IRQ 30
    Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915
    Kernel modules: i915

4. I checked my OpenGL status. Result:

$ sudo glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 2500 (IVB GT1)
OpenGL core profile version string: 4.2 (Core Profile) Mesa 20.3.4
OpenGL core profile shading language version string: 4.20
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 20.3.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string:
OpenGL ES 3.0 Mesa 20.3.4
OpenGL ES profile shading language version string:
OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

5.  I also checked the pacman log to see what packages were changed or added in the last -Syyu update. I found the following which I thought might have something to do with the OpenGL graphics rendering (I could post the whole log if anyone requests it, in case i missed something relevant in my selection):

installed box2d (2.4.1-1)
installed gts (0.7.6.121130-2)
upgraded intel-media-driver (20.4.5-1 -> 21.1.2-1)
upgraded glslang (11.1.0-1 -> 11.2.0-3)
upgraded gegl (0.4.26-1 -> 0.4.28-2)
upgraded gd (2.3.0-1 -> 2.3.2-2)
upgraded mesa (20.3.3-1 -> 20.3.4-3)

So I downgraded the packages that were upgraded (one-by-one, rebooting after each, until all were downgraded) and uninstalled the newly installed packages with pacman -Rsc. Unfortunately none of this fixed the issue.

Everything was working fine before the system update. I can't see an error or anything to fix in the above. Has anyone else had this issue? Any help in troubleshooting appreciated.
[PS. This is my first post on Arch forums so I apologise if my formatting or style is off the norm. Even though I have been using Arch for 3 years, I have always been able to solve issues that have arisen - till now]


Mod Edit - Replaced oversized image with link.
CoC - Pasting pictures and code

Last edited by Slithery (2021-05-01 11:18:07)

Offline

#2 2021-05-01 10:44:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 12,698

Re: OpenGL rendering incomplete surfaces after Arch update April 2021

Have you tried downgrading the kernel yet? Ivybridge is in the lines of GPUs that got hit with a few mitigations, maybe try to boot with the

i915.mitigations=off

kernel parameter

Offline

#3 2021-05-01 10:48:04

Morn
Member
Registered: 2012-09-02
Posts: 740

Re: OpenGL rendering incomplete surfaces after Arch update April 2021

Why are you upgrading to mesa 20.3.x? The latest repo version is 21.0.3.

Maybe you are using a download mirror that is out of sync?

Offline

#4 2021-05-01 14:28:30

WildCat
Member
Registered: 2021-05-01
Posts: 2

Re: OpenGL rendering incomplete surfaces after Arch update April 2021

Thanks to both V1del and Morn - it turned out you were both right but only the i915.mitigations=off fixed the problem.
The mirror I was using was 'stuck' for some reason - when I used a different mirror and did a -Syyu it updated my whole system again, this time with the 21.0.3 mesa. However, the problem persisted.
When I changed the i915 mitigation to 'off' this fixed the problem. Now the OpenGL graphics display normally again. There was no need to downgrade the kernel (thankfully).
Thanks again.

Offline

Board footer

Powered by FluxBB