You are not logged in.

#1 2021-05-04 20:44:58

zettomon
Member
Registered: 2021-05-03
Posts: 4

Giving permissions ain't working!

I have two disks, the first one is SSD with Windows installed so I can play some games. The second one is HDD, and partitioned into two, with one formatted as exFat from Windows' disk part, and the second one is installed with Arch Linux.

During the installation, before generating fstab, I mounted that exFat disk to /data so I can use it from the Linux as well. But now, I wanna store some files and do some stuffs with the data and videos on it (like renaming), the permission got denied when I use it as a user I created, it's okay to just do it with sudo or in root mode, but the files there are only readable for other users although I've given chmod -R 777 to all the files there.

I've noticed this since the time when I git-cloned smth from AUR as a root into the regular user's home directory. Only chmod 1777 worked back then.

Is there something I've missed in this? I've been trying to read that for the whole day, but no luck, I can only find on how to give permissions, and they all seem to work with just 777.

Here (https://i.imgur.com/Vqbqarj.png) is what I did, and all I want is to give full access of the folder "/data" to everyone.

Note: fdisk -l shows the disk as "Microsoft basic data" although it's been formatted as exFat and I can read and write on it as a root.

Offline

#2 2021-05-04 21:06:05

loqs
Member
Registered: 2014-03-06
Posts: 13,291

Re: Giving permissions ain't working!

exFAT does not support user and group permissions.  You can try  the umask  dmask  fmask uid and gid mount options.  See man 8 mount for their details.
Files in a users home directory should be owned by that user.  Executing commands as root commonly changes ownership to root which creates the issue you encountered.
Please do not post images of text.  Avoid using any variant of FAT or NTFS for user home directories because of the permissions issue.
Try mounting an exFAT filesystem with the gid specified and ensure users are members of that gid.

Offline

#3 2021-05-05 11:01:06

zettomon
Member
Registered: 2021-05-03
Posts: 4

Re: Giving permissions ain't working!

Thank you for the reply, I did some reading and found that editing the fmask and dmask of it in fstab file just simply solved it. I'm sorry for the picture of texts.

Last edited by zettomon (2021-05-05 11:06:10)

Offline

#4 2021-05-05 12:06:38

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,590

Re: Giving permissions ain't working!

Please remember to mark your thread [SOLVED] (edit the title of your first post).

Offline

Board footer

Powered by FluxBB