You are not logged in.

#1 2021-05-09 21:17:10

Registered: 2021-05-08
Posts: 8

[SOLVED] "No bootable devices found." After Installation With EFISTUB

Hi, I'm having trouble installing Arch on my Dell Precision T5810 desktop.

I'm using the 5.11.16-arch1-1 installer in UEFI mode. Since I'm using UEFI mode, I'm trying to use an EFISTUB, but am having trouble booting afterwards. I have Secure Boot disabled, and SATA Operation set to AHCI.

My disk is partitioned using gdisk as:

/dev/sda1 1024MiB /boot
/dev/sda2 8GiB swap
/dev/sda3 8GiB /
/dev/sda4 32GiB /usr
/dev/sda5 16GiB /var
/dev/sda6 200GiB /home

gdisk says that the Partition Unique GUID of the EFI System Partition (/dev/sda1) is:

Partition Unique GUID: 7A9A1847-3308-434D-9607-F7539613C7A2

And that the root partition's (/dev/sda3) is:

Partition unique GUID: 177A0F78-670B-4338-A0D6-5F8E459CAE5D

To add the boot entry, I'm running:

efibootmgr -d /dev/sda -p 1 -c -L "Arch Linux" -l /vmlinuz-linux -u 'root=PARTUUID=177A0F78-670B-4338-A0D6-5F8E459CAE5D rw initrd=\initramfs-linux.img' -v

As per the wiki article on EFISTUB, which outputs:

BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0000,0003
Boot0003* UEFI: PLDS DVD+/-RW DH-16AES PciRoot(0x0)/Pci(0,65535,0)/CDROM(1,0x56000,0x86a6)
Boot0000* Arch Linux    HD(1,GPT,7a9a1847-3308-434d-9607-f7539613c7a2,0x800,0x200000)/File(\vmlinuz-linux)root=PARTUUID=177A0F78-670B-4338-A0D6-5F8E459CAE5D rw initrd=\initramfs-linux.img

After rebooting and trying to boot using the new entry, I only get the message:

No bootable devices found.
Press F1 key to retry boot.
Press F2 key to reboot into setup.
Press F5 key to run onboard doagnostics.

I've tried installing Ubuntu Server, and it's able to boot fine. I've also tried installing Debian, but it has the same issue as Arch. Also, both of them were installed with Grub as a bootloader.

I tried looking at the differences in the Ubuntu and Arch boot entry, but can't find any major differences between the two other than the path used. I've also tried different versions of the efibootmgr command I showed above, (backslash instead of forward slash, not using unicode, etc) but nothing has worked so far. I've tried adding the bootloader entry through the BIOS menu, but that doesn't work either.

My guess is that there's issues finding vmlinuz-linux because I'm pretty sure that I've gotten more descriptive errors when there's issues with the arguments (root=PARTUUID=...) when installing on other systems. Note: the files do exist in /boot, so I'm not sure why there would be an issue finding it.

I've been stuck on this for quite a while, but haven't been able to find much information on this, so anything's helpful. Thanks in advance.

Last edited by aspiring_walrus (2021-05-11 02:38:08)


#2 2021-05-11 02:37:03

Registered: 2021-05-08
Posts: 8

Re: [SOLVED] "No bootable devices found." After Installation With EFISTUB

I figured it out!

I moved the files in /boot to /boot/EFI/BOOT, and renamed vmlinuz-linux to BOOTX64.EFI.

mkdir /boot/EFI/BOOT
mv /boot/vmlinuz-linux /boot/EFI/BOOT/BOOTX64.EFI
mv /boot/initramfs-linux.img /boot/EFI/BOOT/initramfs-linux.img
mv /boot/initramfs-linux-fallback.img /boot/EFI/BOOT/initramfs-linux-fallback.img

Then I changed the paths in /etc/mkinitcpio.d/linux.preset and the efibootmgr command in my previous post to use the new file locations, and reran

mkinitcpio -P

and it worked! Glad to finally solve this.

Last edited by aspiring_walrus (2021-05-11 22:20:18)


#3 2021-05-11 04:17:08

Registered: 2012-09-01
Posts: 8,683

Re: [SOLVED] "No bootable devices found." After Installation With EFISTUB

You realize that you're going to have to do that on every kernel update, right?


#4 2021-05-12 08:07:11

Registered: 2021-05-08
Posts: 8

Re: [SOLVED] "No bootable devices found." After Installation With EFISTUB

Yeah, I know. I'm going to look and see if I can use inotify to automate the process. Either way, at least I can boot now.


Board footer

Powered by FluxBB