You are not logged in.

#1 2021-05-12 20:17:24

armin666
Member
Registered: 2021-05-11
Posts: 7

[SOLVED] Arch no inicia al conectar HDD de datos

Hola a todos,

Esta es mi primera incursión en Arch.
La verdad es que me sorprendió la instalación. Me esperaba algo mucho más complicado.
Al hacer la instalación usé un SDD entero y desconecté mi HDD de datos GPT - NTFS, de 3Tb.

El caso es que el sistema arranca y funciona perfectamente, y espectacularmente rápido,... hasta que conecto el segundo disco.
Con el segundo disco conectado, al iniciar, tras el GRUB, arroja este mensaje:

Failed to mount /boot
Dependency failed for local File Systems
Dependency failed for /boot/efi

Si conecto el disco en caliente, lo reconoce y funciona.

He publicado un post en lis foros de Arch en inglés, pero no me aclaro con la única respuesta, algo vaga. Hablan de "Persistent block device naming", pero he buscado y probado varias cosas y no hay manera.
¿Alguien puede echarme un cable, pf?

Gracias!

Last edited by armin666 (2021-05-19 20:38:46)

Offline

#2 2021-05-12 21:28:49

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 201

Re: [SOLVED] Arch no inicia al conectar HDD de datos

¿Qué tienes en /etc/fstab ?
¿Qué entorno de escritorio usas? (Gnome, KDE, etc)

Offline

#3 2021-05-13 02:47:28

armin666
Member
Registered: 2021-05-11
Posts: 7

Re: [SOLVED] Arch no inicia al conectar HDD de datos

Gracias icar !

Uso KDE Plasma.
El PC tiene un SSD de 256Gb para Arch y un HDD de 3Tb en GPT NTFS para datos.

Mi fstab, con el HDD de datos conectado en caliente:

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# UUID=18971116-5527-45f8-8a4b-e96d25d30ec8
/dev/sda2               /               ext4            rw,relatime     0 1

# UUID=DA46-F29C
/dev/sda1               /boot           vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro   0 2

# UUID=DA46-F29C
/dev/sda1               /boot/efi       vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro   0 2

# UUID=687bcf83-cfe4-4eba-820a-44b94171943a
/dev/sda3               /home           ext4            rw,relatime     0 2

Last edited by armin666 (2021-05-13 03:35:25)

Offline

#4 2021-05-14 22:02:52

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 201

Re: [SOLVED] Arch no inicia al conectar HDD de datos

armin, un par de cosas:

  • Utiliza el UUID para los discos a montar, ya que los nombres podrían cambiar entre reinicios del ordenador. Seguramente al instalar Arch has usado genfstab sin la opción -U.

  • El fichero fstab normalmente se usa para dispositivos que siempre estan conectados en el ordenador. De todas maneras, hay la opción de de usarlo para montar el disco duro, en tu caso, de datos si existe. Para eso, una vez hecho el cambio a UUID, usa el nofail tal como se explica aquí: https://wiki.archlinux.org/title/Fstab#External_devices

Offline

#5 2021-05-15 06:34:13

armin666
Member
Registered: 2021-05-11
Posts: 7

Re: [SOLVED] Arch no inicia al conectar HDD de datos

icar wrote:

armin, un par de cosas:

  • Utiliza el UUID para los discos a montar, ya que los nombres podrían cambiar entre reinicios del ordenador. Seguramente al instalar Arch has usado genfstab sin la opción -U.

  • El fichero fstab normalmente se usa para dispositivos que siempre estan conectados en el ordenador. De todas maneras, hay la opción de de usarlo para montar el disco duro, en tu caso, de datos si existe. Para eso, una vez hecho el cambio a UUID, usa el nofail tal como se explica aquí: https://wiki.archlinux.org/title/Fstab#External_devices

Gracias por las pistas. Con tanta cónsola, posiblemente se me pasara por alto el -U.... :S
Un inciso, antes, porque creo que no me he explicado bien: Es un HDD interno, que está siempre conectado. Solo lo desconecté por precaución, como hago siempre que instalo un sistema nuevo.

A ver si mañana temgo un rato y puedo mirar de hacer el cambio a UUID.

Ya postearé el resultado.
Lo dicho, gracias por tu interés. smile

Saludos !

Offline

#6 2021-05-15 10:04:59

icar
Member
From: Catalunya
Registered: 2020-07-31
Posts: 201

Re: [SOLVED] Arch no inicia al conectar HDD de datos

Pues si es interno, haz lo siguiente:

1) Conecta todos los discos que van a estar siempre conectados.
2) Usa "genfstab -U /" en consola
3) Compara con el fichero /etc/fstab y si todo lo que aparece es correcto, usa el mismo comando en (2) pero redirigido a fstab (> /etc/fstab).

Siempre puedes hacer una copia de fichero actual si te da miedo perderlo.

Lo que ha pasado aquí es que genfstab te ha generado el fichero, pero lo genera solo de los volúmenes montados en el momento. Y claro, tú tenías el disco duro desconectado.

Last edited by icar (2021-05-15 10:05:50)

Offline

#7 2021-05-17 05:19:22

armin666
Member
Registered: 2021-05-11
Posts: 7

Re: [SOLVED] Arch no inicia al conectar HDD de datos

Ha funcionado. Gracias icar !!

Offline

#8 2021-05-17 13:38:57

philo
Member
Registered: 2015-01-26
Posts: 155

Re: [SOLVED] Arch no inicia al conectar HDD de datos

Márcalo como [SOLVED]

Offline

#9 2021-05-19 20:37:45

armin666
Member
Registered: 2021-05-11
Posts: 7

Re: [SOLVED] Arch no inicia al conectar HDD de datos

Hecho, gracias por todo !

Offline

Board footer

Powered by FluxBB