You are not logged in.

#1 2021-05-13 03:55:23

fubarhouse
Member
Registered: 2020-02-26
Posts: 11

Kernel Parameters appear to be ignored

In trying to set `systemd.unified_cgroup_hierachy=0` via `/etc/default/grub` and `grub-mkconfig -o /boot/grub/grub.cfg`, it doesn't appear to be following through. I have two process I can use to test that cgroupv2 is not in use... Before I undertook a reinstallation of Arch over the weekend this was working.

Can somebody tell me what I'm doing wrong here?

```
~ $ cat /etc/default/grub
# GRUB boot loader configuration

GRUB_DEFAULT="0"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet systemd.unified_cgroup_hierachy=0"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK="y"

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE="menu"

# Uncomment to use basic console
GRUB_TERMINAL_INPUT="console"

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="auto"

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX="keep"

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT="true"

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU="y"
```

Last edited by fubarhouse (2021-05-13 04:08:32)

Offline

#2 2021-05-13 04:11:00

tsweet64
Member
Registered: 2021-04-29
Posts: 9

Re: Kernel Parameters appear to be ignored

Are you sure your EFI partition is mounted on /boot? Double check using `lsblk`

Offline

#3 2021-05-13 04:22:30

justm3
Member
Registered: 2019-11-12
Posts: 30

Re: Kernel Parameters appear to be ignored

Check your spelling in

GRUB_CMDLINE_LINUX_DEFAULT=

You are missing an -r- in hiera(r)chy

Offline

#4 2021-05-13 04:34:29

fubarhouse
Member
Registered: 2020-02-26
Posts: 11

Re: Kernel Parameters appear to be ignored

justm3 wrote:

Check your spelling in

GRUB_CMDLINE_LINUX_DEFAULT=

You are missing an -r- in hiera(r)chy

Now I look like a goofball.... happy to be so though - you've saved me a lot of time.

Thank you!! smile

Offline

Board footer

Powered by FluxBB