You are not logged in.

#1 2021-05-17 08:57:52

liudvikas.akelis
Member
Registered: 2020-10-05
Posts: 7

[SOLVED] USB-C video out stopped working after system update

Hi,
after a full system update (from 5.10.16 to 5.12.3 kernel wise) my USB-C Lenovo monitor isn't detected by the system anymore (HDMI port works, for example). Since then I've tried rolling back to 5.10 and 5.11 kernels with no luck. The cable/monitor definitely still works, I can still produce video output to the monitor in the bios splash screen.
Attempting to fix this I reinstalled/experimented with different versions of other packages (evdi, nvidia drivers etc), so I feel I should just start over from square one. What debugging steps should I take?

* Thinkpad P53 with Nvidia Quadro RTX 3000 + Intel integrated (yes, a cursed Optimus system)
* Every relevant nvidia driver loaded (nvidia, nvidia-modeset, nvidia-drm), nvidia version  465.27-6
* The USB-C ports (thunderbolt? Can't be bothered to care) operate as USB ports, monitor still works as a USB hub
* dmesg shows this, which I think can be relevant:

[11544.899211] usb 1-5.3: new full-speed USB device number 15 using xhci_hcd
[11545.015391] usb 1-5.3: not running at top speed; connect to a high speed hub
[11545.024929] usb 1-5.3: New USB device found, idVendor=17ef, idProduct=a362, bcdDevice= 3.00
[11545.024942] usb 1-5.3: New USB device strings: Mfr=17, Product=18, SerialNumber=19
[11545.024948] usb 1-5.3: Product: BillBoard Device
[11545.024952] usb 1-5.3: Manufacturer: Realtek
[11545.024956] usb 1-5.3: SerialNumber: 123456789ABCDEFGH
[11545.966108] usb 1-5.2: new full-speed USB device number 16 using xhci_hcd
[11546.062654] usb 1-5.2: New USB device found, idVendor=04d9, idProduct=a09f, bcdDevice= 2.32
[11546.062668] usb 1-5.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[11546.062674] usb 1-5.2: Product: USB Gaming Mouse
[11546.062678] usb 1-5.2: Manufacturer: E-Signal

From googling, monitors are recognized as Billboard devices when the USB alternate mode negotiation fails; am I missing a package/kernel module that enables this alternate mode?

Last edited by liudvikas.akelis (2021-05-17 17:59:38)

Offline

#2 2021-05-17 14:55:41

jrobsonchase
Member
Registered: 2021-05-17
Posts: 1

Re: [SOLVED] USB-C video out stopped working after system update

I'm having the same issue. I've been putting off updating for some time because last time I tried, this happened.

Previously, I managed to resolve it by rolling back my kernel and nvidia driver (+ the other nvidia packages), but that's not a state I like to be in.

Edit:

Well, managed to resolve it again with another downgrade. This time I did *just* the nvidia packages and not the kernel. You have to use the DKMS version of the driver though.

Package archive links:
https://archive.archlinux.org/packages/ … kg.tar.zst
https://archive.archlinux.org/packages/ … kg.tar.zst

Last edited by jrobsonchase (2021-05-17 15:09:09)

Offline

#3 2021-05-17 17:40:44

liudvikas.akelis
Member
Registered: 2020-10-05
Posts: 7

Re: [SOLVED] USB-C video out stopped working after system update

Well I'm crying tears of madness/relief, because it worked. Can't thank you enough jrobsonchase!
For anyone as inexperienced as me, this is what I did:

sudo pacman -R nvidia nvidia-dkms
sudo pacman -U https://archive.archlinux.org/packages/n/nvidia-utils/nvidia-utils-460.67-1-x86_64.pkg.tar.zst
sudo pacman -U https://archive.archlinux.org/packages/n/nvidia-dkms/nvidia-dkms-460.67-1-x86_64.pkg.tar.zst
sudo pacman -S linux    # just to make sure all required hooks run

As for the bug report, this would go straight to nvidia right?

Offline

#4 2021-06-27 15:07:04

liudvikas.akelis
Member
Registered: 2020-10-05
Posts: 7

Re: [SOLVED] USB-C video out stopped working after system update

To get full functionality (for example, OpenGL acceleration) with downgraded drivers, I had to downgrade a few additional packages as well:

sudo pacman -U https://archive.archlinux.org/packages/l/lib32-nvidia-utils/lib32-nvidia-utils-460.67-1-x86_64.pkg.tar.zst
sudo pacman -U https://archive.archlinux.org/packages/l/libxnvctrl/libxnvctrl-460.67-1-x86_64.pkg.tar.zst
sudo pacman -U https://archive.archlinux.org/packages/n/nvidia-settings/nvidia-settings-460.67-1-x86_64.pkg.tar.zst
sudo pacman -U https://archive.archlinux.org/packages/o/opencl-nvidia/opencl-nvidia-460.67-1-x86_64.pkg.tar.zst

Offline

Board footer

Powered by FluxBB