You are not logged in.

#1 2021-05-22 09:06:33

Shinigami92
Member
From: Germany
Registered: 2020-09-11
Posts: 13
Website

[SOLVED] No sound pass through from Win10 qemu VM to host after update

On 19.05.2021 I updated my system from 5.10.36-1-lts to 5.10.38-1-lts with some other packages
Just a normal pacman -Syu

After this update my qemu windows10 vm doesn't send sound anymore to my host system

So before I had Discord and YouTube running on my arch and Overwatch / Apex running in my VM and had all the sound working in my arch

The Windows 10 VM sound is working! When I use the monitor (via HDMI) as sound, then the sound is working normally
Everything in my arch is also working fine.
But when I select "High Definition Audio Device" in my Win10 previously I had sound in my arch from the VM, but after the system update on 19.05.2021 it's not working anymore

I already tried here and there some solutions but had no luck yet

One solution suggested me to execute "systemctl --user status pulseaudio" and that is telling me someing like this:

May 22 10:44:03 shinigami pulseaudio[23132]: ALSA woke us up to write new data to the device, but there was actually nothing to write.
May 22 10:44:03 shinigami pulseaudio[23132]: Most likely this is a bug in the ALSA driver 'snd_usb_audio'. Please report this issue to the ALSA developers.
May 22 10:44:03 shinigami pulseaudio[23132]: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.

I'm also reading something about checking "/run/user/1000/pulse/native" with "pavucontrol" in playback, but there is nothing about "/run/user/1000/pulse/native"! So I assume there is something broken with "pulseaudio" after the update?!

Please let me know every file and info you need to know to help me and I will attach it in further posts

My current workaround is to pass my headset usb-slot to the VM
But this have two downsides:
1. I have crackling sound
2. I have only the sound of my VM, forcing me to also run Discord and YouTube in my VM

So this is only a temp solution but very annoying sad

Last edited by Shinigami92 (2021-05-23 18:04:35)

Offline

#2 2021-05-22 09:38:05

Shinigami92
Member
From: Germany
Registered: 2020-09-11
Posts: 13
Website

Re: [SOLVED] No sound pass through from Win10 qemu VM to host after update

Additional Info #1: On non-lts kernal "5.12.5.arch1-1" it also doesn't work and the same problem occurs
So I assume it is not directly a bug with the kernal, but an issue with some other dependencies I updated alongside on 19.05.2021

I looked on the ALSA website and the latest release they list was on "2020-10-20". So it could be that the current version has an issue with the latest kernals (plural!, lts and non-lts) but I don't think that this is the issue

Offline

#3 2021-05-23 18:04:11

Shinigami92
Member
From: Germany
Registered: 2020-09-11
Posts: 13
Website

Re: [SOLVED] No sound pass through from Win10 qemu VM to host after update

Solved: Seems it was an update with libvirt and I needed to update my sound configuration
From ICH9 to USB and some other rearrangements

https://wiki.archlinux.org/title/PCI_pa … PulseAudio

Last edited by Shinigami92 (2021-05-23 18:06:09)

Offline

#4 2021-07-23 04:52:30

cinatic
Member
Registered: 2013-01-27
Posts: 13

Re: [SOLVED] No sound pass through from Win10 qemu VM to host after update

Stumbled upon that issue too. It looks like the audiodev settings has been moved out from qemu:args somehow, so it only works for me with the new syntax:

    <sound model='ich9'>
      <codec type='micro'/>
      <audio id='1'/>
    </sound>
    <audio id='1' type='pulseaudio' serverName='/run/user/1000/pulse/native'/>

Offline

Board footer

Powered by FluxBB