You are not logged in.

#1 2021-05-22 13:41:04

chrepechrep
Member
Registered: 2021-03-01
Posts: 26

[SOLVED] dual boot: Problems with dualbooting and btrfs

I have been trying to install debian and arch and have them both use btrfs and after a while i`ve actually managed to get them both running and booting but now new problems came up
Firstly debians grub doesn`t show a arch entry and arch grub shows debian but when selecting it i get :

error: '/boot/vmlinuz-4.19.0-16-amd64' not found
error: you need to load the kernel first

Now i have tried to write a manual entry for debian in grub(arch) but that`s not even close to something i am proficient in and writing one for a btrfs subvolume beats me

Secondly while both distros boot from their own grubs when arch is booting after loading linux linux and initial ramdisk arch goes black screen for a good 2 minutes after which shows me a quick error (image 1) that i managed to take a picture of with my phone (pretty blurry tho) and enters tty1 like nothing happened

Soo I think it`s important to explain how my system is structured:

I have one m.2 drive /dev/sda and a 1T hard /dev/sdb

/dev/sda : /dev/sda1 ->esp ,fat32, mounted on /boot/efi on both distros
                /dev/sda2 ->swap ,shared by the distros
                /dev/sda3

I have made a volumegroup out of sda3 and sdb out of which I made two logical volumes: arch and debian
arch: btrfs with two subvolumes : @ and @home
debian: btrfs with one subvolume: @
On both the distro is installed on @


I would also like to add that the grub I would preffer to use is arch`s as arch is my main distro and debian is only for gns3 and that when installing grub i used "--removable" option as without it grub wouldn`t come up at all

Logs and such(all from arch):
Image1(very blurry sry):   https://www.dropbox.com/s/lqnjn4ehgww7b … 3.jpg?dl=0
dmesg:          https://gist.github.com/SebastianDoroba … dcb733d3dc
journalctl -rb: https://gist.github.com/SebastianDoroba … fb15572567
grub.cfg :       https://gist.github.com/SebastianDoroba … 358e9021b2

Last edited by chrepechrep (2021-05-23 17:21:40)

Offline

#2 2021-05-23 17:21:21

chrepechrep
Member
Registered: 2021-03-01
Posts: 26

Re: [SOLVED] dual boot: Problems with dualbooting and btrfs

Still don`t know how to write grub.cfg .... but debian sure does:))
I just copied from the debian cfg to the arch and it works now, also the boot problems were from the fstab

Offline

Board footer

Powered by FluxBB