You are not logged in.

#1 2021-05-24 15:22:47

Registered: 2021-05-24
Posts: 2

[SOLVED] b43-phy0 error -> no wifi

Hello guys

I am reinstalling my system on my pc with the newest arch linux iso.
Upon start up I'm trying to connect to my wifi, but ip link is not showing any available wifi card, only lo, enp34s0.
I am expecting to see `wlo1`.

The wifi card is of model BCM4352

At first I thought the relevant mod is not loaded, so I checked lsmod | grep b43, but it's loaded.

Then I checked dmesg | grep b43 and saw the following:

b43-phy0 ERROR: FOUND USUPPORTED PHY (Analog 12, Type 11 (AC), Revision 1)
b43: probe of bcma0:1 failed with error -95

I searched around on the net and some people seemed to have had the same issue in the past, for some it works even with the error.
As I don't have internet at all right now, I can't really proceed, I have no device to wire up to give it internet. I can only pass it a USB if I need to install smth specific.

I remember this having worked out of the box in the past, so I am a bit surprised.

Last edited by hasnoidea (2021-05-24 15:45:37)


#2 2021-05-24 15:45:18

Registered: 2021-05-24
Posts: 2

Re: [SOLVED] b43-phy0 error -> no wifi

I finall found a similar problem:

The following steps solved the problem:

$  modprobe -r b43
$  modprobe -r bcma
$  modprobe -r wl
$  modprobe wl


Board footer

Powered by FluxBB