You are not logged in.

#1 2021-05-31 04:35:34

From: New Hampshire USA
Registered: 2018-12-10
Posts: 272

SOLVED Custom ISO script stopped working after archiso & mtools update


1) The mtools (4.0.27-1 -> 1:4.0.28-1) update was the problem. The mtools (4.0.28-1 -> 1:4.0.27-1) downgrade has been posted and my script works again.

2) The efiboot section of archiso has changed. If you are making modifications there you will need to look at the changes.


I have a script that builds a custom ISO using the archiso package and mkarchiso. After the archiso package was updated today I decided to test my script. I got the following error message from mkarchiso:

sudo mkarchiso -v -w /tmp/"${name}" -o "${build}"/out "${build}"

[mkarchiso] INFO: Setting up systemd-boot for UEFI booting...
[mkarchiso] INFO: Creating FAT image of size: 63488 KiB...
mkfs.fat 4.2 (2021-01-31)
Disk full
Disk full
Disk full
::/EFI/BOOT/BOOTx64.EFI: no match for target
Bad target ::/EFI/BOOT/BOOTx64.EFI

I tried switching to the archiso-git package and got the same failure. I then looked at my update logs and found that mtools was also updated today.

pacman update log

[2021-05-30T22:48:30-0400] [ALPM] upgraded shellcheck (0.7.2-23 -> 0.7.2-24)
[2021-05-30T22:48:30-0400] [ALPM] upgraded python-urllib3 (1.26.4-2 -> 1.26.5-1)
[2021-05-30T22:48:30-0400] [ALPM] upgraded pcre2 (10.36-1 -> 10.37-1)
[2021-05-30T22:48:30-0400] [ALPM] upgraded graphviz (2.47.1-2 -> 2.47.2-1)
[2021-05-30T22:48:30-0400] [ALPM] upgraded archiso (54-1 -> 55-1)
[2021-05-30T22:48:30-0400] [ALPM] upgraded file (5.40-3 -> 5.40-5)
[2021-05-30T22:48:30-0400] [ALPM] upgraded libcap (2.49-1 -> 2.50-1)
[2021-05-30T22:48:30-0400] [ALPM] upgraded mtools (4.0.27-1 -> 4.0.28-1)         <--- possible culprit?

Looks to me like mtools is a possible culprit but I am not sure how to troubleshoot this one.

Last edited by lenhuppe (2021-05-31 12:45:11)

Why do we drive on the parkway and then park in the driveway?


#2 2021-05-31 09:11:15

The Evil Wiki Admin
Registered: 2016-07-02
Posts: 595

Re: SOLVED Custom ISO script stopped working after archiso & mtools update

The culprit is indeed mtools 4.0.28-1. See .


Board footer

Powered by FluxBB