You are not logged in.

#1 2021-06-01 09:45:12

vavra.7
Member
Registered: 2021-05-22
Posts: 4

Gnome software store stopped working

Hi all, I am currently experiencing that Gnome Software app stopped showing any apps to install.  There are only listed previously installed apps but nothing to install.

I have properly installed

gnome-software-packagekit-plugin

and

archlinux-appstream-data

.

My humble guess is that it could has something to do with upgrading pacman to version 6. Any help on this?

Offline

#2 2021-06-01 09:56:03

GeorgeJP
Member
From: Czech Republic
Registered: 2020-01-28
Posts: 93

Re: Gnome software store stopped working

I have same issue with packagekit on KDE.
After update to pacman 6 packagekit service is code-dumped if ParallelDownloads option is enabled in pacman.conf.
If Parallel downloads are disabled, it works.

Offline

#3 2021-06-01 10:30:25

vavra.7
Member
Registered: 2021-05-22
Posts: 4

Re: Gnome software store stopped working

I altered respective line in pacman.conf to ParallelDownloads = 0 but it didn't take any effect. Anyway what if I don't want do disable parallel downloads? This seems to be much more workaround than solution.

Offline

#4 2021-06-01 11:28:06

GeorgeJP
Member
From: Czech Republic
Registered: 2020-01-28
Posts: 93

Re: Gnome software store stopped working

Message from log is:

packagekitd[1218]: Failed to initialize alpm: using /etc/PackageKit/alpm.d/pacman.conf: /etc/PackageKit/alpm.d/pacman.conf:8/etc/pacman.conf:37unrecognised directive 'ParallelDownloads'

so you must disable it with '#'

#ParallelDownloads = 5

It's just workaround until packagekit will be corrected ...

Last edited by GeorgeJP (2021-06-01 11:28:42)

Offline

#5 2021-06-01 12:30:54

pranavjerry
Member
Registered: 2021-06-01
Posts: 3

Re: Gnome software store stopped working

PackageKit probably does not support ParallelDownloads in pacman.conf. I found a way to stop the coredump by without commenting out ParallelDownloads
in pacman.conf.

PackageKit has its own config in /etc/PackageKit/alpm.d/pacman.conf, where it sources /etc/pacman.conf:

Include = /etc/pacman.conf

You can copy /etc/pacman.conf to another file, say pacman-pk.conf and comment out ParallelDownloads in the new file.
Now replace

Include = /etc/pacman.conf

in /etc/PackageKit/alpm.d/pacman.conf with

Include = /etc/pacman-pk.conf

Now you have two files /etc/pacman.conf and /etc/pacman-pk.conf, with the former having ParallelDownloads enabled.
So pacman will use ParallelDownloads while packagekit will not.

If GNOME Software is open, close it and stop packagekit.service:

sudo systemctl stop packagekit.service

Now open GNOME Software again and it will run without showing any errors.
Having two separate configs might cause some problems, like if you change one file and forget to change the other one, or something like that.

Source:
https://bbs.archlinux.org/viewtopic.php?id=261467
https://bbs.archlinux.org/viewtopic.php?id=118936

EDIT: Doing this will only stop packagekit from exiting with coredump. For some reason I still can't install or find packages via GNOME software or pkcon. Trying

pkcon install fortune-mod

shows an error:

Command failed: This tool could not find any available package: No packages were found

Another edit: After a packagekit update, this solution works!

Last edited by pranavjerry (2021-06-02 04:54:32)

Offline

#6 2021-06-02 15:45:02

pranavjerry
Member
Registered: 2021-06-01
Posts: 3

Re: Gnome software store stopped working

After a new packagekit update, things are back to normal (atleast for now) and packagekit doesn't crash now when ParallelDownloads is set.

So don't change /etc/PackageKit/alpm.d/pacman.conf or any other files like my previous post said.

Offline

Board footer

Powered by FluxBB