You are not logged in.

#1 2021-06-07 12:02:22

Thirsk
Member
Registered: 2021-06-07
Posts: 4

[SOLVED]Problem alsa-lib (1.2.5-2) breaks the dependency when upgrade.

Good afternoon, after three days I have this error when updating with the yay command and I don't know how to solve it.. any ideas? Thanks!

solving dependencies ...
looking for conflicts between packages ...

error: could not prepare operation (could not satisfy dependencies)
:: installing alsa-lib (1.2.5-2) breaks the dependency with "alsa-lib = 1.2.4", necessary for the lib32-alsa-lib package

Last edited by Thirsk (2021-06-10 09:36:21)

Offline

#2 2021-06-07 12:19:23

StJimmy
Member
From: De Lage Landen
Registered: 2020-02-26
Posts: 55

Re: [SOLVED]Problem alsa-lib (1.2.5-2) breaks the dependency when upgrade.

If I query the lib32-alsa-lib package with pacman -Si lib32-alsa-lib, it shows that it depends on alsa-lib=1.2.5.
Did you disable multilib (by accident or on purpose), but not uninstall the packages installed from that repository?

Please check (and preferably post, in [ code ] tags without the spaces) your /etc/pacman.conf.


If it ain't broke, don't ask Allan to fix it.
If it is broke, don't ask Allan to fix it either.

Offline

#3 2021-06-08 06:11:49

essence-of-foo
Member
Registered: 2008-07-12
Posts: 71

Re: [SOLVED]Problem alsa-lib (1.2.5-2) breaks the dependency when upgrade.

On my system I have this: dependency chain

 alsa-lib=1.2.4 <- lib32-alsa-lib <- lib32-alsa-plugins <- steam

And I have the same problem. The package  lib32-alsa-lib specifically wants version 1.2.4 of alsa-lib and that is why it is not possible to upgrade to 1.2.5.
The big question is now: Does this pinned version make sense? Or will it break steam whe we force an upgrade?

Edit: I created a ticket.

Edit: StJimmy made a good suggestion: Multilib was disabled on my system and I don't remember disabling it. I'm looking into how to proceed from here.

Last edited by essence-of-foo (2021-06-08 06:51:40)

Offline

#4 2021-06-08 06:55:21

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,320
Website

Re: [SOLVED]Problem alsa-lib (1.2.5-2) breaks the dependency when upgrade.

lib32-alsa-lib was updated to 1.2.5 three days ago: https://archlinux.org/packages/multilib … -alsa-lib/

Either you have an outdated mirror, or you disabled the multilib repo after installing packages from it, leading to a partial upgrade.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2021-06-08 09:05:33

StJimmy
Member
From: De Lage Landen
Registered: 2020-02-26
Posts: 55

Re: [SOLVED]Problem alsa-lib (1.2.5-2) breaks the dependency when upgrade.

essence-of-foo wrote:

(...)
Edit: StJimmy made a good suggestion: Multilib was disabled on my system and I don't remember disabling it. I'm looking into how to proceed from here.

As WorMzy said as well, this has (accidentally) caused you to do an (inadvertent) partial upgrade. Re-enable the multilib repo, and re-run pacman -Syu to make sure everything gets updated properly.

Would that yield no results (i.e. said dependency conflict is still not resolved), then try picking a different mirror, as it may just be that your preferred mirror hasn't fully/properly synced yet.


If it ain't broke, don't ask Allan to fix it.
If it is broke, don't ask Allan to fix it either.

Offline

#6 2021-06-10 09:35:34

Thirsk
Member
Registered: 2021-06-07
Posts: 4

Re: [SOLVED]Problem alsa-lib (1.2.5-2) breaks the dependency when upgrade.

I check the pacman.conf and multilib was disabled, now it works!

Thanks

Offline

Board footer

Powered by FluxBB