You are not logged in.

#1 2021-06-09 13:47:06

eearcher
Member
Registered: 2021-01-08
Posts: 15

[SOLVED] 3DConnexion SpaceExplorer with spacenavd not working

I have a 3D mouse, an older model of a USB SpaceExplorer mouse. I'm trying to use it with spacenavd. According to http://spacenav.sourceforge.net/ all USB mice should be supported. As suggested by the Wiki (https://wiki.archlinux.org/title/3D_Mouse), I ran

sudo spacenavd -v -d

but there is no output like it is shown in the Wiki, it just doesn't show anything. However, the daemon is running and the LED of the 3D mouse lights up as soon as I start it. I can control the LED with the spnavcfg GUI utility, this tool also says that "the daemon is running fine".

The log file in /var/log/spnavd.log has no content, the config file in /etc/spnavrc is in default state.

I would expect that I can use the SpaceExplorer as a pointing device, but this is not the case. Ultimately I want to use it with FreeCAD, which currently does not detect any 3D mice when I start it.

My window manager is dwm.

Any ideas? How can I "test" the 3D mouse and ultimately make FreeCAD recognise it?

Cheers

Last edited by eearcher (2021-06-10 10:33:24)

Offline

#2 2021-06-10 10:33:07

eearcher
Member
Registered: 2021-01-08
Posts: 15

Re: [SOLVED] 3DConnexion SpaceExplorer with spacenavd not working

Ok so I got it working.

The fix was quite easy, I just used

sudo cp ~/.Xauthority /root/
sudo spnavd_ctl x11 start
sudo systemctl restart spacenavd

as suggested here: https://wiki.freecadweb.org/3Dconnexion_input_devices

With this the log file seems good:

Spacenav daemon 0b3f9c8
reading config file: /etc/spnavrc
unrecognized config option: List
adding device.
device name: 3Dconnexion SpaceExplorer
using device: 3Dconnexion SpaceExplorer (/dev/input/event13)

Note that the "unrecognized config option" error seems to come from the fact that in the default config file there is a '#' missing, so a line is not commented out. This can either be fixed or just left as is, it seems to have no effect.

With this, I could successfully try out the examples from here: https://github.com/FreeSpacenav/libspna … r/examples. They also have a minimal example that just spits out the raw values; great if you're looking for a way of testing your space mouse.

I couldn't get it to work with the flatpak version of FreeCAD (granted appropriate permissions with Flatseal), but it works just fine with the community package "freecad". I will just use the package version from now on.

Cheers

Last edited by eearcher (2021-06-10 10:38:45)

Offline

Board footer

Powered by FluxBB